Solved

Error Type: Provider (0x80004005) ???

Posted on 2001-09-16
36
14,372 Views
Last Modified: 2013-12-24
I have followed the first tutorial of Dreamweaver Ultra Dev 4. Once I preview( View the Result page from Search page(Searches for Department)) it it shows the result but if I go back abd preview it again it gives the same error:

Error Type:
Provider (0x80004005)
Unspecified error
/MyTutorialSite/Results.asp, line 10

Once I close DWUD and open again it works again , but some time no why ??? but when ever it works, it works only once???
0
Comment
Question by:fmufti
  • 18
  • 13
  • 3
  • +2
36 Comments
 
LVL 15

Expert Comment

by:ericpete
ID: 6486322
Open results.asp in a text editor, and make sure your word wrap is off. Count down ten lines, and copy and paste the error here.

What's probably happening is that your search function is filtering the recordset, so when you go back, it tries to "refilter" it, rather than conducting a new search and filter... but to be certain, I'd have to know what that one line says.
0
 

Author Comment

by:fmufti
ID: 6487216
Last night it was an error but today without any single modification its working fine. I'll check it again in the evening, if problem comes or not I'll reply accordingly. Strange!!!
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6487827
Another possibility is that you didn't have your server software running...
0
 

Author Comment

by:fmufti
ID: 6488567
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] Could not use '(unknown)'; file already in use.
/MyTutorialSite/Results.asp, line 10

Line 10 is
Results.ActiveConnection = MM_connCompass_STRING
I have done this as well "
Edit the Account used for Anonymous Access.
In IIS 4.0, clear the Enable Automatic Password Synchronization check box.
In IIS 5.0, clear the Allow IIS to control password check box"
As instrcuted by microsft KB so what to do
0
 

Author Comment

by:fmufti
ID: 6488573
Error is now changed as I have mentioned above ???
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6488589
What's the new error?
0
 

Author Comment

by:fmufti
ID: 6488627
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] Could not use '(unknown)'; file already in use.
/MyTutorialSite/Results.asp, line 10

Line 10 is
Results.ActiveConnection = MM_connCompass_STRING
I have done this as well "
Edit the Account used for Anonymous Access.
In IIS 4.0, clear the Enable Automatic Password Synchronization check box.
In IIS 5.0, clear the Allow IIS to control password check box"
As instrcuted by microsft KB so what to do
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6488641
Make sure you have the permissions set on your database folder such that anyone can see it. You've allowed anyone to see the PAGES, but not the database...
0
 

Author Comment

by:fmufti
ID: 6488716
My data base is in one of the folder in my local machine and its available, My server is the same on which IIS is there and I am developing the web on same Machine and Databse is also on the same machine???
0
 

Author Comment

by:fmufti
ID: 6488724
Since my machine at home( on which I am working doesnt have NIC ) so its not DNS. However win2000 Adv server is installed and its perfectly OK. I'll be glad if u can see the tutorial and try to run the specific tutorial may be u also come across the same problem!!
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6488772
I'd like to help, but I don't think that's your problem. If you can see the administrative pages of the web server, then the problem is more likely in your permissions.
0
 

Author Comment

by:fmufti
ID: 6489352
my http://localhost/default.htm is working perfectly fine even the websites( made in html) that I published on this server works fine. I mentioned the above scenario becuase at time experts ask for such detail so that they can have better understanding of my problem.
This problem seems very common

(Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] Could not use '(unknown)'; file already in use.
/MyTutorialSite/Results.asp, line 10

as so many people have been asking about it.  I hope u being the top expert in UD can help me.
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6490894
I'm not certain I've been clear, but there are usually only a few things that can cause 80004005 errors. The most common is that while the IIS can find the pages, it can't find the database because of a permissions issue. That can be solved by creating a folder under the folder containing the pages and moving the database there. It can also be solved by using a DSN that has a username and password associated with it, and then including the username and password when you connect to the database. If you're using the basic authorization scheme, then the IUSR_COMPUTERNAME user has to have read/write (and usually execute) access to both the IIS folders AND the folder in which the database resides.

The second most common reason is because your MDAC isn't up to date; you should be upgrade to at least MDAC version 2.1; 2.5 is even better. You can get the latest version from Microsoft's website.

The third has to do with Access; make sure there are no lingering .ldb files on your server, and make sure Access isn't open when you're testing your system.

To be more specific, or to give specific things to check, I'd need to know the operating systems on both your development computer and your server.
0
 

Author Comment

by:fmufti
ID: 6491692
I have Microsoft Windows 2000 Advance Server SP-2, IIS 5.0
Microsoft Office XP 2002
Access is not opened, during this process. If I close Ultra deve and restart at times it func normally and after some tries it stat giving the error, but not always,
I am using basic authentiaction scheme
Since I have Office XP so MDAC is latest.
I have even placed the databse file in \intpub\wwwroot\mysite\Database but no effect
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6491807
I'll do some more research... but I'm NOT an expert in Windows2K server -- we use NT4 around here, and we've declined to upgrade to XP... but let me see what I can find...
0
 

Expert Comment

by:usmanbuxi
ID: 6492366
Please check the following link
http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q166029


since last night i'm getting the same error

cheers(r u happy)
0
 

Expert Comment

by:usmanbuxi
ID: 6492376
do check this one also
http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q174943


after checking the above link go to

http://www.macromedia.com/support/ultradev/


and check under this heading of COmmon server errors

ODBC error 80004005 with Live Data, Preview in Browser or direct browsing of file on Windows 2000 system.

0
 

Author Comment

by:fmufti
ID: 6492448
I am talking of Office XP and not Windows XP
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 

Author Comment

by:fmufti
ID: 6492462
usmanbuxi I am afraid that I have already seen these pages as far as IUS... User permissions are concerned how can they be enhanced might be the key issue!???.
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6493636
Office XP isn't an issue. The issue is certainly one of permissions.

The first article usmanbuxi mentions (http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q174943) is an EXACT description of what your error message is (and is also exactly what I said your problem was right off the bat). The link to Macromedia's site (specifically Tech Note 14753) more or less repeats the Microsoft article, and even includes a link to the Microsoft article.

Your problem is with how your permissions are set: "The account that is accessing the page doesn't have sufficient permissions to lock the database. The account would be either the anonymous account (by default the IUSR_<machinename>) or a specific user account if the page has been secured for authenticated access."

To save you re-reading the Microsoft article, here's what it says to do to resolve the issue:

"If the page is meant to be accessed anonymously, give the IUSR_<machinename> account full control to the ASP page, and the folder and files where the database is located. Additionally, if the path to the database is being referenced using UNC (\\Server\Share), ensure that the Share Permissions allow the IUSR_<machinename> account full access. This step applies even if the share is on the local Web server.

"If the page has been secured such that the IUSR_<machinename> can't access the file or database, then ensure that the user's account that is being authenticated has full control to the appropriate folders and files.

"At a minimum, the account being used needs Create, Destroy, Read, Write to work with the .ldb file. Specific permission can be applied to the database to limit access."

Additionally, they offer this advice... which is NOT meant to be a permanent solution:

"A quick way of ensuring any particular error is a permissions issue is to add the IUSR_<machinename> account to the Administrators group. If this fixes the error, then it is a matter of ensuring that the user account being used has sufficient permissions. Ensure that you remove the IUSR_<machinename> account from the Administrators group when finished testing."
0
 

Expert Comment

by:usmanbuxi
ID: 6495576
I have figured it out
just follow these steps..
1. Go to IIS security/permissions tab and deselect the option for anonymous access for your access database..and select it for basic win2k authentication.

2. come back to ultradev and edit your DSN again by clicking the define/edit button

3. don't leave the user and password fields blank..give the administrator name and password for these fields..

4. shut everything down and restart the IIS..it would work fine...

cheers


0
 

Author Comment

by:fmufti
ID: 6496135
Nop it dit not!
0
 

Author Comment

by:fmufti
ID: 6496142
Well I have found the solution my self, In IIS instead of IUS_server.. Use Administrator and password in anonymous,
As even giving IUS_ .... Administrative rights did solve the problem then in UD instead of Local DSN use DSN on Application server, if u dont use Administrator in IIS in Anonymous u'll not be able to make connecion in UD!!!
Why this is so I dont know but this how my system has stared to work!!!
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6496817
The reason is that your DSN needs to be a system DSN; when you use a User DSN, only the local machine can see it. That's one of the first things they tell you in the UltraDev materials.

And you'll also note that the suggestion was made several times that you had a permissions issue; indeed, as you said, giving the IUSR_... administrative (read/write/execute) rights solved the problem.

If you wish to get your points refunded, you can do so by leaving a zero-point question in the Community Support area referring to this question by number, and explaining that you've solved the problem yourself, and asking that the question be moved to the PAQ.

The link to Community Support is: http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt

Regards,
ep
0
 

Author Comment

by:fmufti
ID: 6496916
Please read through my comment infact it was a typing mistake I wanted to say this

1. IUSR_... administrative (read/write/execute) rights DID NOT solve the problem"
as the line above clearly says "... In IIS instead of IUS_server.. Use Administrator and password
in anonymous..."

Even inluding IUS_sever..in Administrative group HAS NO EFFECT so
USE Administrator account and password in anonymous at all cost!

2. "DSN on Application server within UD " I am not talking of system DSN  on ODBC in Control Panel/Administrative Tool


Sorry for typing error for first part but second one has now been elaborated !
0
 

Author Comment

by:fmufti
ID: 6496922
Hope no objection on meto delete it as I have further clarified my point!
0
 

Author Comment

by:fmufti
ID: 6496923
Please read through my comment infact it was a typing mistake I wanted to say this

1. IUSR_... administrative (read/write/execute) rights DID NOT solve the problem"
as the line above clearly says "... In IIS instead of IUS_server.. Use Administrator and password
in anonymous..."

Even inluding IUS_sever..in Administrative group HAS NO EFFECT so
USE Administrator account and password in anonymous at all cost!

2. "DSN on Application server within UD " I am not talking of system DSN  on ODBC in Control Panel/Administrative Tool


Sorry for typing error for first part but second one has now been elaborated !
0
 

Author Comment

by:fmufti
ID: 6496927
Hope no objection on meto delete it as I have further clarified my point!
0
 

Author Comment

by:fmufti
ID: 6496932
Hope no objection on meto delete it as I have further clarified my point!
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6496964
*whispering*... don't hit the refresh button...

I do object to trying to delete. I don't object to your asking for your points back.
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6496967
*whispering*... don't hit the refresh button...

I do object to trying to delete. I don't object to your asking for your points back.
0
 

Author Comment

by:fmufti
ID: 6497051
How can I get the points back without deleting ????
0
 
LVL 15

Expert Comment

by:ericpete
ID: 6497083
*copying and pasting*

If you wish to get your points refunded, you can do so by leaving a zero-point question in the Community Support area referring to this question by number, and explaining that you've solved the problem yourself, and asking that the question be moved to the PAQ.

The link to Community Support is: http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt

Regards,
ep
0
 

Accepted Solution

by:
ComTech earned 0 total points
ID: 6497301
fmufti has requested a deletion of this question as he has solved the problem himself.  

I will not delete, but instead PAQ the information here and refund the points.

Thank you,
ComTech
Community Support Moderator
0
 

Expert Comment

by:yunusp
ID: 12239789
using a connection string with the following solved the probem for me:

MM_opentext_STRING = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=C:\Inetpub\wwwroot\test\db\opentext.mdb"

I was using the following connection string when i got this error:

MM_opentext_STRING = "DRIVER={Microsoft Access Driver (*.mdb)}; DBQ=C:\Inetpub\wwwroot\test\db\opentext.mdb"
0
 
LVL 15

Expert Comment

by:ericpete
ID: 12239888
yunusp,

Yours was a slightly different problem; his was a permissions issue, while yours was one of using the correct driver. It's been a while, but as I recall, it will return the same error.

Actually, the best description of both the problem and the solution was in the old Drumbeat2000 documentation, but Macromedia took their stuff down when they stopped supporting it. I might have it around somewhere; if I do, I'll post it on a website and post it here.

ep
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

When deciding to adopt any help desk solutions many factors should be explored before taking decisions. This will change from business to another but in general there are some kind of rule of thumb. Here are some quick tips: Do we need only ticket…
Introduction In this tutorial, I'll explain how to create an animated progress meter in a wireframe prototype developed using Axure RP 7.0 - a leading prototyping tool for designing web sites and software. (For more information about Axure and gett…
The purpose of this video is to demonstrate how to add AdSense Ads to a WordPress Website, and how to set up WordPress to automatically place Ads in Sidebars. This will be demonstrated using a Windows 8 PC. Log into your AdSense account. : Cli…
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now