DNS Caching on W2K Pro-Workstation

I performed the following test:

- assigned to IP-Adress 18.1.105.10 the DNS alias "alias1"
- ping to alias responds with IP: 18.1.105.10

- assigned alias1 to IP-adress 18.1.105.12
- ping to alias1 responds with IP 18.1.105.10
- ping to alias1 from a machine which hasn't pinged alias1 before answers with the correct IP 18.1.105.12

Does Win2K write DNS-aliases into a lokal cache?
How can I turn off the caching?
beermcpAsked:
Who is Participating?
 
AvonWyssConnect With a Mentor Commented:
0
 
HousenetCommented:
-Check the hosts & lmhosts files on the local station.
-Perform clear the caches with nbtstat -R
-do an arp -d as well..
-try it again.. No go ?
-Clear the cached dns zones from the dns server mmc & copy the sample dns cache file to the servers cache file.
0
 
AvonWyssCommented:
The cache is in memory. To clear it, use the
IPCONFIG /FLUSHDNS

(NBTSTAT is for netbios only, ARP is IP-to-MAC translation).
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
beermcpAuthor Commented:
the ipconfig /flushdns works perfect. But how can I permanently avoid caching or set the time until refresh to a minimum?
0
 
Droby10Commented:
you can also simply disable the dns client service.
0
 
beermcpAuthor Commented:
Your solution just works perfect. Thanks
0
 
AvonWyssCommented:
Glad to help. Thank you!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.