100 pts to get road runner in Linux

Running Mandrake 8.1 beta 3. Compaq nc3121 fast ehternet module eepro100 and a netgear rp114 websafe router.  can't ping the router, can't bring up network through ifup eth0, can't access internet.  This connection ran with Mandrake 7,2 but hasn't worked since with or without the netgear router.  The same setup works fine on my dual boot machine under win98.  

Thank you for your help,
Miki
miki92Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bptacekCommented:
take the ip that you get from dhcp  in win98(winipcfg) and make it a static IP in your Linux.  It just may not be contacting the dhcp server right.  Make sure you get the IP address, IP Gateway, and subnet mask from the win98 box, and then just enter it in as a static on your linux box.
0
miki92Author Commented:
I thought it might work, but it didn't.  The Internet configuration wizard in Mandrake always says the network's down and when I run ifup eth0, i now get a message saying SIOCSIFFLAGS  and something to the effect of illegal operation.  Still no connection.  Thanks anyway for your comments.  Any others out there.
Miki
0
miki92Author Commented:
I thought it might work, but it didn't.  The Internet configuration wizard in Mandrake always says the
network's down and when I run ifup eth0, i now get a message saying SIOCSIFFLAGS  and something to the
effect of illegal operation.  Still no connection.  Thanks anyway for your comments.  Any others out
there.
Miki
0
jlevieCommented:
My guess, without having 'hands on the box', is that you might be experiencing a resource conflict involving the NIC. Just because it worked with an earlier verion of Mandrake doesn't mean that it will with this later version. I don't think that your earlier installation had support for USB and if your system has a USB controller it could well a cause of a resource conflict.

Check for a resource conflict by examining the output of 'dmesg | grep -i irq', the contents of /proc/interrupts, and the contents of /proc/pci. If there's any other device using the same IRQ as the NIC is using there'll be trouble. Fixing a resource conflict can be something of a bear. I start by making sure that PnP mode is disabled in the system BIOS. Sometimes moving cards to different slots will help. As will disabling onboard devices that aren't necessary. In extreme cases I've had to change one or more cards (like video, or NIC) to a different brand.

Also, you are using a pre-release version of Mandrake. It's entirely possible that this beta is simply broken for your configuration. I'd suggest that you might have a greater chance of success with a release version, like 8.0.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
miki92Author Commented:
You were absolutely right!  I changed to a slightly different chipset on the intel ethernet card and put it in a different slot and it worked great!  Thanks,
Miki
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.