Reply-adress to notes mail over POP

Another weird one, causing me a headacke.... I've helped others before, and now I can't get it to work myself!

About a year ago, I installed notes 5.0.2c server + client, and configured it in a way so people could respond to my messages over the internet. Mail was not routed to though a notes server, but straight from "local" to the SMTP-server. No problem. Not even after lots of upgrades to 5.0.8.

Recently I had to reinstall notes (server + client 5.0.7). Still sending mail the same old way:
through a dial-up internet connection, bypassing the notes server (=directly to the internet),
adding POP and SMTP accounts in my local NAB,
defining the correct (internet mail!) adress in the location document, but:

Recipients can't reply: the From-field holds something like "User_Name/OU/" instead of the adress defined in my location document.

What option did I forget of misconfigure?
To make things clear: I do NOT want to make any design changes to set the Recipients field! I only use the local NAB (I could use the public one....).

LVL 13
Who is Participating?
If you configure your Location document and Mail file in the following way your problem should be solved.

Location document:
- Basics - Internet mail address: fill in your full address ->
- Mail - Internet domain for Notes addresses when connecting directly to the Internet: fill in you internet domain  ->
- Mail - Notes mail domain: This field may be left blank if you use internet mail only.

Mail File
- Tools - Preferences - Basics - This mail file belongs to: fill in your internet user name (excluding the domain name) -> notes.domino
I think that all that needs to be changed, is how Notes addresses the mail. You want to drop the /o/u/c stuff for SMTP mail.
Check the SMTP and related fields for addressing mail. This should all be in the NAB.

I hope this helps !
I'll preface this with I might be wrong.. only because I have a similar configuration.

Just a quick thought.. Did you configure POP and SMTP accounts in your local address book?  (Local Address Book, Create>>Account).  You need one for each, and another for Newsgroups, if you're using them. Also, if you have more than one ID, you need to configure each one while your logged into that ID. (So, it's possible that when you upgraded, you lost your desktop.dsk settings and are locked out of these two configuration files)

Then I configured a location document that I switch to when I specifically want to collect mail from the internet, this one has the internet address in the basics tab, the home mail server set to my pop/smtp mail server, and the local mailfile that I want to use to collect internet mail.

On the Mail tab of the locations document, the internet domain is set to the same ISP address for my pop/smtp mail.

Let me know if you need more specifics..

Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

CRAKAuthor Commented:
To marilyng:
That's exactly what I have always done!
I did indeed configure separate POP and an SMTP accounts in my local NAB for each ID that I use. By switching locations (like "ISP1" or "ISP2"), I switch to a different ID, ending up with a different set of accounts. Using the field "Only for location(s)..." I filter the appropriate accounts. Each of those accounts were made with the ID that uses it.
I had not specified any home servers in my location documents, but filling one out does not seem to help. I checked my old NAB, but that one did not have any homeserver specified either (and the problem did not occur there!)

I did find my notes id specified in the "owner"-field in the (mailbox:) tools > preferences > Tab: Mail/Basics.
Specifying my internet reply adress does appear to work, but in the old situation I sent and received mail through both internet accounts in the same mailbox without a problem (unless mail was always returned to only one of the accounts of course). Now I could live happily with a separate mailbox for the two accounts (is probably a more logical think to do too!), so there is a way out, but it does not explain the actual problem.....

If you have two different internet accounts (sending from local; not through an internal network), could you please help me out by sending me a test message from both accounts so I can see how the different fields are populated (Principal, ReplyTo, From, INetFrom etc.)? My adress is


To SysExpert:
It's not just dropping the OU's etc. None of the mailaccounts resemble my common name.
Which fields did you have in mind? In which database? Both the mailbox and the local NAB are involved; not a public NAB!

To both (better start thinking about this option too):
If I end up using different incoming mailboxes for the different internet accounts, and have to fill out the reply adresses as "mailbox owner" (when we can't get the mailadress specified in the location document to be used)..... who should receive the points?
OK, look in your preferences and see if your pernames address book is first on the list. Else, the accounts want to look at the names.nsf, and that email address is your notes address.

Home/Mail servers can be blank,but on the mail page, specify your smtp address(, etc) for Internet Domain for Notes Addresses when connecting to the internet.  Mail addressing should be local only.

Having the Notes address appear does suggest that there's something amiss with the RFC822 MIME values.

Here's a technote from Lotus:

   Customer Support   Technote

Title: How Is a "From" or "Reply to" Internet Address Formed in Domino R5?
Product Area: Domino Server
Product: Domino Server 5.x
Topic: Messaging & Mail \\ Mail Routing (Router - SMTP)  
Number: 172715
Date: 07/14/2000


How is a "From" or "Reply to" Internet address formed in Domino R5?


The process by which Domino 5.x formats the "From" or "Reply to" Internet address is as follows:

1. If an address is found in the Internet Address field of the Location document, then the mailer will populate the InetFrom field with this address. The router will also use this address to format the From or Reply address.

2. If the Location document's Internet Address field is empty, or a Notes 4.x client is used, the Person document is then referenced, and the Reply address will be the Internet address of the Person document. If the Internet Address field is populated, that address will be used.

Note: For the R5 router to look up the Internet address from the Person document or build the Internet address from the global domain, one of the following fields must be enabled:

A. The "Internet address lookup" feature of the Global Domain document. The Global Domain document can be found in the domain view of the Domino directory; if one does not exist, one can be created. The above field can be found on the conversions tab of the global domain document.


B. The "Lookup Internet address for all Notes addresses when Internet address is not defined in document" field can be found on the SMTP Server Configuration document. To find the correct field, follow this tab path: (MIME\Conversions Options\Outbound).

If neither A nor B are enabled, and there is no address specified in the Location document, then the default settings of the Global Domain document will be used, and the address format will be as follows:

"Joe_User/ou/" without the quotes.
If there are too many users to populate the Internet address manually, you can use the tool provided in the Domino administrator. Refer to the Supporting Information section below for details on the Internet address tool.
3. If (1) there is no entry in the Internet Address field of the user's Location document, and (2) the user's Internet Address field in the Person document is empty and (3) there is no Internet address specified in the user's Shortname field of the Person document, then the user's Internet address will be built from the Server Configuration document and the Global Domain document.

NOTE: The Internet address lookup field of the Global Domain document and/or the "Lookup Internet address for all Notes addresses when Internet address is not defined in document" field in the Configuration document (under Mime, Conversion Options, Outbound) must be enabled.

Supporting Information:

The RFC822 address is no longer formatted in the Global Domain document on R5 servers like it was in the R4 SMTP MTA. The RFC822 address is now configured on the Servers Configuration document and is called "RFC822 phrase handling". It is found in the MIME, Advanced, Advance Outbound Message Options section of the Server Configuration document. The options for this field are as follows:

Do not add phrase (Default setting)
Use DN as phrase (This is the distinguished name (hierarchical.)
Use Alt. Name if available - otherwise DN
Remove Phrase
Use CN as phrase (This is the Common Name.)

The following excerpt is from the Administration Help:
Populating the Internet Address field in Person documents
Populating the Internet Address field in Person documents

When upgrading to Domino Release 5, you can use the Internet Address tool to fill in the Internet Address field for all Person documents in which the field is blank in a Domino Directory.
1. Launch the Domino Administrator.
2. Click the People and Groups tab.
3. Select the server and Domino Directory for which you wish to fill in the Internet Address fields.
4. Click the People tab.
5. Click Set Internet Address.
6. In the Internet Address Construction dialog, choose a format for the Internet addresses.
7. Choose a separator for the Internet addresses. This character separates the items in the Format field.
8. Enter the Internet domain for the company.
Note If you select the option "Use existing address from short name field, if available" the tool searches the Short name field in each Person document for a valid Internet address (for example, If the tool finds a valid Internet address, it uses this address to complete the Internet Address field, instead of creating a new entry based on the information in the dialog box.
9. (Optional) Click More Options and do any of the following:
Select "Use existing Internet domain from shortname field, if available" to search the Short name field in each Person document for a valid Internet domain (for example, If the tool finds a valid Internet domain, it uses this domain to complete the Internet address, instead of using the entry in the Internet domain in the dialog box.
Select "Separate multi-word names with selected separator character" to insert the separator character you specify between words in a name with multiple words.
Select "Create addresses only for people in a specific Notes Domain" to set Internet addresses only for users in a given Notes domain. Enter the domain name of the Notes domain in which you want to set Internet addresses.
Select "Use alternative format pattern in case of name conflict" to specify a second Internet address pattern if Notes generates the same Internet address for two users. Specify the alternative format pattern in the box. See "Using Custom Format Pattern."
This allows you to use the alternative format pattern if the primary pattern results in an address containing non-ASCII characters, an address that is not unique, or one which contains an invalid character.
The Internet Address Construction dialog box specifies the server and Domino Directory on which it runs. It also gives an example for each address and separator format.
Note The dialog box does not give examples for all Custom Format combinations.
The Internet Address tool checks all Person documents in the Domino Directory. When it finds a document without an entry in the Internet Address field, it creates an entry based on the rules above, verifies that the entry is a valid RFC 821 address, and checks to ensure that the entry is unique by performing an exhaustive name lookup of the entry on all Domino Directories on the server. If the entry matches an Internet Address field, the tool leaves the field blank and enters an error in the Log (LOG.NSF).
Note All errors are entered in the Log (LOG.NSF).
Caution The Internet Address tool performs an exhaustive name lookup of every new Internet address and should not be run on a directory or server that is under heavy load.

Related Documents:
CRAKAuthor Commented:

Thanks for your mail. The reply adress appeared correct.

I only use the local (personal) NAB, and already had the internet domain for notes... filled out (
I Don't understand!
Still no progress:

Increasing points: the question must be harder than I expected!
CRAKAuthor Commented:
By the way: the technote is about a domino server.
I use one, but only for development. For mail I use a different location and no domino server.


Yes, this is basically what I said in my first response, only you said it a bit clearer than I. smile.

Sorry, didn't realize that you weren't using a server, as a stand alone client, then you just need to make sure that your location documents are correct.. I have my preferences resolving to my ou address, and if you didn't see this in my email to you, then the Tools>>Preferences as Rodolfus suggests shouldn't make a difference.  

However, I do have an entry in my address book, and the Advanced tab under fulluser name, add a FIRST ENTRY in user name type your real name:  John Smith so that it appears before the ou name: john smith/acme/acmeservices/us.

Then the first name will appear rather than the OU name, but will not prevent mail addressed to john smith/acme/acmeservices/us from reaching you.

I also copied my public key into this document so that it basically mirrored the server document.  

If you have a master address book configured. Then be sure that your internet address is listed under the mail tab, and that your common name is listed in the username SECOND.

Hard to say, I have both names.nsf and pernames.nsf; but on local my preferences are set to use pernames first, and I only turn on the server for development.

So, since we have identical configurations, try this in your pernames.nsf

Let me know.. next thing we can do is compare line for line.. smile.
Oops, to clarify.. in my pernames.nsf I have a document for each of my notes ids that use an INTERNET ADDRESS as the email and include an INTERNET email address in those documents

But offhand, I believe Notes is collecting the value from the entry in my names.nsf person document where my internet address is set at

Now, you might try deleting the location and account documents, compacting your workspace to remove the stored cache information,compact your address book,  log off, log on and create the location document and the SMTP and POP accounts again.

This seemed to work on my Win2000 PC.  The 98PC had no problem.


CRAKAuthor Commented:
Hey.... that does the job!   :-O

Still a few weird things (not meant as questions; I'm just observing):
- Why does Notes no longer use the internet mail adress in the location document?
- Why do we have to split up our internet mail adress into a ISP-part and an account part, and fill each part out in two different fields that are not not even on the same document?
This used to be a lot easier!

No wonder this problem occurs so often in as well!

If either one of you ever get to solve how I can make my own name appear in the inbox as well (instead of "notes.domino"), I'll throw in another 150 "A"'s! ;-))


Not following the inbox question.. if my internet address is formatting using RFC822: "John Smith"<>, then "John Smith" should appear in the inbox. If you only include the RFC821 address part of the email address, then you see the

Where are you seeing "Notes.domino" in your inbox?

Quite a new one to me.. smile.
CRAKAuthor Commented:
Thanks for staying with me!

"Notes.domino" appears in the "who" column in my inbox. How/where should I enter the additional RFC822 name?

I have following fields set now:
Mailpreferences; this mailfile belongs to: "notes.domino" (obviously important)
Location; internet mailaddress: "" (appears unused)
Location; internet domain: "" (important).

If I fill out a full RFC822 name (including quotes), the part left of the "@" in the RFC821 name is shown.

If I fill out my own name, it appears in the "who" column (space is replaced by underscore); reply does not work!

And.... I'm not using a server for mail!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.