We help IT Professionals succeed at work.

Network NIC connections is not visible?

kbb2
kbb2 asked
on
This is a strange problem!

I have a bunch of Win2k server and workstations. Some are member of a domain and some are not. The problem is that I cannot view my my NIC settings such as TCP/IP.

The network is working fine but I just can't access the NIC information. I go to "Control panel" and select "Network and Dial-up connections" and there is nothing except "Make new connection".

I am logged in as administrator on a standalone PC so my rights are in order. I simply wanna change the TCP/IP settings from DHCP to static.

The problem seems to have come after applying Service pack 1 or 2...

Thanks.
Comment
Watch Question

bbaoIT Consultant
CERTIFIED EXPERT

Commented:
what happens after you type "ipconfig /all" in a window of command prompt?

Author

Commented:
As you can see below my network is working just fine and DHCP is enabled. Nothing wrong there. But I wan't to change all that.

Windows 2000 IP Configuration

        Host Name . . . . . . . . . . . . : kbb-note
        Primary DNS Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : todo.com

Ethernet adapter {50E8B25F-BD36-452C-B6D1-37AA5BAB0C5C}:

        Connection-specific DNS Suffix  . : clockcycle.com
        Description . . . . . . . . . . . : FE575 Ethernet Adapter
        Physical Address. . . . . . . . . : 00-50-DA-55-D4-39
        DHCP Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.100.219
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.100.1
        DHCP Server . . . . . . . . . . . : 192.168.100.20
        DNS Servers . . . . . . . . . . . : 192.168.100.20
        Lease Obtained. . . . . . . . . . : 19. september 2001 11:27:39
        Lease Expires . . . . . . . . . . : 24. september 2001 11:27:39
CERTIFIED EXPERT
Top Expert 2007

Commented:
I think you can use the net  xxxx
command to make most changes in the TCP/IP config info.

Try net /?  from a dos prompt and see how versatile it is.
Also download tweakUI V 1.33 or newer and see if there is a way to put the info back from there.

ALso do
sfc /scannow

I'll try to get more details

I hope this helps !
mikecrIT Architect/Technology Delivery Manager
CERTIFIED EXPERT

Commented:
Right click on the My Computer icon and choose manage. Go to services and make sure that the Network Connections service is started. If it isn't start it. If it is, restart it and see if you get your connections back.

Commented:
The thing is... what caused this problem in the first place ?
I'd run an up to date virus check just to make sure....

Author

Commented:
The system IS virusfree/updated. The network IS running.

I tried what tobyk suggestedm, but it didn't work. I might look a bit more into that suggestion.
Ehhr..This might sound stupid. But what happens if you go to "Advanced" and the "Advanced settings". Is that empty to?

Author

Commented:
Is it to is empty! Strange because the action described in tobyk's link to Microsoft defines my problem very well, but the solution described under the bulletin dosen't work!
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
I had the same problem after installing an ISDN card in a win2k server using the card's software the NIC dissapeared from network connections but was working and appeared in device manager. I uninstalled the NIC with add/remove hardware and then reinstalled it and that solved it.

Author

Commented:
I tried that to!! But when I reinstalled the NIC Windows never game me any options. It just automatically selected DHCP and I still couldn't see anything under Network and Dial-up connections
CERTIFIED EXPERT
Top Expert 2007

Commented:
It sounds like the drivers were not fully installed.
I would see if there is a way to complete delete all the NIC drivers , see the install readme, it usually says how to manually uninstall or lists all the files installed.

I hope this helps !

Author

Commented:
The drivers are fully installed! It just happend "overnight" and I think it was perhaps one of the servicepacks that did it!

Commented:
Do the following:

1. Start => Control Panel => Add/Remove Hardware
2. Uninstall/Unplug a device => Uninstall a device
3. Check option - Show hidden devices
4. Find and remove NIC
5. Repeat steps 1-4 until all NICs are removed.
6. Reboot computer and let W2K re-discover network adapters (or install using NIC manufacturer instructions)
7. The problem should be fixed.

NOTE: This procedure will result in the interruption of services. So, use maintenance window.
CERTIFIED EXPERT
Top Expert 2007

Commented:
akagan : I see that you are new here !!

Please see
http://www.experts-exchange.com/jsp/cmtyQuestAnswer.jsp
 (The following has been stolen from emery800 and pasted here)
   Welcome to E-E! Its common courtesy to provide comments unless you know your answer is the only answer and is 110%   correct and is what the questioner is looking for to fix their problem. Please don't take this personally, (others could have let       you know before I and not in manner I use) I made the same mistake when I first arrived and someone was nice enough to      point it out to me. This does a couple of things, first it doesn't lock the question allowing more exposure to other experts         allowing a faster fix, secondly it gives the questioner the option to make an award based on the best comment that helped the
        most in fixing their problem and it is also common courtesy to other experts.
 Please change your present answer to a comment. Again welcome and look forward to working with you in the future, a lot    of teamwork is used at this forum!

Author

Commented:
Woo! It has been a long time! I haven't been able to log in to EE for a while due to heavy downtime. I wonder why they don't fix it for good!!?

I reject this answer because it didn't work!! You are going in a wrong direction!! My connections work, they are just hidden some how! Same goes for my dial-up network connections. They are hidden too!!!
CERTIFIED EXPERT
Top Expert 2007
Commented:
Did you see

missing Local Area Connection ICON in Network Places.
http://support.microsoft.com/support/kb/articles/Q254/6/31.ASP

I hope this helps !

Author

Commented:
Thanks!! Finally!

Here are the trick that solved my problem:

To work around this problem:
1) Click Start, click Run, type dcomcnfg, and then click OK.

2) On the Default Properties tab, click any setting other than Anonymous in the Default Impersonation Level box. The default setting is Identify.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.