We help IT Professionals succeed at work.

Couldn't find NTLDR

mAmitai
mAmitai asked
on
I updated my NT WS to SP6a
and since I am getting the above message afler boot.
I can boot from a floppy disk.
I tried to fix it with the NT instalation discs but it in no use.
Any Ideas?????
Comment
Watch Question

If you can boot from a floppy, copy the NTLDR file to the boot partition.  This should be on the Service Pack CD.  It may have to be extracted.
BRONZE EXPERT

Commented:
If the file is missing (it should be in the root of c:) you can try the following:-

1/ Boot the system with a DOS bootable floppy disk (if it is a FAT partition). If it is a NTFS partition use the NT boot disk shown in the above step

2/ In the i386 directory of the CD-ROM there will be a file NTLDR._, which is the compressed version of NTLDR.

3/ You can expand this file using expand.exe that comes with DOS and Windows for Workgroups
expand d:\i386\ntldr._ c:\ntldr

If the file already exists you may wish to ensure your Boot.ini file is there andcheck that it is not damaged.  You should make sure it is pointing to the correct partition etc.

Hope this helps.
BRONZE EXPERT
Top Expert 2007
Commented:
IF you changed any partitions, then you will need to modify the boot.ini file.

Also you a DOS/win9x Boot floppy, and run fdisk, and make sure your partitions are set correctly and that the first one is set to active ( C: ).
see www.bootdisk.com for more boot disks and utilities.

I hope this helps !

Commented:
Hi,

I've had this problem several times, through my own fault.
If none of the above work and you have an ntfs partition....  this is what you do...

If you have the bootdisks for nt (3 of them), and boot into setup. Select the 'repair' option.. Continue on by reading carefully and you come to a point where you can fix/replace/repair (somthing like that) the system files (not the installation). Do that. It will take a couple of seconds. You need to have the cd handy or have the i386 directory on the cdrom copied to your harddisk.

If you don't have the bootdisks, you can do the same with the nt cd-rom, although, you need to have the original disk (not a cd-burn. I've never successfully burned a bootable disk of any kind) and the cd-rom set up to boot before the hardisk in bios.

Goodluck
mAmitaiSoftware developper

Author

Commented:
Thanks but...
Repair option dosesn't work
It says somthing like "can't fint windows NT".
I am doing it from the original disks.
I have all the files in place (Ithink)
I had problems with the partition index in boot ini but I fixed it
before the error I added an extra partition after I found some extra space using the disk manager. I rearly boot my machine so I don't know is it is related.
My machine works, but I can only boot from a floppy.
mAmitaiSoftware developper

Author

Commented:
OK, I solved it.
It wasn't the active partition.
I used disk administrator to fix it.

Thanks...

Explore More ContentExplore courses, solutions, and other research materials related to this topic.