We help IT Professionals succeed at work.

(PowerToys) Tweak IU's auto logon option

ajw771
ajw771 asked
on
I need to have my Windows 95 PCs automatically login when powered on.  I have installed PowerToys and set the auto logon option.  When I restart the first time it works fine however, when I restart every time after that it no longer does the auto logon.  These PCs all use profiles and have policies in place. All suggestion welcomed.
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2007

Commented:
The policies are preventing this from working properly.

I'm not sure that you will be able to bypass this.

I hope this helps !

Commented:
don't remember win98 by heart, but anyhow, logon normally, enter in your password..., once logon, go into Control Panel|Users->select user then chose set password, enter your old password and keep the new password blank, click ok.   The next time you restart your comp, just hit enter @the login screen, it should go away aft a 2nd logon.

hope this help.

Author

Commented:
s0mvnguy

I am talking about Win95 not Win98.  Also that suggestion will only work if your loging in to Windows not a NT Domain
Top Expert 2004

Commented:
only one user per machine?
Automatic Logon without Name or Password (Windows 9x/Me) Popular
Category: Enhancements > Windows 95, 98 & ME
http://www.winguides.com/registry/display.php/125/
This setting allows Windows clients to logon without entering a user name or password, therefore bypassing the logon box.

Open your registry and find the key below.

Create a new string value called "Default Password" and set it to match the password of the default user.

Restart Windows and the system should automatically logon.

Hint: The username of the default user can be found at [HKEY_LOCAL_MACHINE\Network\Logon\Username]

Note: The password is stored in clear text, therefore anyone with access to the registry can see the default password.



 
     
  Default Password REG_SZ "blogs123"  
 
 HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion...  
 


Settings
Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
Winlogon]
Value Name: Default Password
Data Type: REG_SZ (String Value)
 

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

CERTIFIED EXPERT
Top Expert 2007

Commented:
If the above does not work ( an I think that tweakUI does the same thing Steve ), then what is happening is tat you make the change, reboot and get logged in.
During login you receive the policy over-rides and this wipes out your auto-login.
That's why it only works once, and the policy will always prevent any change.

I hope this helps !

Author

Commented:
SysExpert

I suspect that this is what's happening, however I would be intrested in knowing which setting in the policy is causing the problem.  I have try disabling serveral settings now wil no luck.

Thanks
CERTIFIED EXPERT
Top Expert 2007
Commented:
1) D you have a mandatory policy ?
This could simply overwrite the autologin stuff .

Are any changes done to your registry  manually at login ( thru a script perhaps ? )

What happens if you use a workgroup rather than Domain login ?

I hope this helps !
The is an option in Poledit that wipes the userid of the previous person, while not the password this would cause a logon prompt to be displayed even if logon is set to automatic as your password can be blank, but not the userid
ajw771,
No comment has been added lately (669 days), so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area for this question:

RECOMMENDATION: Award points to SysExpert http:#6505585

Please leave any comments here within 7 days.

-- Please DO NOT accept this comment as an answer ! --

Thanks,

scott_renton
EE Cleanup Volunteer

Explore More ContentExplore courses, solutions, and other research materials related to this topic.