We help IT Professionals succeed at work.

Autorun diskette?

peterx
peterx asked
on
How does a "autorun.inf" file for DOS look like?
My gf changed some bios settings, the password,
(without writing it down) and the device search order, from A,C to just C...
How could I force the computer to read first in A: ?
All ideas are welcome.
Thx in advance!
peterx
Comment
Watch Question

dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
The way to force the computer to look at the floppy is through the BIOS.

The BIOS controls which drive to look at for an OS first and then the drives afterwards in case it doesn't find a valid OS, eg, A, C or C, A or CDROM or just C only.  There is a setting in the BIOS to change.

If you want to get into the BIOS seeing your gf has changed the password then remove the battery and leave the computer sit for half an hour and then reinstall the battery.  Ensure the power is off and disconnected when you do this.  Warning you may lose some settings in doing this.
The only way is to through the BIOS.

The BIOS controls which drive to look at for an OS first and then the drives afterwards in case it doesn't
find a valid OS, eg, A, C or C, A or CDROM or just C only.  There is a setting in the BIOS to change.

Author

Commented:
Hi Dbrunton, I tried removing the battery,
that was the first thing I did, but no luck...
renjithr78: ????
CERTIFIED EXPERT

Commented:
Mainboard manufacturers often have "shorting" pads or jumpers for clearing the CMOS (and password). Do you know the model number of the motherboard?

bill
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
Other methods include:

if you have two sticks of memory, remove one and reboot.  It may indicate a major error on startup and allow you into the BIOS

disconnect all drive cables and reboot and the startup error may allow you into the BIOS.

Author

Commented:
have tried to remove one of the memory sticks,
disconnecting almost all cables and booting up,
some times i see the dos window with some err message
flash, before the password-entry window pops up...
Dont know how the motherboards model nr looks like,
its a dell latitude cpi 300xt...
Heres one of the numbers i found on the board:
Pwb 55718
DAOTM2ABAG9

Commented:
The battery thing works everytime but you may need to leave it out for several hours for capacitive discharge on the motherboard to force it to forget. Don't forget to disconnect the power connector on the MB from the power supply (wide Utilux plug) as this can also take a while to discharge

Author

Commented:
nvms, did all that, had the battry out in at least 24h...
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
Can you boot the machine in C:?  If so there are utils that can crack the BIOS.

Author

Commented:
yepp, but havent found any working one...
my bios is Phoenix A09,
cmosPwd fixes up to A08,
but still, i dont know how to use them,
because i cant access dos or a:.
Dell wants me to send the puter in,
but i want to fix this whitout paying
a bundle to them (again) :-)
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
Are we talking Windows 9* here?

Pressing F8 at startup doesn't get you to the menu for various start modes like SAFE and command prompt?

Has the computer got an InterNet connection?  Or a CDROM drive and do you have access to a burner?

Author

Commented:
win98, and no, Ctrl doesnt get me to command prompt.
it has got internet and a dvd, but since neither
dos or win starts i cant access it from other computers..

Commented:

peterx,

Have you got into it yet? Is that a notebook you have? We had some Dells come through,
purchased as used at auction by the client who wanted them configured for a wan
and I think a couple were Latitudes... Looking at notes scribbled on it here
but wrote down Inspiron and then "Latitude hard drive password" and
during the job was unable to get beyond passwords on 3 or 4...

Just reading from these remarks denoting info (probably obtained from Dell techs)
and it appears some can have their own "master password" unique to the "service tag"
(as indicated here) set in the bios. To get a master password straight from Dell
the auditing firm transferred ownership into their name through Dell's
"mobile computing corporate account" (unintelligible) who issued
a password somehow derived from the tag.

This was over a year ago and I forget all the details and the above is only a
translation of my notes, but as it applies I'll include what I wrote down
of these and see if I kept more about it if you think it's relevant
to your situation and that particular Dell Latitude model.
This is cryptic but is what else is on this paper...

~password stored in nvram onboard...
~battery removal won't clear bios password...
~press Fn + F1 to enter bios...
~hard drive can have own separate password...
~clear master password nvram
~primary & administrator password

 

Commented:

peterx,

Found another note having names and dates when spoking with Dell about it...
Five techs on three occasions, but here are numbers and specs I saved,
which may help you get more info if you don't already have some of it...
Sorry I can't provide more, but got in by giving Dell certain numbers
off the systems... This has a list of these system's "asset tag"
and invoice numbers... Dell provided a password using that.

Again, these were originally sold on a corporate account and may not apply to yours,
but hopefully some of it's helpful and will give you info to search on or help decipher it.
Also there's currently an open q (20190836) here in the dos ta having stuff about
an autorun.inf file. Did you say you can boot the C: drive (and then access A:)
or does the password prompt appear during post like a supervisor password?
The "master password" may be needed to access the bios password.
Anyway, here are numbers and an url from these notes where you
may be able to get a clue as to decoding or cracking
the master password if necessary...


Mobile Computing   =   800  822-8965

Direct Accounts   =   800  247-9252

Corporate Accounts   =   800  247-9256

Customer Service   =   800  624-9897

System Transfers:

http://support.dell.com/us/en/emaildell/cc_opt09.asp 

 

Commented:
Hey, is there any special jumpers to restore CMOS defaults on your motherboad?
If it doesn't,I can write a little program that writes something dummy to CMOS, that will make it to reset  itself, i suppose.

Author

Commented:
Hi there guys,
yes the laptop is still getting dusty.
Rin1010, thanks for the detailed info :-)
however i live in sweden, and Dell support
here just wants me to send it in.
Freakoz, sounds interesting, but the prob
is that at boot up the computer doesnt
read diskdrive, but the light in it switches on
when the Admin password window pops up.

Commented:
Yeah, laptops are funny buggers.  I had a client with a similar problem some years ago with a Toshiba laptop.  I eventually tracked down a wiring diagram for a dongle which used no components other than a DB-25 parallel connector and wired the appropriate pins.  After attaching it to the printer port and rebooting the laptop, it threw me straight into the CMOS and I was able to change the master password as it had cleared it.  It is now a part of my toolset.

Just thought I'd mention it.

BTW, there MUST be master password if there is no hardware CMOS reset.  This is likely to be an engineer's password or Dell's Engineers' password (which is likely to be kept secret) - dig around the net, you might find one.

As for returning the laptop - nonsense!!  If the **** hits the fan, threaten to return the laptop as 'faulty' and demand compensation on the grounds that the machine does NOT function as it is intended - because quite frankly, you're supposed to have total access to YOUR property.

Torture might jog her memory.... say, no sex for a year....

Commented:
try this....

hold down the HOME key on power up

or

enter 'phoenix' as pwd

or

if you can access to your pc, get DOS up and running. Fire up DEBUG and enter the following:

O 70 2e
O 71 0
q

this should erase the pwd

Good luck!!



Commented:
very interesting discussion on DOS based pc.

anyway, I kinda like t0t0 comment...

I wonder whether this works.  The boot manager that I used XOSL (http://www.xosl.org), will will actually let you choose to boot from follopy.  Just grab it (download), install, and add an option (within the setup mode), to boot from floppy.  It even comes with Advance Boot Manager (what they call it), that could do the job.

But still, the computer will boot from HD first, hit the MBR and get XOSL loaded, before anything else (application) started.

Remember to install to a DOS partiion, and do not install to a dedicated partition.  Otherwise you might end-up losing you data (by mistake).  

To remove, just boot normally and issue a FDISK /MBR to clear up the mbr to the original DOS MBR.  Or resetup XOSL again to remove it.

Not the best solution, but it might work.

good luck

Author

Commented:
t0t0, i cant access Dos mode so debug doesnt work here..
Ill try XOSL tonight, looks really interesting, thx!!
Still open today, any updates?
EE Moderator
ADMINISTRATION WILL BE CONTACTING YOU SHORTLY.  Moderators Computer101, Netminder or Mindphaser will return to finalize these if they are still open in 7 days.  Experts, please post closing recommendations before that time.

Below are your open questions as of today.  Questions which have been inactive for 21 days or longer are considered to be abandoned and for those, your options are:
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you, but may help others. You must tell the participants why you wish to do this, and allow for Expert response.  This choice will include a refund to you, and will move this question to our PAQ (Previously Asked Question) database.  If you found information outside this question thread, please add it.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question (if it has no potential value for others).
   --> Post comments for expert of your intention to delete and why
   --> YOU CANNOT DELETE A QUESTION with comments; special handling by a Moderator is required.

For special handling needs, please post a zero point question in the link below and include the URL (question QID/link) that it regards with details.
http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
 
Please click this link for Help Desk, Guidelines/Member Agreement and the Question/Answer process.  http://www.experts-exchange.com/jsp/cmtyHelpDesk.jsp

Click you Member Profile to view your question history and please keep them updated. If you are a KnowledgePro user, use the Power Search option to find them.  

Questions which are LOCKED with a Proposed Answer but do not help you, should be rejected with comments added.  When you grade the question less than an A, please comment as to why.  This helps all involved, as well as others who may access this item in the future.  PLEASE DO NOT AWARD POINTS TO ME.

To view your open questions, please click the following link(s) and keep them all current with updates.
http://www.experts-exchange.com/questions/Q.20186164.html
http://www.experts-exchange.com/questions/Q.20191054.html
http://www.experts-exchange.com/questions/Q.20233028.html
http://www.experts-exchange.com/questions/Q.20249673.html
http://www.experts-exchange.com/questions/Q.20281951.html
http://www.experts-exchange.com/questions/Q.20291706.html

To view your locked questions, please click the following link(s) and evaluate the proposed answer.
http://www.experts-exchange.com/questions/Q.20264642.html
http://www.experts-exchange.com/questions/Q.20299959.html

*****  E X P E R T S    P L E A S E  ******  Leave your closing recommendations.
If you are interested in the cleanup effort, please click this link
http://www.experts-exchange.com/jsp/qManageQuestion.jsp?ta=commspt&qid=20274643 
POINTS FOR EXPERTS awaiting comments are listed in the link below
http://www.experts-exchange.com/commspt/Q.20277028.html
 
Moderators will finalize this question if in @7 days Asker has not responded.  This will be moved to the PAQ (Previously Asked Questions) at zero points, deleted or awarded.
 
Thanks everyone.
Moondancer
Moderator @ Experts Exchange
Commented:

I've again encountered this problem on a Dell Latitude since my initial posts about it.
Needed access to the BIOS but a password had been set and forgotten.
Called Dell support as before and was able to get the password.
Also asked the techs more specific questions about it
and whether there were any workarounds...
According to Dell there are none
(didn't ask for hax/crax, lol)
besides calling them.

Anyway, the conference with Dell confirmed notes from my original experience...
These Latitudes have a Master Password... The BIOS password is unlocked
using the Master password... The Master password is unique to each system
and is derived from that system's Service Tag... After supplying the Tag number
and owner's registration, the tech looked up the Master password and we were in...

I got this info by calling Dell's Mobile Computing Hotline 800 number...
Some of the specific support numbers I previously posted here
aren't in service now, but will still give you a recorded list
having appropriate numbers for the account type.
 

Commented:

Forgot to say thanks to Moondancer...
btw... Some of those question links
are for member name "francyb"...
 
Thank you, rin1010, that is very strange, indeed.  I'll need to check the API function as to why this strange result from a specific Member ID pull.

Hopefully, peterx, will return to this question and update finalize it.

Moondancer - EE Moderator
THIS QUESTION CAN BE FINALIZED

** PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER **

It appears that this question has been abandoned.  Unless there is objection or further activity,  it will be requested that points be awarded to the following expert(s) for their comments:

rin1010

If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers, please post a request in Community support (with a link to this page) to refund your points.  The link to the Community Support area is: http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt


/EW

** PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER **
Thank you, finalized today by EE Moderator.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.