We help IT Professionals succeed at work.

increasing the buffer size for oracle 8i table fields

yilmazay
yilmazay asked
on
Medium Priority
1,428 Views
Last Modified: 2007-12-19
Hi everybody,
i have a big problem, and it is very urgent.
hope someone helps me with this trouble.
i am transfering txt files' data to oracle tables.
oracle doesn't accept the data if it is bigger than 276 bytes ????.I chnaged the size of that column to 2000bytes,
it seems,setting up is okey, but during the data transfer an error occurs telling me that the column3 is too large for the specified buffer size. Unfortunately most of the data are larger than 276 bytes, so i have to find a workaround for this problem.
i tried to change the initial parameters for my database.
i changed the db_block_size to max value(16384) , restart the database, but still having the same error message, as if no change was made.
can someone please give me some advice how to increase the buffer size.
i also tried using CLOB for this large text field, but database doesn't accept, or i am making a mistake somewhere.
any suggestions.
i am looking forward to your (GURUs') precious ideas and help as soon as possible.
cheers :)
Comment
Watch Question

Dear yilmazay

To change oracle block size u've to recreate the database.
or if u want more db_block_buffer u've to increase the parameter db_block_buffer in init.ora file
(total db buffer size = db_block_size * db_block_buffer)
Pls check your rollback segments are having sufficient size
I beleieve ur problem is not due to the db block size or db block buffer,
try sql*loader for data transfer

rgds sajeesh

Author

Commented:
hi sajeeshkm ,
first thanks for replying
i recreated anew database with a max buffersize
but still i am having problem in transfering data.
as you said , i inreased the rollback segment size to 'unlimited', still it keeps throwing the same error message saying that buffer size is not enough.
you say "I beleieve ur problem is not due to the db block size or db block buffer".
then what does "the data for col3 is too large for the specified buffer size " error message mean?
and how to overcome it?
i tried using sqlldr, but it seems too complicated in comparison with the tool i am using at present. but i will continue to work on it. However , i think the buffer size is the bottle neck for this app, so whatever i use i will have the same problem untill i solve the buffer size limitation problem.
thanks for your taking time
cheers :)
are u specifying any buffer size durinf data transfer
or find out the default bufer size for the utility what u r using for data load.

sql loader is simple and very easy

Author

Commented:
thanks sajeeshkm,
i will try using sqlldr
cheers :)

Explore More ContentExplore courses, solutions, and other research materials related to this topic.