We help IT Professionals succeed at work.

How to fix OSD-04101 ORACLE problem...

sarankrishna
sarankrishna asked
on
Medium Priority
1,828 Views
Last Modified: 2012-05-04
I have a problem in ORACLE Server 8 Installed on Windows NT Server 4.0. Due to some problem my machine
crashed. So I reinstalled NT Server,Oracle 8. I copied my older database files into the oracle database
directory. I created the instance and service of my database(two database) using ORADIM80.EXE. One of
the databse is working fine. For the other Services are started but the instance is not initialised.
I am getting the following error

ORA-01034: ORACLE not available
ORA-09243: smsget: error attaching to SGA
OSD-04101: invalid SGA: SGA not initialized

Can any one help me to fix this problem.
Comment
Watch Question

Commented:
Hi,

Check that the ORACLE_SID parameter is correct.
Either open a command window and do

c:\>set ORACLE_SID=<sid> --> this is you SID
c:\>svrmgrl
svrmgrl>connect internal
svrmgrl>startup

or

Check the registry under HKEY_LOCAL_MACHINE\Software\ORACLE\...
and see if the ORACLE_SID is set correctly
Make sure there isn't two instances of Oracle on the NT machine.  
You need to set the ORACLE_SID for the second database. You can use following command:-

c:\>set Oracle_sid=second_database_name

c:\>svrmgrl

svrmgrl>connect internal as sysdba
password> internal_password [by default it is oracle]

svrmgrl>select instance_name from v$instance

if the instance name matches the second name you can start the databse with following command

svrmgrl>startup open

else

set the Oracle_sid again on the c:\> prompt
May be it helps you:
 

Problem Description:
====================
 
You are trying to connect to the database in one of the following ways:
   - A loopback on a Windows NT Server.  The service for the
     instance and the listener are started and running.  In this
     case the following errors are reported:
          ORA-06108 "NETTCP: connect to host failed" is reported.

   - You are connecting from a Windows client machine using SQLDBA.
     A direct connection to the database is possible.  In this case
     the errors reported are:
          ORA-01034: ORACLE not available
          ORA-09243: smsget error attaching to sga
          OSD-04104: unable to map shared memory (SGA) into the address space

   - You are connecting from Server Manager and these errors are reported:
          ORA-01034: ORACLE not available
          ORA-09243: smsget error attaching to sga
          OSD-04101: invalid SGA: SGA not initialized


Solution Description:
=====================

Change the SID in the Registry:
1.  Run REGEDT32 and go to HKEY_Local_Machine on Local_Machine.
2.  Got to Software.
3.  Go to Oracle.
4.  Look for ORACLE_SID and verify it is set to the SID to which the you are
trying to connect.  If not, double click on ORACLE_SID and modify the string.

           -- OR --

If you don't want this SID to be your primary SID, use the local two task
driver to connect:
svrmgr23>  connect internal/password@2:SID  -where SID is your SID

You can only connect using this designation if you are using Oracle7 and
SQL*Net version 2.x.  This is not valid for Oracle8 and NET8 configurations.


Explanation:
============

With the wrong value in the registry, and not specifying the right one during
connect, the software was trying to start up an SGA for a database which does
not exist.
.

 

--------------------------------------------------------------------------------
 
 Copyright (c) 1995,2000 Oracle Corporation. All Rights Reserved. Legal Notices and Terms of Use.

Commented:
Hi,

This problem could be because of insufficient memory to allocate to the second serivce or database at the startup of the services.
Shtdown the first instance and database and try starting the second one. It should work, If not
change the startmode of the service to 'service' only using ORADIM , In oradim you can specify the start type of the service, Dont start the 'instance' just start the service, For help type ORADIM help=y at command prompt.

After starting the service go to command prompt set oracle_sid and invoke svrmgrl , issue startup command.

If it works then increase virtual memory on the machine, if possible try to increase RAM

Best of luck
Prasad
CERTIFIED EXPERT
Author of the Year 2009

Commented:
Hi sarankrishna,
It appears that you have forgotten this question. I will ask Community Support to close it unless you finalize it within 7 days. If there is no objection or further activity, I will suggest to:

    Refund points and save as a 0-pt PAQ.

EXPERTS: Post a comment if you think somebody deserves credit here!

Please do not accept this comment as an answer!
==========
DanRollins -- EE database cleanup volunteer

Author

Commented:
hi DanRollins
I don't know how to close this question. That's why i left as it is. But my problem didn't get solved. What I did was I reinstalled OS and oracle. So tell me what should i do
CERTIFIED EXPERT
Author of the Year 2009

Commented:
You can:
 * Award points to any expert who helped
 * Request to split points among experts who helped.
 * Click the Delete button to delete the question (you may need to reject adepsoft's answer first)

Just post your decision here, and the Community support Moderator will be along soon to handle it.

-- Dan
sarankrishna ->  You logged in 6/11/2002 and ignored this, please deal with it or we'll need to.
EXPERT INPUT PLEASE>>>>
Thanks,
Moondancer - EE Moderator
Points refunded and moved to PAQ

** Mindphaser - Community Support Moderator **

Commented:
sarankrishna

have you found a solution to this error:

  ORA-01034: ORACLE not available
  ORA-09243: smsget error attaching to sga
  OSD-04101: invalid SGA: SGA not initialized


I am having the same problem. if you have a solution, let me know, really appreciate it.

thx

Kevin