We help IT Professionals succeed at work.

Windows Explorer starts maximized regardless of setting

donander
donander asked
on
I'm posting this to Win2000 because I only seem to have the problem under Win2000. The problem is with Windows Explorer (although according to the title bar it's called Internet Explorer.) Anyway, I'm talking about the file management utility, not the internet browser.

The first problem with W2K and Explorer is that it started focused on My Computer but I found out how to get it to start focused on C:\ by adding /n,/e to the command line in the shortcut. However, it now insists on starting maximized even though "Run" in the shortcut is set to "Normal Window." I would like for Explorer to start as a normal, resizeable window, focused on C:\. Is there a way to get all these at the same time?
Comment
Watch Question

Top Expert 2004

Commented:
here are the explorer parameters
Parameters

/n

Always open a new window (even if the specified folder is already open).

/e

Use Windows Explorer view. The default is Open view.

/root,object

Specify the object in the normal namespace that will be used as the root of this Windows Explorer Folder.

The default is to just use the normal namespace root (the desktop).

subobject

Specify the folder to receive the initial focus unless /select is used. The default is the root.

/select

Specifies that the parent folder is opened and the specified object is selected.

donander,

You click the Windows Explorer shortcut, it opens in maximized window.
You make it to normal windows again.
Now, Hold CTRL key and click the [x] Close icon at the top right hand corner.
This reset and save your current settings of Windows Explorer.

Hope it helps.

Patricia / pslh

Author

Commented:
stevenlewis: I am using /n,/e now and the focus is on C:\ as I would like. This is not the problem. The problem is that the window opens maximized rather than as a resizeable window. The shortcut is configured to use a normal window but that does not seem to be working. I don't see how any of the other switches you mention would affect the window size but if you could give me a specific syntax I would be happy to try it. Here's what the command line looks like now.

C:\WINNT\EXPLORER /n,/e

If I remove the /n,/e Explorer DOES start in a normal window (resizeable) but the focus is then on My Documents, which I don't want.

pslh: I tried holding the CTRL key while clicking the [x] but this does not cause Explorer to remember the settings. I also tried closing the window with File/Close, which in most applications will cause the window size settings to be remembered but that does not work either.
donander, take a trial of this.

For Windows 2000  Pro      

C:\WINNT\EXPLORER.EXE /n, /e, C:\

OR

Target [%SystemRoot%\explorer.exe /n, /e, C:\       ]

Start in: [%HOMEDRIVE%%HOMEPATH%       ]

Author

Commented:
I tried both suggestions but I get the same result (maximized window.)

Author

Commented:
pslh: After I posted the comment about it not working, I was working on some other stuff using that computer, and suddenly, when I opened Explorer, it opened in a resizeable window. The strange part is I don't know what was changed between the time I tried your last suggestion and it didn't seem to work and the time when it did seem to work. Anyway, I'm accepting your comment as the answer.

Thanks,
donander
It's strange. I repeated.

I clicked the restore down icon next to the close icon.
It changed to normal window.
I close windows explorer.
Re-open it again. It is opened in normal windows.

Are you login as user or Administrator? Any policy made to restrict you and custom the destop in open maximized windows?
Well, while I posted my last comment, it is noted the problem is solved.    ;-)


Patricia / pslh
Thanks pslh. I too use Windows 2000 Pro and have wanted Windows Explorer (aka Internet Explorer) to open at C:\.
Your suggestion to set the Target to  [%SystemRoot%\explorer.exe /n, /e, C:\       ] works like a charm.

OT. Why has Microsoft muddied Windows 2000 Pro by naming Windows Explrorer "Internet Explorer"? It's most confusing.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.