We help IT Professionals succeed at work.

Help - access W2K drives from W98 machines

bowker
bowker asked
on
Medium Priority
242 Views
Last Modified: 2010-04-13
New W2K install went fine ... it's on a peer-to-peer LAN with 2 W98 machines.  The W2K machine can read all (shared) drives and devices on the W98 machines, but the W98 machines can't access the W2K machine drives or devices.

The LAN is behind a firewall ... on the W2K machine, "User must enter a user name ..." is NOT checked ("Administrator" is the default user on boot) ... I've checked everythjing I can find at MS, but no luck.

Where do I start ...?  What do I need to check ...?

Bob.
Comment
Watch Question

Commented:
Browker.
Shared Folders shows you three lists:

Shares: Lists all the shared files and folders on your computer.
Sessions: Lists all the users connected to your computer.
Open Files: Lists all the files on your computer currently opened by other users.
Using Shared Folders, you can create, view, and set permissions for shared files and folders.

Open Computer Management (Local).
In the console tree, click Shared Folders.
 Notes

To open Computer Management, click Start, point to Settings, and then click Control Panel. Double-click Administrative Tools, and then double-click Computer Management.
For information about using Shared Folders, click the Action menu in Computer Management, and then click Help.

If you need more help please ask
Good Luck!
Top Expert 2004

Commented:
what protocols are on the w2k box? the w98 box? are they on the same network (tcp/ip) what does ipconfig /all show on each machine
try using the lmhosts file on the 98 boxes
for info on the lmhosts file
http://www.realcomputerguy.com/lmhosts.htm
Top Expert 2004

Commented:
also enable the guest account on the w2k box
Click on Start/Programs/Administrative Tools/Computer Management. Look for Local Users and Groups under

System Tools (on the left side), and expand it to show the two folders, Users and Groups. Highlight

the Users folder, and then you'll see the Administrator and Guest account. Highlight the Guest account,

and click on Action. Go down to properties, and on the General Tab for Guest Properties, you'll see

the box checked for Account is Disabled. Uncheck it

Author

Commented:
jwc02026:
SHARES: shows C$,C and ditto for all partitions and the printer
SESSIONS: shows ADMINISTRATOR, and 2 separate sessions for each of the connected W98 computers ... 1 has proper user, 2nd does not..  All have "No" in Guest column.
OPEN FILES: empty.

stevenlewis:
W2K: Client for Microsoft Networks, File and Printer Sharing, TCP/IP, all checked
W98: same
lmhosts: I'll investigate, thanks ...
GUEST ACCOUNT: already enabled

HERE'S WHAT HAPPENS:
On either W98 system, click on NETWORK NEIGHBORHOOD, click on the W2K machine name, all SHARED drives show up.  Click on a drive letter, and "ACCESS DENIED" error window pops up ...
On the W2K system, drives and printers on both W98 machines are available.

Still trying ...

Bob.
Top Expert 2004
Commented:
OK, the "access denied" gives us a clue.
Log on to the 98 boxes using the client for M$ networks as the primary logon, this creates the access token that the w2k box needs. then on the share(s) you have to allow the guest account access to the share(s), in the permissions, allow everyone full control
CERTIFIED EXPERT
Top Expert 2007

Commented:
SHaring a drive drive share  NT shares  NT file sharing
Permissions are set in two seperate places in NT and win2k.

   1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

                   right click on the drive/file, choose properties - security - permissions. Give the person/goup full
                   access.

3) delete all the *.pwl files in the \windows dir on win98. Your next login will recreate them. reboot
                   !!
OK, you need to add a new share rather than the default administrative share.
                   Add the new share -( there is a new share buton at the bottom )  call it C-drv, set the permissions,
                   and that should solve the problem.
1) Add a new user on NT.
               2) Try loggin into a win98 station using this new user and password.

               See if you can access the NT machine.

               Please note that the default shares on NT are not accessible, you have to create NEW shares !

                   I hope this helps !

Author

Commented:
stevenlewis:
Thanks, that did the trick!  I appreciate the help ...

SysExpert:
What ...?!?!?!?

Bob.
Top Expert 2004

Commented:
bowker Glad I could help
Steve

Explore More ContentExplore courses, solutions, and other research materials related to this topic.