We help IT Professionals succeed at work.

Networking WIN2K with Windows 95

adam8
adam8 asked
on
Medium Priority
164 Views
Last Modified: 2010-05-18
Hi,
I have tried and simply cannot do it.
I have set them both to the same Workstation name.
it was a lot simpler in Windows ME.

is there something I am missing.

please help
Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2007

Commented:

SHaring a drive drive share  NT shares  NT file sharing
Permissions are set in two seperate places in NT and win2k.

   1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

                   right click on the drive/file, choose properties - security - permissions. Give the person/goup full
                   access.

3) delete all the *.pwl files in the \windows dir on win98. Your next login will recreate them. reboot
                   !!
OK, you need to add a new share rather than the default administrative share.
                   Add the new share -( there is a new share buton at the bottom )  call it C-drv, set the permissions,
                   and that should solve the problem.
1) Add a new user on NT.
               2) Try loggin into a win98 station using this new user and password.

               See if you can access the NT machine.

               Please note that the default shares on NT are not accessible, you have to create NEW shares !

                   I hope this helps !


ALso See          http://www.practicallynetworked.com/
http://www.practicallynetworked.com/howto/
Need to map the port, as you are using ICS (network address translation)
   http://www.practicallynetworked.com/sharing/icsconfig_maps.htm
  port list
  http://www.practicallynetworked.com/sharing/app_port_list.htm
http://www.sohointer.net/howto/
http://www.sohointer.net/top/kwe-faq.htm
http://www.onecomputerguy.com/networking/peer.htm
http://www.dslreports.com/information/rated/PPPoE
http://www.microsoft.com/windowsME/using/homenetworking/articles/default.asp
 www.speedguide.net
http://www.cert.org/tech_tips/home_networks.html Firewall and security for home and offices
Test firewall ports  and port blocking http://grc.com/
CERTIFIED EXPERT

Commented:
Adam, you need to make sure that you set up the machines as follows:

In the Network ID section, the machines must:

1. have different 'computer names'

2. have the same 'Workgroup' name

3. Computer description is irrelevant.

To share resources on the Windows 2000 machine, you must enable the guest user account, which is disabled by default.

There must be something shared on both machines, and/or at least share created on the win2k machine.

Client for Microsoft Networks must be used!

Dennis
Top Expert 2004

Commented:
a couple of other things to add to the good advice above.
Make sure to use the same protocols on both w2k 's default is tcp/ip w95 is NetNEUI. I also recomend updating the winsock on the 95 box
http://www.microsoft.com/windows95/downloads/contents/wuadmintools/s_wunetworkingtools/w95sockets2/default.asp the one that shipped with the original OS was faulty

Author

Commented:
sorry. I meant networking it to a win98 machine but I am guessing the process is similar anyway.

I know the other comp had shared resources. would that stop me from seeing his shared items.

PS. workgroup name is the same, comp names are different

Author

Commented:
BTW: I will be logging in as an Administrator at all times since This is a home computer and there are no other users.
CERTIFIED EXPERT
Top Expert 2007

Commented:
Can you ping the other machine ?
Can you see it in the network neighborhood ?

Are you using just TCP/Ip, or have you tried adding NetBeui ?

We need more info on what hte exact symptoms are !

Author

Commented:
I cannot see the other computer in network neighbour hood.
when I browse the Entire network I can see the workgroup but no one in it.

I am just using the CLient for microsoft networks.
so is the other computer.

file sharing is enabled on the other computer but I don't think I enabled it on the Win2000 one unless it is shared by default.
CERTIFIED EXPERT
Top Expert 2007

Commented:
try

Start- run
\\computername

See if this gives you access to the other computer.

Also - try adding NetBeui protocol on both machines.

I hope this helps !
CERTIFIED EXPERT

Commented:
Have you set the IP addresses for each machine?

Is TCP/IP bound to the network cards on both machines?
CERTIFIED EXPERT

Commented:
It would help Adam to know at which computer you can see the other or ?

NT2000 does not share by default, you must enable the guest user.

Author

Commented:
I can not see any of the computers and they cannot see me.
CERTIFIED EXPERT

Commented:
How 'exactly' are these machines connected to on another?

Author

Commented:
a lan cable. the connection is green. they connect fine when I run windows me instead of 2000
CERTIFIED EXPERT
Top Expert 2007
Commented:
Have you any firewall programs, NAT or ISA installed on win2k ?

Have you compared the WinME TCP/IP vs. the win2k ?

Have you added the NetBeui protocol to both computers ?

I hope this helps !
CERTIFIED EXPERT

Commented:
Are you using just a plain crossover cable, no hub etc?

If so, you should be aware that on Windows 2000, NetBUI is disabled by default and should be enabled if needed.
Top Expert 2004

Commented:
:~)

Author

Commented:
I am using crossover.
BTW don't just tell me to check the TCP/IP address. it is easy in windows me but I am not sure in win2k.

also why was it so simple in windows me. isn't Win2k the one that is supposed to be for networking?

Author

Commented:
also don't ask me what i have installed or not because I don't have any idea. I installed it. whatever is there is there, it's that simple.
CERTIFIED EXPERT
Top Expert 2007

Commented:
OK.
post the results of

ipconfig /all
from a dos window.

This may help out.

Author

Commented:
I haven't got it installed at the moment. Only winme
Top Expert 2004

Commented:
In w2k go to a command prompt start-->programs-->accessories and from the prompt type
ipconfig /all
Top Expert 2004

Commented:
I'm betting the ip will be 169.254.x.x which means you hae it set to get it's ip from a dhcp server, and there isn't one.

Author

Commented:
I would but I don't have windows 2000 installed.

In a week I will so I can continue with this question then
CERTIFIED EXPERT

Commented:
adam, are you telling me that we're trying to sort out a network problem when you haven't even installed Windows 2000 yet?

Author

Commented:
No. I had it installed but since I couldn't wait to sort out the network I had to install windows ME because I needed the network going but don't panic.

I installed it on another partition and still having problems.

I will try some of the suggestions and write back later.

Author

Commented:
BTW I have now shared C and D but there is still no response.

I cannot find the other comp by searching in network places\

they are both configured to use the same workstation. the comp names are different.

I just have the standard three protocols installed in win2k. I am not sure which one to use in win98 though. I used clients for microsoft networks or whatever but I am not sure if it is right.

The IP addresses are automatically assigned.

both comps are sharing drives.

I will try the ipconfig thing later when I can get off the internet and load win2k again
CERTIFIED EXPERT

Commented:
Adam, use the Client for Microsoft Networks, and assign IP addresses to both machines. As an example, use 10.0.0.10 and a subnet of 255.255.255.0 for the Win2k and 10.0.0.20 and 255.255.255.0 for the other. Remove NetBUI from both and run TCP/IP only.

Author

Commented:
I installed the NetBEUI protocols on both comps and it worked.

I had to also enable the guest user account but the main prob was with the protocols.
CERTIFIED EXPERT
Top Expert 2007

Commented:
Glad you got this working !!
CERTIFIED EXPERT

Commented:
Bizarre!

Explore More ContentExplore courses, solutions, and other research materials related to this topic.