We help IT Professionals succeed at work.

Can I use ASUS USB card on a DFI motherboard?

leeal
leeal asked
on
I have a DFI K6BV3+ motherboard, which have USB support onboard but doesn't come with the card-edge bracket. And I also have a couple of ASUS USB card-edge brackets that comes with some ASUS motherboards (USB/MIR rev1.11, USB3P rev1.00).

What I am wondering is that if they are supposed to be compatible, so that I can use the ASUS USB bracket on the DFI motherboard? The pins on the motherboards looks the same.

P.S. I tried it before but at that time it didn't seem to work. So I'd like to make sure whether I was missing something or it really isn't compatible.
Comment
Watch Question

Quid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT
Commented:
The answer is probably Yes and No.

What you need to do is get a map for you Motherboard on how the USB pinouts are laid out on your motherboard.  You also need to get a map of how the pinouts are laid out for your ASUS brackets.  Quite probably you will find a pinut for an ASUS motherboard is required.  Compare the two and you will most likely find they do things differently.

There are at least three or four ways that the cables that go into the USB blocks that plug into the motherboards can be arranged and another three or four ways that the pins on the motherboard can be arranged.

You need to see if your cabling that goes into the USB blocks is compatible.  You have tried it and it seems not to be.  You now need to see what is the correct cabling layout.  You can remove the cables from the blocks carefully by pulling and depressing the lock dimple in the side of the block.  The cable should come free.  You can then reinsert the cable and the dimple will lock the calble in place.

Been there and done that but in my case I was adding USB support to an ASUS.
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
This site goes into the subject in depth.  Highly recommended.  I used it to fix my USB up.

http://www.usbman.com/Guides/BelkinMotherboard_cable_assembly.htm
First check your USB controller is being seen in device manager, it should be there whether you have the cables installed or not. If it is not try enabling it either in BIOS setup or with an onboard jumper depending on how your mobo does it. If it is enabled and still not being seen, try installing the latest motherboard driver package. Now try messing with the cables.

BTW I assume you are using at least win 95b with USB support package installed?

regards,

Road Warrior

Explore More ContentExplore courses, solutions, and other research materials related to this topic.