We help IT Professionals succeed at work.

Installing IRIX on a clean disk

crash020297
crash020297 asked
on
Hello,
when I try to run the installation tools from the PROM menu it gives me an error about not finding a corrent partition or something like that and then returns me to the PROM. I'm upgrading the disk to 4gb and I have IRIX on a 1.5gb but there isn't any room left on the drive and I would like to use the 4gb instead. I've initialized the 4gb disk and I have tried writting to it and it works but when I remove the 1.5gb disk I can't load the OS. I'm hitting escape to get to the PROM...should I just let it turn itself on before and wait for something to happen.
Thanks for your help,
Chip
Comment
Watch Question

Top Expert 2005

Commented:
I don't know how you initialized the drive, but I suspect that it has been initialized as a data disk rather than as a system disk. There may be other procedured that will work, but the way I do it is to configure the new drive for the same SCSI ID as the original system disk, replace the existing system disk with the new disk, and then follow the procedure documented in the IRIX System Administrator's manual for partitiioning and labeling a system disk.
CERTIFIED EXPERT

Commented:
depending on your hardware, IRIX has a limitation of partition sizes, IIRC its like:
   Indigo  1.5GB
   Indy    4 GB
   Indy2   8 GB
The problem is that mkfs fails to handle this size, there is also a problem with the filesystem type, AFAIK only efs works with larger partitions, but not xfs.

So, depending on your system type, you need to partition you disk in the boot monitor (according max sizes, see above), format it and mkfs a efs filesystem, then installation should work.

Author

Commented:
This is interesting.
When I posted this question I was having trouble with a 4gb disk on an INDY and now I'm also having this problem on a MUCH bigger disk in my OCtane. It just so happens that I'm also using the same external CD_ROM to try and install IRIX.
I haven't tried using my O2's cdrom remotley yet though.
I've been reading up on this like crazy and every turn I take is a wrong one.
How would you go about initializing a disk as a system disk? I can't use my 4gb disk for the INDY in my O2 or my Octane but I think that right now my most important issue is the Octane. I have IRIX installed and running on my O2 so I still have access to IRIX in some form. My BIG disk though won't fit into the O2 drive slots so I'm out on an island with that.
I'm making a lot of mistakes and learning much here in my quest for IRIX fresh installation nirvana.
I think that my best bet at this point might be remote folder. Though I'm not sure what to do.

Commented:
Try putting the new hardrive in the lowest drive bay on the Octaine.  IRIX normally trys to mount that as /dev/root as default.  If you suspect that your external CDROM is bad, try bootp from your O2.  You have to turn on bootp and make sure you have a guest account with the password set to null.  At the BIOS menu select the boot from network option and type in the ip address of the O2.  Sorry about all the holes in the "how to" but I gotta run.   Hope this gives you some options to look into.

Rob

Author

Commented:
does NFS have to be installed inorder for me to perform remote install? I've shared my cdrom drive on my O2 but when I try to perform a remote install on my Octane. I enter the IP of my O2 and then the directory /CDROM/dist. I read something about tftp as well. How can I check to ensure it has access to my cdrom drive...or at least the /CDROM/dist folder and everything under it.
I feel shortwired at the moment...but I'm spending a lot of time trying to understand this and the documentation is so hard to sort out. I never know if I'm looking in the appropriate places for anything.

Author

Commented:
By the way I figured out the INDY thing...I wasn't aware of the need to fx a clean disk...that solved everything!
THanks,
CHip
Commented:
Looks like you solved your problem.  If you want to get bootp working here is what you do:
- check your /etc/inetd.conf and make sure bootp and tftp are not commented out. (remove the #)
- check /etc/passwd and make sure there is an account called'guest' and it's password is blank:
guest::998:998:Guest account:/usr/people/guest:/bin/csh
- Make sure both boxes are on the same subnet.  Bootp is supposed to work over across subnets but I've never got it to work.
- Stop and restart the network
      /etc/init.d/network stop
      /etc/init.d/network start
General comments:
- I can't remember if you need to 'exportfs /CDROM' to allow acess to the cdrom but you might give it a try if it still doesn't work.
- Bootp uses tftp to push the sash (minikernal or what ever they call the thing) to boot so you have to have that working as well.
- Also try to boot it using the destination as /CDROM/dist/sa (on the irix install cd).  That is the actual sash.  It maybe unable to find it without the full path.

Anyway play around with it.  Once you get a bootp server working, its a real handy deal. I load code to all my machines across the network using the CDROM and the servers harddrive.  Hope this helps.

Rob

Author

Commented:
YEAH!!!!
I've got IRIX up and running on my Octane!
Thank you Rob for all your suggestion and help.
Before I give you all the points and accept your answers I was wondering if you could help me with one more thing...or perhaps explain something to me.
I'm using one of those linksys routers that you can get at bestbuy to share my cable modem connection. It has DHCP built in and for obvious reasons you can't do much by way of configuration other than decide the segment of addresses it uses to assign IP's.
Now that my Octane is set up I'm trying to get it to use DHCP. Well it gets its IP and DNS IP's from the little router but it still can't resolve any domain names...which is obviously annoying because I can ping ip's outside of my network (which is more that I can do on my O2).
Do you have any suggestions for fixing this? I guess there is something I don't know about setting ip IRIX workstations to use DHCP. My linux machine has no problem whatsoever using DHCP with this linksys router thing.
Whether or not you can help...thank you for helping with the setup issues I was having. I'll be happy to accept you comments as an answer one way or the other.
THanks a bunch,
CHip

Commented:
Hum, well I only use static IP's on my network so I'm not sure if IRIX will let you 'DHCP' the DNS config (like Microsoft).  The static config file you are looking for is: /etc/resolve.conf and it should look like this:

#hostreorder local nis bind
nameserver 10.1.1.1
nameserver 10.1.1.2

The hostreorder line (you may not have it if you are using the default order) specifies in what order internet names are resolved.  Our network uses 'local' (/etc/hosts), NIS, and then bind (DNS).  The first nameserver is the primary DNS.  The second is the backup.  You can get more info by 'man resolv.conf' or going to http://techpubs.sgi.com/ if you don't have the manuals installed.

Author

Commented:
THank you for all of your help Rob.
See ya later,
Chip

Explore More ContentExplore courses, solutions, and other research materials related to this topic.