We help IT Professionals succeed at work.

Problems with search page

jimenez
jimenez asked
on
When I installed FP server extensions over a Win NT 4.0 and then create a Search web page my searches goes ok.
Now Ive installed Windows 2k and when I create a search web page whit FP2K and I try to run a search, I recieve a message that the service is not runing, Ive installed MSSQL SERVER that Office 2K becomes with.
I dont know what could be happend.
Thanks
Comment
Watch Question

You still need to have some kind of Web Server Running AFAIK....PWS would have been installed with your NT.  Do you have PWS?

Author

Commented:
Im not using PWS, and Im using W2k Server edition, sorry if I wasnt clear.
This means that Im running a web server, IIS 5.0, and FP server Extensions,  Am I right ?
Or I still need to use other software?

 
I think you still need to install the server extensions for w2k separately.

Commented:
You might want to check and see if the Indexing service is running.
 
1. Goto Start|Control Panel | Administrative Tools | Services
2. Check the status column for "Indexing Service" and see if it is running. If it is not running Right Click on the service name and choose "Start"
3. Also, check that the "Automatic" is listed in the Startup Type column. If it is not the service will not start when the server is booted.  Double click on the service name and change the startup type in the drop down list to automatic.

If this is not the problem. Go to the event view and see which service is being requested that is not running.  Then follow the same steps above for that service.

Good luck!

Author

Commented:
Ok, I did that and no message appears, but now I Have no results on my search page.What else do I need ?
It is possible to restrict the search over one virtual directoy ?
Thanks again

Commented:
You can restict your searches by using the "Index this resource" check box in the Internet Services Manager.

1. Open the ISM by clicking Start |
Programs | Admin Tools | Internet Services Manager
2. Exapand you computer name until you find the website you want. (Usually "default website")
3. Right click on the website name and select properites
4. Click on the "Home Directory" tab.
5. In the middle pane look for the check box labeled "Index this resource" If this is checked you entire site is being indexed. If you uncheck it you can drill down through your site and choose the directories and folders you want indexed by following the steps above and checking the "Index this resource" box.

Once you check or uncheck a "Index this resource" box the Index service will automatically add or remove the pages from the catalog. You can see what directories are being indexed by opening the index service.

1.  Open the indexing service by clicking Start |
Programs | Admin Tools | Computer Management and expand "Services and Applications"
2. Look for "Indexing Service" and expand it.
3. Look for "Web". This is the default name for the catalog used to index an search your site. Expand the "Web"
4. Click on "Directories" This will give you a list of all of the directories that are being indexed.  Make sure the icon for each one is a folder with a blue world on it. If  there is no blue world the folder is not visable to the web.
5. Go back to ISM and add or remove any directories you don't want.
Note: It takes index server a long time to index a site with a lot of documents. So if things don't show up in your search right away don't be surprised. You can check its scanning progress by clicking on "Indexing Service" in Computer Management. The right hand pane will give you the "status" of your catalogs.

Good Luck!


Author

Commented:
Thanks for your detailed explanation.
My folders under the indexing service doesnt have the blue world on it.
Ive checked the site and all the virtual directories and all they have the "Index this resource" option checked.
All my web pages and virtual directories are located not under the wwwroot directory, some of them are on the C:, D: etc directories, could this affect to make this folder not visible for the index service ?
Thanks Again!!

Author

Commented:
Thanks for your detailed explanation.
My folders under the indexing service doesnt have the blue world on it.
Ive checked the site and all the virtual directories and all they have the "Index this resource" option checked.
All my web pages and virtual directories are located not under the wwwroot directory, some of them are on the C:, D: etc directories, could this affect to make this folder not visible for the index service ?
Thanks Again!!
>>All my web pages and virtual directories are located not under the wwwroot directory, some of them are
on the C:, D: etc directories, could this affect to make this folder not visible for the index service

That would be correct jimenez.....index service cannot see anything (AFAIK) that is not in a virtual directory.

Commented:
Commented:
As long as there is a folder listed in the Internet Service Manager that is pointing to the folder your web pages are in, then they should be on the web.  I am assuming you can see the pages by going to the pages' URL. If so, Index Service should be able to catalog them for the web.  Check the permissions on the folders and make sure System has Full Control. Then try opening the "web" section in the  Indexing Service. When you get the directory listing showing in the right pane, right click on a directory and choose All Tasks | Rescan (Full)  
This should rebuild your catalog.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.