We help IT Professionals succeed at work.

problem about redhat7.0 installation

10point
10point asked
on
Hi

redhat7.0 works fine in my old Pentium200 computer.But when I buy a new computer with thunderbird with ide 40G ibm harddisk,it doesn't.

It cant probe my logitech usb mouse,my winfast mx200 AGP card dont past the X-window test either.I can just use the test mode to install.
After I install the package and before make the bootdisk,an error message appears and soon be covered by the next window,so I cant read it clearly.I just read the words about "large liner storage error".And the lilo doesnt install correctly.Also I turnoff the first liner storage surpport for the scsi disk,the
result is the same.And the installation can be continue.Then my display card cant past the x-window test.Then reboot and the linux doesn't work. And the bootdisk doesnt work either.

help me please.

thanks.

Cong


 
Comment
Watch Question

Commented:
See if this works -- When asked to test your X set-up,choose skip. Your machine will hopefully boot into console mode (run level 3). Then you may have a working Linux system available to diagnose the problem. Configuring the GUI can come later.

Author

Commented:
The major problem is I can not boot the system.

While using a rescure disk,linux boot with "error 0x10".That's all it can respone.

Commented:
Does the installation run to completion?
Top Expert 2005
Commented:
My guess would be that you've violated the 1024 cylinder restriction when installing Linux by making the / file system too large (assuming this is a pure Linux box). The easy fix is to reinstall Linux, making a small (~20MB) /boot area as the first partition on the disk. The other file systems can then be of any size desired.

As noted above, you can skip the X config section when installing and configure X one the system is up and running. But, before attempting to configure X you should probably check to see if that video card is supported. I don't recognize that card, but it might use some chipset that is supported by XFree86.

Author

Commented:
Thanks your answer.It might work.
But I dont want to fdisk now cause my 40G harddrive had been seperated into 20G NTFS(MRB)+5G FAT32.Other is planed to install linux.

Author

Commented:
The installation run to end.But the lilo not install

Commented:
I'm thinking that jlevie is right, you need to ensure that your kernel image is in the first 1024 cylinders on your disk. Loadlin my be an alternative but I've never worked with it.

Author

Commented:
My computer can boot into linux now.It's my floppy's ploblem.Now I can boot from disk with lilo into linux and windows2000.

I want to boot from the windows2000 loader.So I follow the howto to do it.But when I use
dd if=/dev/hda6 of=/bootsect.lnx bs=512 count=1
the file bootsect.lnx is full of 0x00 and cant boot.

My disk is partition into hda1=windows2000 hda6=linux.

Author

Commented:
I solved this ploblem.
It should be /dev/hda.

But my x-window still doesnt work.

My Geforce2 mx200 display card cant pass the Xconfigurator Xwindow test.

The error says:
(EE) No device detected
Fatal server error
no screens found

Commented:
My Geforce2 mx200 display card cant pass the Xconfigurator Xwindow test.

http://www.xfree86.com/4.1.0/Status22.html#22

Make sure you have xfree86 version 4.10 installed so that your card is detected.

Commented:
My Geforce2 mx200 display card cant pass the Xconfigurator Xwindow test.

http://www.xfree86.com/4.1.0/Status22.html#22

Make sure you have xfree86 version 4.10 installed so that your card will be detected.

Author

Commented:
I download the nvidia driver for linux in it site and install successfully.It works.The Xwindow runs fine.

But when I finish install XFree86 4.1.0. The fonts of Xwindow all turn into rectangle.I cant see a sigle letter.

How to fix it?

Explore More ContentExplore courses, solutions, and other research materials related to this topic.