We help IT Professionals succeed at work.

Start up problem

zchuss
zchuss asked
on
Medium Priority
139 Views
Last Modified: 2010-04-13
Win2K SP2.  Hardware: AMD Tbird 1.2/Asus A7V133/IBM 75GXP 30G HD (FAT-32, no partitions).

I was upgrading software (ZoneAlarm) from previous version to latest version v. 2.6.357.  Was logged on as Administrator.  Upon re-boot in order to complete the install process, I accidentally logged back on with my User account.  Win2K didn't like this one bit.  The BIOS loaded, found the HD, Win2K started to load (the desktop appeared) but Win2K would not complete loading - it froze before all icons and desktop completed appearing, and the HD began making repetitive noises at fixed intervals.

I suspected a file structure problem, i.e., some system files got blown out during the botched install of the ZoneAlarm update.  I first tried to re-boot in SafeMode -Last Known Good Configuration.  The system then appeared to enter 'fix' mode where it checked the disk for errors.  There were some messages there, but the screen did not stay up long enough for me to read the entire message (I did notice however the first item listed was 'BOOTEX.LOG 1st Allocation Table is Not Valid').  

I tried normal re-booting several times but Win2K kept hanging at the point just before completing the desktop, and HD making same reptitive noise, as if seeking but not finding something.

Any ideas, tips or suggestions are most welcomed.

Sincerely,
Dan
Wellington, Florida
Comment
Watch Question

Commented:
Try booting in Safe Mode (but don't select last know good configuration)... If it boots this way, then it's probably something to do with one of your startup programs misbehaving (I would suspect ZoneAlarm since you were working with that last).
If you do manage to get a complete boot in Safe Mode, reapply the Service Pack 2 to bring all your system files back in line.

Another suggestion, if your Win2k installation disk is already SP2, is to boot from the Windows CD and run a repair on the system. This will also reapply SP2 level system files that may have been replaced or corrupted...

Good Luck!

Author

Commented:
Ok, thanks.

I can boot into safe mode.

But how do I re-apply SP2?

Originally I did via the MS Windows update site.

I do not have the SP2 disk.

Could I connect to and use the MS Windows update site in safe-mode, do you think?

??

Thanks again.

Author

Commented:
Ah-ha.. I just checked. Yes, I can connect to Windows update while in Safe-mode.

However.. it's showing that I already have installed SP2.  Should I install SP2 right on top of the old SP2?

Thanks.

Author

Commented:
I downloaded the SP2 Express installation package from MicroSoft, and then attempted to run under safe-mode.

I received the following error message:

'The RPC Server is Unavailable - Service Pack Was Not Installed'


Any ideas?

In advance, thanks.

Author

Commented:
And now it appears that I can ping any site (from the command prompt) expect for   www.microsft.com


hmmm the plot thickens..

Commented:
As far as the pinging of microsoft goes, it can't be done... We do the same thing on our corporate connection. We simply do not respond to ICMP (Ping) packets. Not a problem, just a security tweak for their servers. When a site/server doesn't respond to a Ping, it will usually be passed over by hackers doing "sweeps", and will increase the chance that your server will not be singled out for attack...
Microsoft's Express installation is convenient, but I don't recommend it. If possible, download the entire service pack as a self-contained file. I believe they call it the Network Install version, or something along those lines. The full download is pretty hefty! It runs around 100+ MB, so Hopefully you have broadband!
This should get you there:

http://download.microsoft.com/download/win2000platform/SP/SP2/NT5/EN-US/W2KSP2.exe

The RPC message may or may not be related to the fact you are in safe mode and trying to use the Express install. Try downloading the full Network version of the service pack, and yes, install it right over the one it claims is already there. If you get the same RPC message when doing this install, then there is something else going wrong.
Disable/unload ZoneAlarm (even uninstall it, if neccessary) once you are in Safe Mode to make sure it is not interfering with any processes that may be running... Try disabling or unloading it (ZoneAlarm) first. That way you won't have to go through this all again when you re-install it...

Keep me updated! Good luck!

Author

Commented:
Guys, I just want to let you know that I solved my problem as follows.  I downloaded msconfig.exe and used it on Win2K to sequentially load my applications until I could determine the source of the problem, and then I removed the offending application and = walla = the machine is back to normal again..

Thanks for you help and suggestions..

Regards.

zchuss

Commented:
Ah... Like I said earlier... It was a misbehaving startup application! Was it ZoneAlarm or another one? I'll assume it was NOT ZoneAlarm since you did not specify it.

Commented:
BTW... Where did you say you downloaded msconfig from?

Commented:
zchuss, as per my comments to you in question # 20170472

ComTech
Community Support Moderator

I'm waiting.

Author

Commented:
i downloaded msconfig.exe from www.ipkonfig.com

the offending application was not zonealarm.  

as to question # 20170472, i'm not sure what the question is.

thank you, all.

zchuss

Commented:
Hello CyberGar, this was mistakenly awarded to me.  I will create a question for you in this Topic Area for 100 points for the correct answer.

Best regards,
ComTech
Community Support Moderator

Explore More ContentExplore courses, solutions, and other research materials related to this topic.