We help IT Professionals succeed at work.

Unable to detect hard drive after setting up dual boot system

Hi all,

This may not be the most difficult of questions, but it has me stumped for the moment.  
I've installed a system with both Win 9x and Red Hat Linux 7.1.  Like most systems, the boot sector has been replaced with lilio boot loader, so when I system starts, the user has the option of selecting the OS, Red Hat, or Win 9x.  

Here's the problem, I'd like to do a new clean install of Win 9x so I want to format the FAT32 partition and reinstall.  However, if I go through DOS, I cannot detect a CD-rom (needed for install).  If I try to start from a Win 9x boot disk then I can't detect the hard drive for some reason.  If I go to the dual boot problem and select the text option, I only get a "boot:" which will only let me map an image.  So, my question is how can I format the FAT32 partition on the hard drive and still detect the CD-ROM?
Comment
Watch Question

dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT

Commented:
You either have to remove LILO and install a standard master boot record or either add dos cdrom drivers to your config.sys and autoexec.bat.

Probably best is the first option.
CERTIFIED EXPERT
Top Expert 2007

Commented:
I agree. ALso backup your lilo config files and read up on how to install/uninstall Lilo.

You need to be able to boot from a floppy in an emergency, so learn how to get this working.

I hope this helps !

Author

Commented:
Sorry about the delay, computer was down fro some time.
The above may work, but how do I remove LILO from the MBR
and install a standard MBR?
Quid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT
Commented:
Get a Windows boot disk and put the fdisk utility on it.

Boot off the boot disk and type in the following and press Enter


fdisk  /mbr

Author

Commented:
Thanks for the help dbrunton!

Explore More ContentExplore courses, solutions, and other research materials related to this topic.