We help IT Professionals succeed at work.

peer to peer

moggy12
moggy12 asked
on
I just switched both of my computers over to win200 pro and one one of the machines i have my cable modem and a second nic card.  in the other i have a nic card and both machines are linked via a cable (not cat 5 but the other one).

Can anyone give me the instructions on how to set up a peer to peer network with these two systems?  All i want to be able to do is share folders, etc via the connection and possibly share the cable internet connection too.

Comment
Watch Question

Commented:
That's not hard, by default everything needed is installed by default in Windows 2000. Just make sure that the user accounts (including their passwords) are the same on both computers to avoid annoying logon messages when accessing shares on the other computer.

For the internet sharing, open the properties of the NIC used with the cable modem, and use the checkbox to share this connection on the "Sharing" tab. That should pretty much be it; note that the computer with the internet connection should be turned on before the other one since it will assign the other computer an IP address via DHCP.
CERTIFIED EXPERT
Top Expert 2007

Commented:
Beyond the great advice given so far.

1) Make sure that the IP and subnets are on the same subnet
use

ipconfig /all
to see that info.

Workgroup name should be identical on both machines.

Turn off any firewalls until you get this working.

Sharing a drive drive share  NT shares  NT file sharing
Permissions are set in two seperate places in NT and win2k.

   1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

    right click on the drive/file, choose properties - security - permissions. Give the person/goup full
      access.

       
OK, you need to add a new share rather than the default administrative share.

                   Add the new share -( there is a new share button at the bottom )  call it C-drv, set the permissions,
                   and that should solve the problem.

1) Add a new user on NT.
               2) Try logging into  the second machine/ station using this new user and password.

               
               Please note that the default shares on NT are not accessible, you have to create NEW shares !

If all else fails, enable the guest account !


See          http://www.practicallynetworked.com/
http://www.practicallynetworked.com/howto/
http://www.practicallynetworked.com/sharing/specialapps.htm 
Need to map the port, as you are using ICS (network address translation)
   http://www.practicallynetworked.com/sharing/icsconfig_maps.htm
  port list
  http://www.practicallynetworked.com/sharing/app_port_list.htm
http://www.sohointer.net/howto/
http://www.sohointer.net/top/kwe-faq.htm
http://www.onecomputerguy.com/networking/peer.htm
http://www.dslreports.com/information/rated/PPPoE
http://www.microsoft.com/windowsME/using/homenetworking/articles/default.asp
 www.speedguide.net
http://www.cert.org/tech_tips/home_networks.html Firewall and security for home and offices
Test firewall ports  and port blocking http://grc.com/
http://www.nipc.gov/warnings/computertips.htm

Author

Commented:
Thanks for the advice so far.  I have been trying to get this to work all this time and so far all failed.  I even re-installed Win2000 on both machines but still no luck.

So now what i have done is to have one machine as Win2000 and one as WinME.  I can now ping the machines ok and can even see them in MyNetwork.  The only problem i am having now is:

1: When i turn off the machine for a while (the Win2000 machine) and then turn it on it will lose the WorkGroup it belongs to and reverts back to the default one of WorkGroup.  Anyone know how to stop this?  

2: When i try to log in via the WinMe machine i get asked for a password - the problem is, i never set a password and did not set any setting to ask for one (i don't even see where to do that).  Anyone know what is going on here and how to solve it?

Sorry for the delay in getting back to this post but with all the work being done on my two machines i have been offline for a long time.  

CERTIFIED EXPERT
Top Expert 2007

Commented:
Strange.

1) Make sure that you are logging on as administrator on win2k.

Also try running a win2k repair/install.

2) In order to access shares on the win2k machine, you need to log in as a user that is defined on the win2k machine ( or use the guest account ).

To do an automatic login downlaod tweakui and use the login tab from tweakui in the cntrol panel.
 you can install the latest version v1.33 of TweakUi from Microsoft
                    http://www.microsoft.com/windowsme/guide/tweakui.exe
See tweakui in the control panel .


I hope this helps !

Author

Commented:
Thanks SysExpert - but how do i set up the WinMe machine to log in as a guest of the Win2000 machine?
CERTIFIED EXPERT
Top Expert 2007
Commented:
If you enable the guest acount on win2k, then anybody can access regardless of the login.

From: stevenlewis     Date: 09/29/2001 06:49PM
              OK, the "access denied" gives us a clue.
              Log on to the 98 boxes using the client for M$ networks as the primary logon, this creates the access
              token that the w2k box needs. then on the share(s) you have to allow the guest account access to the
              share(s), in the permissions, allow everyone full control
              also enable the guest account on the w2k box
              Click on Start/Programs/Administrative Tools/Computer Management. Look for Local Users and Groups       under   System Tools (on the left side), and expand it to show the two folders, Users and Groups. Highlight       the Users folder, and then you'll see the Administrator and Guest account. Highlight the Guest account,               and click on Action. Go down to properties, and on the General Tab for Guest Properties, you'll see            the box checked for Account is Disabled. Uncheck it
---------------------------
I hope this helps !

Author

Commented:
thanks sysexpert that seems to have done the trick - i got the WinMe and Win2000 computers to work together.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.