We help IT Professionals succeed at work.

Non-root User Login Problem

billwcc
billwcc asked
on
Medium Priority
370 Views
Last Modified: 2013-12-27
I have a Blade 100 running Solaris 8.  I created a normal user account that initially worked fine.  After setting this account up to use Netscape for email, I am now unable to login to this account.  As root, if I run "su - bill", I get the error message "No directory!"   If I run "su bill", the error is slightly different:  "su: No shell".

Both the user shell and home directory exist.

I have never seen this happen before in all my years with Solaris.  Can anyone shed a little light?

Thanks in advance for all info.
Comment
Watch Question

Commented:
Is user bill still in the /etc/passwd file ? Or is the passwd entry in some way corrupted ? The typical entry on solaris looks like this :

postgres:x:999:998:postgres user:/home/postgres:/usr/local/bin/bash

the field separator are ':' and there must be 7 fields. If the entry got corrupted (e.g. : within a field, making it 8 fields) then errors like you
describe may occur.

Hope this helps.
K.

Commented:
Hi !

Plz. check the /etc/passwd file for the user "bill". Ensuere that the home directory and shell are defined correctly.  Now go to the home directory of bill and see if he has got rwxr-xr-x permisions and if not then change it.

R. K.

Author

Commented:
Thanks R.K. and K.,

I did check /etc/passwd; it was good.  So was /etc/shadow.
I have also been talking with Sun tech support; as yet
no solution.

But thanks to you both for your help.

Commented:

Commented:

Commented:
Hi (4th try),

  try running "sotruss su - bill" to find out if there are any libraries missing.

K
Check if you have any white spaces after the shell like if you have /bin/bash__ (I mean _ is a space). Check that ane post your comments here. If you have trailing spaces then also you will have the same problem.

Try your luck
Kidambi
Hey it might be this way. The home directory might have been created. But, it may not be owned by the user. So, try checking the owner of the home directory.

GIRIX.

Author

Commented:
Commented:
try these

/usr/sbin/pwck
/usr/sbin/grpck

Commented:
billwcc - did you run the mentioned commands?
These will diagnose MANY problems within Solaris's password database.

Author

Commented:
Yes, did all the above, no go.
Even Sun's tech support drew a total
blank.  Lesson learned:  Let the nsmail
directory alone!

Thanks to all.

Commented:
One thing to remember (if ever you have a similar problem
is that solaris usually backs up the password databases to the following files:

/etc/opasswd
/etc/oshadow

can be very helpfull if you get into trouble with passwords.

Commented:
Is the home directory local to the machine? Are you automounting it from elsewhere?

Author

Commented:
yes, it is on the local machine--not
automounted.  Does a fix come to mind?

Commented:
Can you show us a copy of the password entry?

Commented:
It may be worthwhile copying the passwd and shadow files to copies and then opening them in VI
to check for control characters etc.

eg:

     [esc]:set list

as many control characters (such as TABs) will not normally be visible.

Commented:
Mmm. Good idea, festive.

Commented:
If its not solved:
Check your permissions on /usr , /usr/lib

Author

Commented:
Thanks to all for your info.  However, this problem
has nothing to do with the passwd or shadow file. Neither
has any control chars.  Perms everywhere are unchanged.
It was only after setting Netscape's mail spool directory to something other than ~/nsmail that the account got
locked.  And after doing that, ANY new non-root users
created also could not log in, no matter what.  The little
tweak to Netscape's default mail spool seems to hose the whole machine.

I personally think it's more trouble than it's worth.  From now on, I leave sleeping dogs lie.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.