We help IT Professionals succeed at work.

Failed in connecting from PowerBuilder to an Access database

Iulian
Iulian asked
on
I am trying to connect to an Access Database from PowerBuilder 6.5.

SQLSTATE=S1003
[Microsoft][ODBC driver manager]Program type out of order.

What could be wrong?
Comment
Watch Question

Commented:
Hallo lulian,

Actually connection between PB and Access Database depends upon the versions of the Access Database, Powerbuilder and the Version of the ODBC. I don't know which version of the Access Database or Access you are using and Which OS you have and ODBC Version.

Please let me know which ODBC Version you have and Access Version, may I find some results.

THANKS

Bhatti

Author

Commented:
PowerBuilder Enterprise/32 version 6.5 built 444

Access97 SR-1

I selected "Driver do Microsoft Access(*.mbd" from the instaled drivers in "configure ODBC" menu.

Commented:
Hallo lulian,


If you have PB version 6.5 built 444 then you need Access driver 3.50 which is  "odbcjt32.dll" from 1996 (may you have).  But if you have Access Driver 4.0(That you can see in the ODBC cinfiguration dialog box) then you need PB 6.5.1.

I don't recomend you to change PB version, But if you can install the access driver 3.5 in ODB Config.

I am afraid, But you know how you install the driver if you have.

I think you should have access driver 3.5 in some where(look in Explorar by search, where you have other drivers, for odbcjt32.dll from 1996).

THANKS

Bhatti

Author

Commented:
Hello Bhatti,

I looked for odbcjt32.dll and I found this file in c:\winnt\system32 folder but it is said it was created on December of 1999 not in 1996.

I forgot to tell you that I use Win2k server as a SO.

Thank you for your interest in helping me.

Regards
Iulian

Commented:
Hi,

File odbcjt32.dll from December 1999 is the Version 4.0 and the file with the same name "odbcjt32.dll" from 1996 is the version 3.5(what you need) from PB 6.5 (444).

What do you mean by Win2k as a SO?


THANKS


Bhatti

Author

Commented:
SO = Operating System.
Generally the new versions are compatible eith previous versions. What could I do in this case?
Commented:
Hallo lulian,

You are right, New version is compatible with the previous version, but I tested and found that PB 6.4 built 444 needs odbcjt32.dll from 1996(previous version). I think if you have privious MS-Office may you find there this file from 1996, or just look for this file in www.microsoft.com.

I am looking for better way, return you soon asap.

Bhatti

Author

Commented:
Well, I will try to find this version, because it seems to not be so easy and if the things work the points are yours.

Thanks a lot

Commented:
Lulian,

Sorry I wrote in my latest comments that PB Version 6.4 built 444.

Thia is not correct. PB Version 6.5 Built 444 is correct.


Bhatti

Commented:
Hallo Lulian,

Did you find the file and tested. Please let me know. THANKS


Bhatti

Author

Commented:
No, I haven't found it. But your answer seems to be correct because I found another comment on the internet which said the same thing.
So if you could give me a link(checked) to download this dll, it would great. Someone gave me such a link but it didn't work.

Anyhow your answer is corect so the points are yours.
Thank you very much.

Iulian

Author

Commented:
No, I haven't found it. But your answer seems to be correct because I found another comment on the internet which said the same thing.
So if you could give me a link(checked) to download this dll, it would great. Someone gave me such a link but it didn't work.

Anyhow your answer is corect so the points are yours.
Thank you very much.

Iulian

Commented:
Hallo Iulian,

I am looking for this dll, if I shall success to find let you know the download page.


Bhatti