We help IT Professionals succeed at work.

Installing Win98SE on a HP omnibook 2100 Laptop

bantams
bantams asked
on
I recently changed the HDD in a HP Omnibook 2100 laptop to a Fujitsu MHM2100AT 10gb HDD, and installed Win98se and drivers, other apps on it and gave it back to the surveyor it belonged to working perfectly.

have now received it back, completely trashed, surveyor said that he got an error on boot up saying Windows couldn't initialise VKD, and wouldn't load windows in either normal mode or safe mode.
then it stopped booting altogether, just gave a black screen after the post check.

I managed to get it to boot via a windows98se boot disk obtained from www.bootdisk.com and ran scandisk on the C: drive, it crashed after 1% completed.

so thought ok, format the thing, that failed after 1% completed saying not ready.

so went to fujitsu, and downloaded their Disk Manager Disk go software for preparing the HDD.

ran that and it formatted the HDD ready for win98se.
then booted the laptop with the win98se cd, and it gets to system configuration, it then gave an error message about regsvr32.exe and stopped, so i rebooted, and it came up with Windows couldn't initialise VKD.

I managed to install Windows NT4 workstation on the laptop with no problems, however our surveyor does not want windows NT4 on his machine as some apps he is using won't work on it.


any ideas how to get Win98SE on this laptop?

thanks

Comment
Watch Question

Commented:
Have you looked at the memory.  Sometimes flaky memory will cause this.  I would give you an article or two at the MSKB to use but the site appears to be down.  Look up PROTECTION ERROR at http://search.support.microsoft.com/kb/c.asp?fr=0&sa=gn&lng=eng
CERTIFIED EXPERT
Top Expert 2007

Commented:
I would suspect the win98 IDe drivers.
Did you get the latest HP drivers ?

Did you run a windowsupdate ?

Did you run a full diagnostic on the hard drive to see that it is not flakey ?

I hope this helps !
Sounds like maybe a HD problem.  Most likely Win98 loads differently than WinNT considering the fundamental differences in the two OS's.  I would try two things.
1. Partition the drive and try installing both OS's on both partitions and see what happens then.
2. Get another HD, it can be an old 2 GB drive or whatever, and just try to load the OS on it.  Once that works (if it does) you can do extensive diagnostics on the other drive by making it the slave.  That is one of the best ways to test a hard drive, it releases it from "mission critical duty."  In other words, it is not responcible for primary system startup and primary OS.  You might even want to try running a copy of 98 on both drives.  That may give you some more insight.  

All in all I think once you do those things there it should give you more information on the problem.  If it is found to be a faulty HD, then the solution is relatively simple and obvious..;-)  Hope this helps...

jitjester
JJ2Technical Manager

Commented:
Might be an MBR virus (spirit)that prevents windows98 from loading smoothly. I experienced the same symptoms though not on notebooks but on desktop PC's. Try checking it with an AntiVirus scanner(Norton 2002).

Author

Commented:
partitioned the HDD into 1 2gb drive to install WinNT, planning to partition the other 8gb through disk administrator when WinNT was installed, WinNT installed ok, and created the new partition through disk administrator, tried to format the new partition, failed instantly saying could read drive.

so d/loaded a HDD diagnostic program from Fujitsu and ran that against the HDD, it failed saying it was a unrecovered read error, so have placed a call with Fujitsu to sort out - the HDD is only 2 months old, so hopefully under warranty.

I'd like to know why I received a 'B' on this.  I gave you the steps to follow and the conclusion of a bad HD if those steps produced errors.  Do you think my answer was flawed?
CERTIFIED EXPERT
Top Expert 2007

Commented:
: jitjester  and  bantams . I actually suggested running a diagnostic on the hard drive first !!

In any case, I'm glad you got this solved !!

Explore More ContentExplore courses, solutions, and other research materials related to this topic.