We help IT Professionals succeed at work.

STICKYKEYS ACCESSIBILITY FEATURE UNINSTALL

ej00807
ej00807 asked
on
I cannot figure out how to uninstall the stickykeys feature from Windows 2000. I have turned it off repeatedly, but it keeps coming back.

The control pannel add/remove Windows features does not list accessibility functions. The registry doesn't seem to have any accessibility or stickykey entries. I've even tried third party registry tweaking utilities. The MS knowledglessbase doesn't seem to have any answers either. I've also tried running the windows setup disk, but it doesn't seem to allow removal of components.

If I hold down the shift key (which I have a tendancy to do when I'm thinking), this feature pops up a dialog box. Dismissing it has the added benefit of locking up my keyboard.

Comment
Watch Question

CERTIFIED EXPERT
Top Expert 2007

Commented:
The control panel should list accessibility options as the first thng in the list of sorted by alphabet.  If not, then I would first do a
sfc /scannow from a DOS box to fix any broken files.Reapply SP2 and this should solve the problem.
If not, it could be that the options were deliberately hidden or you have a virus.

I hope this helps !


CERTIFIED EXPERT

Commented:
In order to be able to list all Windows components that are installed perform the following:

Go to WINNT/INF folder
Find the file sysoc.inf
Open it in the notepad.
DELETE all the "HIDE" and "hide" words from the file.
Save the file.
Go to ADD/REMOVE programs once again.
You will have additional components there.

Author

Commented:
I've decided that it must be related to filterkeys instead of stickykeys, because a clock icon appears in the sys tray when this happens.

Getting into the accessibility options is not a problem. Getting rid of them is. Everything under keyboard tab is unchecked. Yet something still causes the filter key feature to pop open (sometimes) when I hold down a key too long.

I guess what I'm looking for are the .dll's that make up this feature, so that I can basically remove it all together.

Another possibilty I've considered is that something is resetting my user preferences for some reason.






ej00807,
At the Accessibility Options, keyboard, click the [settings] button of stickykey, clear the box for
[ ] Use shortcut.

You can also uncheck the box for
[ ] Show StickyKey status on screen.

OK, Apply.


Do the same for Filter Keys at the Settings button, clear the checkbox for
[ ] Use shortcut

You can also uncheck the box for
[ ] Show FilterKey status on screen.

OK Apply.

Close the Control Panel, changes will be effective.

If you still got the Prompt windows, checked the box
[x] Turn off keyborad shortcut for this accessibility feature
And DON'T click [OK] but hit the [CANCEL] button.

It should switch off.

See if this helps.

Patricia / pslh

Author

Commented:
Right on! Who would have thought to look under settings for something that is suppose to be shut off.

I probably rest on the shift key a bit, causing the shortcuts to activate.

Thanks bunches pslh!
<<Who would have thought to look under settings for something that is suppose to be shut off.>>

<grin  ;O)   >

Glad to hear that solved.

Patricia

Explore More ContentExplore courses, solutions, and other research materials related to this topic.