We help IT Professionals succeed at work.

printing problems with RH7.2 and HP820cxi

emherman
emherman asked
on
I have a RH Linux 7.2 box under KDE that I am trying to get to print to a HP820cxi. The driver is there and I have it installed but I can't get it to print (or do anything). I have even tried some basic LPR commands, but being at the newbie 2.0 level, I'm sure I have missed something.

How can I make this print (correctly)?
Comment
Watch Question

Commented:
Hi,

so what does your system anwer if you question it with

root#  lpc status all  

Please post the output here.

Also, before we examine your systems software configuration for possible bugs,
please do a quick check on these areas:

hardware:  Printer supplies, parallel port connectivities in & outside your box.
BIOS: no IRQ conflict & parallel IRQ adressed correctly

Author

Commented:
that yielded:

bash: lpc: command not found

I also checked the bios info regarding the printer and it appears to be correct.

Commented:
bash: lpc: command not found ???

HUH, the local printer demon & it's commands for queriiing the queue did still exist in
Redhat 6.2 & 7.1. Because I don't have 7.2 installed it is a bit difficult right now
to verify what has changed . . .
Does the complete path
/usr/sbin/lpc status all  
yield anything ?
Or any result with lpq instead ?
You say you have tried basic LPR commands, so the printer demon & set of related commands
should exist.

Any more details on how you did install the driver for your HP ?
Please mind information at http://www.linuxprinting.org/show_printer.cgi?recnum=61568

Author

Commented:
ahh yes the full path..

"/usr/sbin/lpc status all" yields:

Printer//Printing//Spooling//Jobs//Server//Subserver
HP820c@pig//enabled//enabled//0//none//none//

lpq yielded:

Printer: test@pig
 Queue: no printable jobs in queue
 Status: removing job 'cfA500pig.sis.com' - JREMOVE at 20:29:26.824

If I try to print to the printer I get the "removing job" error. ????

Since this is a workstation, I was trying to use all the graphical tools at my disposal. I used "K">System>Printer Configuration which brought up printconf-gui. I used the "wizard" to help set this up. The HP820c was represented by two driver options. I took the top one.

Commented:
> If I try to print to the printer I get the "removing job" error. ????

No, it's not an error. You printer has to sneak anything down the pipe in order to query your print setup.
So it appears as a standard procedure which redraws that ' test job ' after lpc has been performed.  

What puzzles me is that, concerning your system information,
nothing really seems to be wrong with your print setup substantially.
Per your information:
- hardware ok
- BIOS setup ok
- print setup ok

What's left ?  Well, let's say it like that: many things in a Linux system can be approved ' virtually ',
without actually giving a result in ' physical reality '= anything on a piece of paper for instance.
So, ' internally ' it could well be that the print setup is all fine up to the ' virtual ' device /dev/lp0 but from
hardware side it might be that 'behind' /dev/lp0 is anything exept your printer.
Especially if you do have several parallel ports at your machine be sure that you don't get them mixed up
within Linux:
LPT1 = /dev/lp0 !
LPT2 = /dev/lp1 !

I once had my zipdrive at /dev/lp0 with my print setup pointing to the same device:
Local Printer at /dev/lp0
Of course, because there was a device at the printer port it could actually send = print files
to /dev/lp0 & from internal point of view everything seemed ok but my printer, physically related to
/dev/lp1 stood dead silent, desperately waiting for any print commands arriving at his port.

Author

Commented:
Ok I think we are moving closer. I still can't get it to print, but I think that it is in the GUI Print Configuration setup something is getting dropped.

Here is my /etc/printcap:

# /etc/printcap
#
# DO NOT EDIT! MANUAL CHANGES WILL BE LOST!
# This file is autogenerated by printconf-backend during lpd init.
#
# Hand edited changes can be put in /etc/printcap.local, and will be included.

test:\
     :sh:\
     :ml=0:\
     :mx=0:\
     :sd=/var/spool/lpd/test:\
     :af=/var/spool/lpd/test/test.acct:\
     :lp=/dev/lp0:\
     :lpd_bounce=true:\
     :if=/usr/share/printconf/util/mf_wrapper:

 epson|Epson880:\
     :sh:\
     :ml=0:\
     :mx=0:\
     :sd=/var/spool/lpd/epson:\
     :af=/var/spool/lpd/epson/epson.acct:\
     :lp=|/usr/share/printconf/util/smbprint:\
     :lpd_bounce=true:\
     :if=/usr/share/printconf/util/mf_wrapper:

 HP820c:\
     :sh:\
     :ml=0:\
     :mx=0:\
     :sd=/var/spool/lpd/HP820c:\
     :af=/var/spool/lpd/HP820c/HP820c.acct:\
     :lp=/dev/lp0:\
     :lpd_bounce=true:\
     :if=/usr/share/printconf/util/mf_wrapper:

 raw:\
     :sh:\
     :ml=0:\
     :mx=0:\
     :sd=/var/spool/lpd/raw:\
     :af=/var/spool/lpd/raw/raw.acct:\
     :lp=/dev/lp0:


I really would like the epson 880 to print (via Samba) on my w2000 box. However, for this question, I would like this to print to my local port /dev/lp0. Can you see anythin wrong in the /etc/printcap? What are some basic line commands that I can use to test functionality? I tried "lpr" but maybe I botched my syntax.

Commented:
Hi again,

at first glance I would say that you have too many devices set for the queue option
LOCAL printer at /dev/lp0. Please refer to
http://www.redhat.com/docs/manuals/linux/RHL-7.1-Manual/custom-guide/printconf.html
for a proper setup.
If in doubt, remove all your printers & do a clean setup.
For syntax of 'lpr' type 'man lpr' to have
reference to accurate use of the command.

Commented:
Because I did a reinstallation of my printer on Redhat 7.1
I followed through all essentiel steps with respect to your
very own problem. this is what I#ve worked out for your
HP 820 cxi:

it works inn color only if you use the pnm2ppa printer.

In ' eddit queue ' > printer driver > printer
> postscript printer select your Hp from the list.
Then in ' Printer driver ' < driver options I strongly recommend to have
this option set active: ' Send EOT '.
Also I recommend to reexamine all your other settings,
such as Page size, which should be A4
& Choice of Ghostscript driver: ' Format for color images '

Again, make sure that the printer port is set right.
If unsure, type ' dmesg' at the console to get a
reliable info of all available devices at the
parallel port.

After you've made your chice, say OK
& back in printconf-gui open > File > Save Changes
& then ' Restart lpd ' . Wait until it's finished & then do
> Test > Print A4 Postscript TEst Page

Author

Commented:
The weird thing here is that I had a RH7.1 machine that this printer worked on. I have since upgraded to 7.2 and have not tried it on this machine. I was trying to make it run on a different computer (Gateway PII 350, 192MB RAM). I think I am going to reformat/reinstall the old junky computer to 7.1, get the printer running again, and figure out what makes it print. Then I will go back to the Gateway 350 and try again.

OK. I'll try your solution first, since that will save me alot of work if it does it. I'll give this a go in the next few days.

Author

Commented:
I ran "dmesg" and got this. Only the relevant area is noted:

[PCSPP,TRISTATE,EPP]
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38) Linux Tulip driver version 0.9.15-pre6 (July 2, 2001)
PCI: Found IRQ 11 for device 00:0e.0
PCI: Sharing IRQ 11 with 00:0c.0 tulip0: MII transceiver #1 config 1000 status 782d advertising 01e1. eth0: Lite-On 82c168 PNIC rev 33 at 0xcc868000, 00:A0:CC:3D:19:98, IRQ 11. eth0: Setting full-duplex based on MII#1 link partner capability of 05e1. parport0: PC-style at 0x378 [PCSPP,TRISTATE,EPP]
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
parport0: cpp_daisy: aa5500ff(38)
parport0: assign_addrs: aa5500ff(38)
lp0: using parport0 (polling).
lp0: console ready Installing knfsd (copyright (C) 1996 okir@monad.swb.de). es1371: version v0.30 time 17:36:47 Sep 6 2001


I would like to say I know how to interpret this but beyond the lp0 part, I'm kind of lost. I'll get you the results of the other parts when I get them done.
Commented:
Ok, what I can see there is that only one parport is reckognized at your machine which is:
your PCI network adapter card.
The reason is a simple IRQ conflict:
Look:

> PCI: Found IRQ 11 for device 00:0e.0   # 00:0e.0 certainly is your printers parallelport address  
> PCI: Sharing IRQ 11 with 00:0c.0 tulip0: # 00:0c.0 a different address (your network card) under the same
IRQ. It says it already: Right now it is 'sharing' the IRQ 11 with your printer.

So it looks as if on your new 7.2 setup there first was the network card assigned to IRQ 11 & then
later it hang up your printer to the same one because there wasn't any one else left.
In my experience Linux always sets priority to network recognition, but in your case it blocks
the 'normal' printer port.

Now, either in the PCI configuration of your BIOS alter the IRQ assignment for your various PCI slots,
so that it frees up one place for your printer or try it like this:

Physically remove your network card & reboot your REdhat &  set up your print configuration FRESH
after having removed ANY entries in your printconfiguration gui. Rerun your lpd. Once your printer is
working again, get your network card back to your machine.

That really should handle it.
   

Author

Commented:
I tried something even more radical. I plugged the printer into a dual-booting 7.2 machine that had a fresh install and it worked perfectly.

I then reformatted/reinstalled 7.2 on the PII350, that I have been trying to get working and it works now. Apparantly, something gets lost in the upgrade from 7.1 to 7.2. I also had a 7.2 server which couldn't print either. It was a 7.1 to 7.2 upgrade as well. I reformatted/reinstalled with a fresh copy of 7.2 and it works great.

I also noticed the device conflict that you had pointed out and found eth0 conflicting with my embedded Creative Labs Ensoniq sound chip. I found that I by moving the ethernet card to the next lower PCI slot, it would come up with an IRQ of 10 instead of 11. Now there are no conflicts.

Commented:
Thanks for the good news,

glad you have finally reached to a success there

One tip from me with upgrades (i remember I picked it from a kernel news group once):
Always leave out one version number, i. e.
get 6.2, then 7.1, then 7.3 & so on, if buying the complete upgrade package.
If you do your kernel upgrades yourself, you of course do it step by step.

Personally I have best success with getting the latest 'Redhat summer releases' once a year,
such as 7.1, leaving out 7.2, next one 7.3 then.
For a reason I haven't found out yet, there seem to be much less bug reports with those
packagess that normally get released around july.
I assume that developers shouldn't allow to have themselves pushed into the annual X-mas rushes
 ; )

Seasons greetings & lots of fun wishes

Claus (xberry)  

Explore More ContentExplore courses, solutions, and other research materials related to this topic.