We help IT Professionals succeed at work.

FP 2002 ext on Apache 1.3.19 (apache-fp)

GrungyApe asked
Medium Priority
Last Modified: 2013-12-24
I'm stummped, and likely another word starting with stu....

I have put 97, 98 and 2000 on without this issue, but for some reason FP 2002 ext is causing this error when I try to connect with an FP windows client:

The requested URL /_vti_bin/shtml.exe/_vti_rpc was not found on this server.<P>

FP2002 ext are installed on an patched apache server running(1.3.19 with 2002patch)running on unix(linux 7.1).

I checked the files and perms and they are fine, the server has been restarted, and extended to enable publishing and content.  

You can hit the site fine in a browser, but nothing with a client!


Watch Question

I don't think you can run the necessary programs (one of which is what's not there) on Unix. They're Windows programs, designed to run on Windows.

AFAIK, using FP directly (connecting directly to the server) requires IIS.

Do the pages on your machine, then upload them. Use FTP to upload, it's easier.


Technically, this is incorrect.  

The UNIX extensions are designed for a unix environment and if set up correctly can accept a connection from a windows client.  

My main server works fine with FP 2002 extensions on a Solaris box connected to from my XP system and 2000 client at home.  The intent of providing these extensions is so IIS is not required.  They offer at least 95% of the same functionality on unix as they do on IIS.

In my case however, this instance of FP fails to want to work.  I have 2000 and 98 extensions running on other linux systems without issue.  Some with and some without the apache patch; yet, this set is being difficult.


Can you connect from another machine? At least then you could narrow it down to the client or the server.


Sorry it took so long.  No, it fails a connect from any other machine, but I can use my 2000 win client to hook to my main FP2002 unix server.

Is this the error you get when connecting to the ROOT web?
I am only getting this error with virtual domains on Server version: Apache/1.3.23 (Unix)
I have a feeling their is something extra needed in httpd.conf for the virtual domains to understand _vti_rpc.

If it is the root web I can lead you in the right direction on fixing that.
ok i got your answer but after EXTENSIVE research on my own.
I have been trying to get this working for 2 weeks on
Freebsd 4.4 stable
Apache 1.23
I am using apache13-fp from my ports collection just so apache gets all the modules installed right.

First things first..
something is totally messed in this latest version on front page extensions. It does not copy any of the files to your web root. (wich FPSE 4.0 DID)
you can either make a link for each web or just copy them over.
default install of FPSE 5.0
you need to
cp -R /usr/local/frontpage/version5.0/exes/_vti_bin /(your webroot)/_vti_bin/

this will put the extensions in the correct place.
make sure the user/group is correct on these files or it will not work.
chown -R nobody:nogroup _vti_bin/   "the nobody:nogroup" is what apache is using as user/group

Also in your http.conf file you need to make those DIRS script alias along with setting an option.
<VirtualHost *>
ServerName test.yourdomain.com
DocumentRoot /home/kenny/public_html/
ScriptAlias /_vti_bin/_vti_adm/ /home/kenny/public_html/_vti_bin/_vti_adm/
ScriptAlias /_vti_bin/_vti_aut/ /home/kenny/public_html/_vti_bin/_vti_aut/
ScriptAlias /_vti_bin/ /home/kenny/public_html/_vti_bin/
Options ExecCGI

also make sure when you are starting and stopping apache to use the new command
./apachectl start_FP

this should get your server backup and running..
now that my clients can stop complaining about extensions being broke.,.

have fun.

this line doesnt space out correctly on this web based stuff.
you need to
cp -R /usr/local/frontpage/version5.0/exes/_vti_bin /(your webroot)/_vti_bin/

cp -R (sourcefolder) to  (destincation)
there is a space in between  _vti_bin  /(yourwebroot)/_vti_bin/


Thank you!

It's been a while since I posted this and ended up just doing the FP on my PC and transfering it up, but after your post I went back through and it works!

Thanks Kenny, I'd all but given up.


Explore More ContentExplore courses, solutions, and other research materials related to this topic.