My Folder Properties are Gone!!

Hello. I am running Win2000 Pro, SP2. From the explorer and the desktop window, I can get properties for a file, "My Computer", and "Network Neighborhood". I cannot get properties for any drive or any folder. What is up with that? This could be as easy as searching MSDN or the MS KnowledgeBase. I just want my properties back. :)
Snakie1066Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NavidCommented:
Hi  Snakie1066!
Are you saying that the options "properties" are missing from the menu or you can't get detailed information about files?
If the property button is missing, I need to ask:
Do you have administrator access to your computer? The network administrator might have sat restriction for accessing folders and files.
If you have administrator access or there is a administrator profile you can access. Log on as administrator, Open Control Panel > User names and passwords and Tab advanced and give the other account, access to other file properties.
A guest profile can for instead not use property options.
If you are saying that properties are not displayed on explorer, all you need to do is to go in explorer "View", "detailed list"
GUEENCommented:
A few questions -
Do you have SP2 installed?
Do you have zone alarm installed?
Do you have IIS installed?
For firewall give explorer server access

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CrazyOneCommented:
Ok I suspect the "Properties" option is available on the menu list but when clicking on it nothing happens. Is this correct? If so did it just start happening? If so did this happen shortly after applying SP2? If so uninstall SP2 which is a bit difficult to accomplish. Mainly because there probably isn't any one thing specifically pointing to SP2 but there are several PRE-SP3 uninstalls which are the SP2 updates.

If this doesn't work you may need to revert back to prior registry. One way to this is at the point where when you boot you see "Starting Windows" hit the F8 key and then choose "Last Known Good Configuration". Chances are this won't do the trick since this only deals with the hardware in the registry settings ControlSet.

The other option is to boot to the Repair Console and copy from this folder

C:\WINNT\repair\RegBack

over to this folder

C:\WINNT\system32\config

these registry files one at a time and reboot.

DEFAULT
SAM
SECURITY
SOFTWARE
SYSTEM

I would suggest starting with the SYSTEM file first and then the SOFTWARE file. Note there are no file extensions on these files.

Before doing this while in the Repair Console make a backup copy of the afore mentioned files that are in the C:\WINNT\system32\config folder in case the method I suggested causes problems you will still have  the current registry files to put back in place. Note that when using the files in C:\WINNT\repair\RegBack may set your system back to the state it was from sometime back. Look at the dates on these files and you will know how far back they go.

In the future I would suggest to use the Start > Programs > Accessories > System Tools > Backup program to backup the registry when you know it is in a good state on a regular basis. To do this migrate to the "Welcome" tab and then choose "Emergency Repair Disk". When the next Window pops up check the box "Also backup the registry.....". Don't do this now because it will overwrite the files in the C:\WINNT\repair\RegBack.


The Crazy One
Get a highly available system for cyber protection

The Acronis SDI Appliance is a new plug-n-play solution with pre-configured Acronis Software-Defined Infrastructure software that gives service providers and enterprises ready access to a fault-tolerant system, which combines universal storage and high-performance virtualization.

CrazyOneCommented:
BTW did you install Win2000 as an upgrade over the top of another Windows or was this a clean install?
embCommented:
I've had this problem on and off with my machine on numerous occasions.  Sometimes it only affects network files, sometimes both local and network files.  Sometimes it works but only after a long delay - select file, properties, wait 2 minutes then the dialogue appears.  Reapplying the service pack is worth a try (it worked once for me, but not on other occasions).

emb
Snakie1066Author Commented:
Navid: Properties is showing on the menu but selecting that menu item has no effect. The window I select properties for a folder from loses focus, as if some other process has grabbed the focus and wants to do something. I am the admin on this computer and I haven't played with the security settings for months. You had a good idea about trying a different user. I logged in as a different administrator (also only for my use) but I found the same problem. However, your comment gave me the idea to check through security properties via command line and I might do that later. Finally, the problem is for folder properties, not details on folder contents. Thanks for your comment.
Snakie1066Author Commented:
shekerra: I do indeed have SP2 installed but it has been installed for quite a while with no problems. I do also have Zone Alarm installed and I did install it right around the time the problem occurred. I have IIS installed and it too was installed around the time the problem occurred. I tried shutting down ZoneAlarm and getting properties, with no effect. I wouldn't think that ZoneAlarm continues to watch ports, even after it is fully shutdown from the systray, but I am not sure. I tried getting to IIS config from computer management and the MMC hangs when I click to expand the services node. Hmmm... Maybe it is IIS. I believe that IIS was installed after SP2, and I haven't been doing much Computer Management as of late. I will try removing IIS.
GUEENCommented:
Also check security templates (MMC) compatws and see what is listed for 'take ownership of files or other objects'
And also from MMC - if you don't already have the 'security configuration and analysis' snapin - add it
Snakie1066Author Commented:
shekerra: I uninstalled IIS and then I could get properties for folders, etc. I reinstalled IIS and had the problem again. I will try your additional suggestions. Thank you for your time.
Snakie1066Author Commented:
shekerra: I uninstalled IIS and then I could get properties for folders, etc. I reinstalled IIS and had the problem again. I will try your additional suggestions. Thank you for your time.
Snakie1066Author Commented:
shekerra: my setting for "Take Ownership of Files or Other Objects" under COMPATWS.INF is NOT DEFINED. The Security and configuration analysis snap-in for the MMC shows my "Take Ownership..." setting as NOT DEFINED in the database settings, but as ADMINISTRATORS in the computer settings. I am not too familiar with applying these templates. Is this the problem, though? The Computer Management Console is hanging once again whenever I try to expand the services node (which includes the IIS management snap-in, now that I reinstalled it). When I had IIS unistalled a little bit ago, Computer Management was just fine. Is it the IIS snap-in? Will reinstalling SP2 help? I thought that components would draw newer files from the SP if present to eliminate the need for reapplication of SPs. Thanks again - I had no idea the prob would be this complex.
GUEENCommented:
Test With IIS installed -
Try this:
In ZoneAlarm 'Configure' tab, disable "Load ZoneAlarm at startup".
<removes the TrueVector service> and verify by checking  services You'll still be able to use ZoneAlarm but  it may be that TrueVector service messes with W2K functionality.
Also check ZA site:
http://www.zonelabs.com/services/support_issues.htm
GUEENCommented:
If take ownership is not defined - don't worry about it as I think it is really a ZA problem at this point in time.
GUEENCommented:
Another thought--
Run this at commandline:
C:\WINNT\System32\iisreset.exe
GUEENCommented:
Hmmmm it might be that when you open up the properties that it makes an RPC to IIS and ZA shuts it down.
Snakie1066Author Commented:
IIS is installed again. As soon as i do the IISRESET and NT finishes stopping the services, all of the queued folder property requests are fulfilled. Also, as the services were stopped, the Comp Management MMC node for services expanded. As soon as the IISRESET began starting the IIS services again, further property requests and nav in services portion of the Comp Management MMC failed. These things must have been hanging because of some IIS thing that was stopped by zone alarm. I am going to try disabling TrueVector now.
AvonWyssCommented:
If you installed SP2 using the express install and added IIS (or other windows components) later, so it might be adviseable to re-install SP2 so that the SP2 files for the newly added components are also downloaded and installed on your system. This is not needed when the SP2 network install was used, because this always installs the whole SP2.
Snakie1066Author Commented:
Fantastic! Thank you very much for your help, shekerra. Indeed, the total problem was that ZoneAlarm's TrueVector service was causing problems for IIS's www publishing, ftp publishing, and SMTP services. I was able to set these services to manual startup and then to start them at the correct point in time after I had logged in. If this box had to boot up and serve pages or FTP without any intervention, I would have to do some more work. This solution is just fine for this problem, though. And now I have my properties back, and my IIS snap-in MMC is accessible. Thenk you again, shekerra. :)
GUEENCommented:
You are welcome snakie -
Happy to hear that you are back up and running!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.