We help IT Professionals succeed at work.

formatting a disk

mkhalidmn
mkhalidmn asked
on
i have faced  a problem when i wanted to format my floppy disk ... when i want to format in Dos this massage appears

Checking existing disk fromat
format 1.44 M
Invalid media or Track 0 bad- disk unusable
format terminated


I have tried to format in Windows
but also a massage appears

File Manger cannot format this disk
Make sure the disk is in the drive and is not write-protecd, damaged or the wrong density.


My floppy disk is
Sony 2HD IBM formatted
for IBM pS/2, PS/1 + compatible with Dos 3.3 & up

I have Dos 5.0 with windows 3.11
Comment
Watch Question

Commented:
I'd say the disk was faulty. Have you tried using another disk?

Author

Commented:
yes i have tried and  used more than 5 diskets
Quid, Me Anxius Sum?  Illegitimi non carborundum.
CERTIFIED EXPERT
Commented:
Then try a floppy drive cleaning unit.  You can buy this from your local pc retailer.  It is a special floppy that cleans the heads of your floppy drive.

After that if it still doesn't work get a replacemennt floppy disk drive.  It is possible that the heads in your floppy drive have been bent or misaligned.  Also try your floppy disks in another machine just to check that their media is OK.  If they pass there then you know it's your drive.

Oh, and one last possibility is that you have a virus on your machine.  Check that as well.

Commented:

mkhalidmn,

I'll paste here some of the comments I posted in your other thread
about the boot disk and floppy drive error...

The "2HD" on your floppy disk signifies a Double-Sided High-Density disk,
so be sure your floppy drive supports that size and is not Double-Density.
That error message can also be generated when using the wrong size media,
such as when attempting to format a high-density disk as double-density
or in a low-density drive, although that doesn't appear to be the problem.

The Format message you get saying "Formatting 1.44M" indicates the BIOS
is configured for a High-Density drive but it's something to check anyway.
For example, if you attempt to format your disks in a 1.44 floppy drive
with the BIOS set to 720k or if the settings are otherwise incorrect
it will generate the "Invalid media or Track 0 bad" error message
and can render a disk useless. Ensure the BIOS is configured
with the correct parameters and the settings match the drive.

You can also verify while you're in there whether the BIOS' boot sequence
is configured to read A: first, for when you're ready to use the boot disk.
Post back if you want more info on that. If the boot order settings
in the BIOS are A: then C: you may get further clues from the
messages when booting with a disk in the floppy drive.

That "Invalid media or Track 0 bad - disk unusable" error message
is also generated when trying to access a floppy disk in a faulty drive.
I encountered that recently and the drive ruined a couple of floppies.
Fortunately floppy drives are easy to find, easy to replace and cheap
if you determine that's the problem.

Have you successfully used that floppy drive recently?
You say you're getting the error on multiple floppy disks...
Have you been able to read a disk that you know is good?

You noted that the floppies are already formatted...
You should be able to do a directory listing  ( Dir A: )
assuming the drive is good (even if no files are found)...
Or type  A:  and attempt to change to that drive.
Post back with error messages received if trying that.

If you've verified that the disks you're using can be
read and formatted (and/or repaired) in another drive,
then it's obviously a hardware or configuration problem.

I'll mention again that a faulty drive can damage a floppy disk
when simply trying to access the disk in that drive.
The disks can typically be repaired but may initially exhibit failure
during subsequent testing in other drives.
If your drive is bad, it may have damaged your floppies
as you were trying to format them...
You may want to check that if testing on another drive.

Please post back with your results or if you need other test methods
to determine whether the problem is the drive or the floppy disks
and whether you need more info on creating a boot disk...
 
rid

Commented:
This could very well be a drive error. You may try going to a command prompt and type format /? to get info on all possible switches. Sometimes I have found that if you actually state the size of the floppy you want to format
format a: /F:1.44
you get a better result with obstinate floppies.
It may also be the floppy, of course, but since you have tried several, the drive is the prime suspect.
Regards
/RID

Commented:
I don't know if it will work with win 3.1 but DTpro at www.surecool.com has solved similar problems for me,it is on the first page under floppy repair
to chk whether drive is okay (or faulty)
format the same floppies on diff machine. if it does then chk the drive

Commented:
Early IBM 1.44 drives were manufactured by a company called YE Data and did not use the currently familiar second hole in the disk case. The reason was that IBM wanted to sell diskettes that were preformatted for this drive. If you have old IBM 3.5 inch diskettes that are preformatted, look further... Hold the disk in front of you with the center hub on the back and the sliding door on the top. If the diskette has a hole with or without a slider for write protect in the lower right corner, GOOD! All floppy disks should have this hole. There should be a hole in the lower left hand corner as well. This hole is used by todays drives to distinguish between 2DD and 2HD diskettes. As I mentioned before original IBM diskettes did not have this hole and the YE Data drive determined the capacity by testing the surface when it was read. Thus if this is truely the type of diskettes you have, they are pretty worthless except when used in a YE Data drive. If they do say 2HD on the diskette and have no hole in the lower left, you can use a hand held single hole punch for paper and pop a hole in the right spot and make them work. Just be carefull to keep hole away from the media inside.

Best bet is to throw these disks away and buy some universal 2HD disks that are not IBM P/N versions. IBM still sells these floppy disks today to many customers who still have old equipment.

Hope this helps...
-greg
hey, he has SONY disketttes...
** PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER **

It appears that this question has been abandoned.  Please take a moment to finalize the question & reward your points as appropriate.  If this question is not finalized within 7 days, Community Support will be requested to force close it.  Unless there is objection or further activity,  it will also be requested that points be awarded to the following expert(s) for their comments:

dbrunton; rin1010

If you feel that your question was not properly addressed, or that none of the comments received were appropriate answers, please post a request in Community support (with a link to this page) to refund your points.  The link to the Community Support area is: http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt


/EW

** PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER **
Thanks for your help, Eric.  Points have been split.
Points for rin1010 -> http://www.experts-exchange.com/jsp/qShow.jsp?qid=20310312
Finalized today by EE Moderator.