No 2nd DataReport Printout


I have a wierd problem:

In my proj, i have a data environment and data report. A command in the DE(which is my datareport source) access 4 tables. 3 of the tables I use for computing.  The content of the 4th table is displayed directly.

My problem is that all my report printouts are good except for the 2nd printout.  There is no data.  In using a parameterized command.  I've tried different parameters for the command. Every 2nd printout has no data.  But if i use the same parameter for the 3rd printout, the correct data is printed.

Any ideas? Please help.
Who is Participating?
Éric MoreauConnect With a Mentor Senior .Net ConsultantCommented:
Are you closing the recordset before re-using it?
Éric MoreauSenior .Net ConsultantCommented:
3MannAuthor Commented:
yup, already read that one...
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

3MannAuthor Commented:
uh... sorry for not posting...
already solved the bug...
i closed the connection before reusing it...

Thanks emoreau
Éric MoreauSenior .Net ConsultantCommented:
will you award me the points or will you delete the question?
3MannAuthor Commented:
Hope you'll agree if I don't give the full points posted...
First, I have already solved the prob before reading the comments and second, closing only the recordset was not enough.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.