Solved

ORA-01031 insufficient privilages in OEM/Backup

Posted on 2002-03-04
12
1,326 Views
Last Modified: 2007-11-27
Trying to backup my Database. All I get is that ORA-01031 insufficient privilages error. I have tried usernames: internal,sysman,sys as SYSDBA. I have also went into Security and granted the users all possible roles and system privilages and set Consumer Group to SYS_GROUP. I have gone into SYSTEM/Manage Administrators/Edit/Preferred Credentials and set SYSDBA Role to each service type.

When trying to grant SYSDBA to my standard username.
In init.ora remote_login_passwordfile=EXCLUSIVE, but when I run show parameters remote this is equal to SHARED.

I also have Backup Exec v8.5 with Oracle Agent, but when it tries to backup, I get an error of: "Directory not found. Can not backup directory \ SYSTEM and its subdirectories."(this error for each directory) even though they are listed in backup selections/Oracle Agents.


Need Help!
Thank You
0
Comment
Question by:rgcomm
12 Comments
 
LVL 2

Accepted Solution

by:
jbever earned 100 total points
Comment Utility
You need the Login as Batch privilege on OS level for the user that connects to the server.
(preffered credentials)

0
 

Author Comment

by:rgcomm
Comment Utility
I do have these logins as settings in "Log on as a batch job" within Local Security Settings on my W2k Adv Svr.
0
 

Author Comment

by:rgcomm
Comment Utility
I do have these logins as settings in "Log on as a batch job" within Local Security Settings on my W2k Adv Svr.
0
 
LVL 4

Expert Comment

by:asimkovsky
Comment Utility
Have you bounced the database after setting REMOTE_LOGIN_PASSWORDFILE to EXCLUSIVE?  

Also, on Win2k, when you grant "Logon as batch job" privileges to the Windows users, there are two columns, one for Local Security Policy, and Effective Security Policy. Both boxes must have a check mark.

>When trying to grant SYSDBA to my standard username.
>In init.ora remote_login_passwordfile=EXCLUSIVE, but when >I run show parameters remote this is equal
>to SHARED


Andrew
0
 

Author Comment

by:rgcomm
Comment Utility
On Logon as batch jog, the effective column is shaded and cannot be changed, only DBSERVER\VUSR_DBSERVER is checked.

And I have bounced the database. I did not change the reomte_login_passwordfile, it was already set to EXCLUSIVE.

Thanks Everyone
0
 
LVL 4

Expert Comment

by:asimkovsky
Comment Utility
>In init.ora remote_login_passwordfile=EXCLUSIVE, but when
>I run show parameters remote this is equal
>to SHARED.

Look in V$PARAMETER to be sure it's set to EXCLUSIVE.

Have you created a password file with the orapwd utility and granted SYSDBA to the user in question?

Andrew

0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:rgcomm
Comment Utility
When I enter "select value from v$parameter where name = 'remote_login_passwordfile';" it returns "SHARED".
0
 

Author Comment

by:rgcomm
Comment Utility
I'm not sure which INITXXXX.ORA file I was looking at before, but when I looked at it now "remote_login_passwordfile = shared". I changed it to exclusive.

The problem that I had with Backup Exec was solved by:
"alter database archivelog" and by inserting "log_archive_start = true" into the INITXXXX.ORA. As soon as Backup Exec finishes I will try it again.
0
 

Author Comment

by:rgcomm
Comment Utility
I'm not sure which INITXXXX.ORA file I was looking at before, but when I looked at it now "remote_login_passwordfile = shared". I changed it to exclusive.

The problem that I had with Backup Exec was solved by:
"alter database archivelog" and by inserting "log_archive_start = true" into the INITXXXX.ORA. As soon as Backup Exec finishes I will try it again.
0
 
LVL 1

Expert Comment

by:shelton2
Comment Utility
Hi RQCOMM,
I can see your problem usually people think sysman being a super user can do anything that's right but not on the OS level!!!!!
connect to the OEM I am being 8.1.7 specific here as sysman/XXXXXX(whatever your sysman pwd is)go under the menu System--->Preferences ----on the pop up -----Preferred credentials
look for the service type node there should be 2 lines
your_machine_name.company                   node
default                                     node

Highlight them one at a time and change the username/password to match your NT logon and make sure your NT logon has the necessary  privilege batch operator etc depending on if you're on NT 4.0 or W2K because you can't backup your Dbase as sysman why because he has no write permission to the OS file or disk.Now you can run your backup successfully
Cheers let me know of your success.
0
 
LVL 1

Expert Comment

by:Moondancer
Comment Utility
Greetings.

This question has been locked with a Proposed Answer, and remains open today.

If the Proposed Answer did not serve your needs, please reject it and comment with an update.  If the Proposed Answer helped you, please accept it to grade and close this question.  If you need help splitting points between multiple experts, please comment here with details so we can help you.

EXPERTS ->  Please guide me here in terms of closing recommendations if the Asker does not respond in 4 days.

Thanks to all,
Moondancer - EE Moderator
0
 

Expert Comment

by:modulo
Comment Utility
Dear: shelton2

I've rejected your proposed answer as Experts Exchange holds an experiment to work without the answer button.

See:        http://www.experts-exchange.com/jsp/communityNews.jsp
Paragraph: Site Update for Wednesday, November 06, 2002

By this rejection the Asker will be notified by mail and hopefully he will take his responsibility to finalize the question or post an additional comment.
The Asker sees a button beside every post which says "Accept This Comment As Answer" (including rejected answers) -- so if he/she thinks yours is the best, you'll be awarded the points and the grade.

Thanks !

modulo

Community Support Moderator
Experts Exchange
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Join & Write a Comment

Suggested Solutions

Why doesn't the Oracle optimizer use my index? Querying too much data Most Oracle developers know that an index is useful when you can use it to restrict your result set to a small number of the total rows in a table. So, the obvious side…
Have you ever had to make fundamental changes to a table in Oracle, but haven't been able to get any downtime?  I'm talking things like: * Dropping columns * Shrinking allocated space * Removing chained blocks and restoring the PCTFREE * Re-or…
This video shows syntax for various backup options while discussing how the different basic backup types work.  It explains how to take full backups, incremental level 0 backups, incremental level 1 backups in both differential and cumulative mode a…
This video shows how to recover a database from a user managed backup

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now