Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Slow login to RetHat 6.2 on a LAN

Posted on 2002-03-05
9
337 Views
Last Modified: 2010-03-18
I have two RedHat 6.2 Linux machines on a local network (IPs in the 192.168.0.* range).
I'm having trouble in connecting to either machine: Whenever initializing connection (from another computer on the local network) either by FTP or telnet, it takes several minutes until I get response (e,g, login prompt). Once I login however the connection is fast and flawless.
It is ridiculous because I have similar machines hosted outside and it is faster logging to them by modem than logging to the internal machines on the LAN!

What can be the problem? Ask me if you need further info.
0
Comment
Question by:Books
9 Comments
 
LVL 4

Expert Comment

by:MFCRich
ID: 6841457
This sounds like a DNS problem. I am guessing that when you are connected by modem you are using your ISPs DNS service which of course does not have entries for your 192.168.0.* machines.

Edit the '/etc/hosts' file on all the 192.168.0.* machines to look like this:

127.0.0.1   localhost.localdomain localhost
192.168.0.1 host1
192.168.0.2 host2
...etc

host1 and host2 are the names you've given to the machines. You could make this file on one machine and then copy it to all the others since it should be identical on all machines.

And the make sure '/etc/host.conf' has "order hosts,bind" at the beggining.

Post any questions
0
 
LVL 4

Expert Comment

by:escheider
ID: 6841869
Bingo, I agree with MFC.
0
 

Author Comment

by:Books
ID: 6843800
Ok, the situation is now like this:

The linux server named "Serv1" on IP 192.168.0.23 has this hosts file:
127.0.0.1       localhost       localhost.localdomain
192.168.0.23    Serv1

(host.conf is configured as you mentioned)

The windows machine from which i'm tring to telnet (using TeraTerm) has this hosts file:
127.0.0.1     localhost
192.168.0.23     Serv1

Still initializing a connection is very slow.

Maybe I need to defined a name for the windows machine and
put that name in Serv1 hosts file?
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Expert Comment

by:John_Bell_2
ID: 6846411
Setting up DNS with properly configured forward and reverse zone information may help...
0
 
LVL 3

Expert Comment

by:tibori
ID: 6849746
Have you tried connecting via IP rather than name? Is this just as slow?
0
 
LVL 4

Expert Comment

by:svindler
ID: 6851423
Putting the ip address of the client in /etc/hosts of the server will solve the problem.

The delay is caused by the server doing a reverse lookup of the ip number of the client before continuing.

This is the same information other has provided, I am just trying to clarity things.
0
 

Author Comment

by:Books
ID: 6854264
I have put the ip address of the client in the /etc/hosts of the server. And indeed connecting by telnet is fast.

However ftp is still slow as ever.

Is there something special that needs to be done for the ftp? ftp daemon is wu-ftp.

 
0
 
LVL 4

Accepted Solution

by:
svindler earned 100 total points
ID: 6854828
I seem to remember a problem with wu-ftpd. As far as I remember, there is a flag to disable name lookups, but it doesn't disable it and ignores "hosts" in /etc/host.conf, but always does a "bind" name lookup.
After many attempts, I threw the towel and installed proftpd instead, which have better features anyway, so it was not a big loss.
0
 

Author Comment

by:Books
ID: 6874305
svindler claims his/her answer only repeated what other have said. But his/her answer was the best - in plain language - only after reading it I knew exactly what to do.

Thanks.
0

Featured Post

Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

766 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question