Solved

I recompiler mod_coldfusion.so and my Stronghold server cannot restart

Posted on 2002-03-06
1
249 Views
Last Modified: 2013-12-20
I have ColdFusion 5.0 and Stronghold 3.0 in Linux OS( Red Hat Linux 7.2).

I add "SSL_CLIENT_CERT" at mod_coldfusion.c as additional Variable and recompile it.. Well no error and I got mod_coldfusion.so and replace it

at /apps/sh30/modules/libexec/

after stop both server coldfusion and stronghold.. when to start the sh
back
got error below :

[root@www3 bin]# ./start-server
Syntax error on line 241 of /apps/sh30/conf/httpd.conf:
Cannot load /apps/sh30/modules/libexec/mod_coldfusion.so into server:
/apps/sh30
/modules/libexec/mod_coldfusion.so: undefined symbol: __builtin_vec_new
Server could not be started


Can someone consult Me what version of C++ compiler shall I use to compile mod_coldfusion.so? Any website for reference.

Please consult me how to do it..
Thanks
0
Comment
Question by:philipngcc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 2

Accepted Solution

by:
Cyril_H earned 300 total points
ID: 6867504
Here's some articles i found, maybe it can help. I'm still trying to find any references for you...

let me know,
Cyril

---------------------------------------------
How can I recompile Stronghold to include Cold Fusion?
---------------------------------------------

Steps for installing ColdFusion version 4.5.1 (for Linux) with Stronghold 3.0.

You will need to use the apxs utility provided in the Stronghold distribution to build an EAPI enabled mod_coldfusion.so.

Make sure you have perl installed
Make sure a C compiler or gcc compiler is in your PATH.


Change to the apache/src directory in the ColdFusion installation:

cd /opt/coldfusion/webserver/apache/src
Backup the original Makefile:

cp Makefile Makefile.orig
Edit the Makefile by changing the libC.so.5 to the one that you are using, for example from:

#LIB= ./libcf.a /usr/lib/libC.so.5
to
LIB= ./libcf.a /lib/libc.so.1
(if the libc.so.* library you are using is libc.so.1) and change :
#DEF=-Dmy_define=my_value
to
DEF=-DEAPI
and also add the full path to the APXS as following:

Change
#APXS=apxs
to
APXS=/path/to/../sh3/bin/apxs
Run make (which will execute the apxs command) to build mod_coldfusion.so:
make
Run "make install" (which will also execute the apxs command to add the module to the Apache configuration):
make install
This "make install" will copy the newly created mod_coldfusion.so to your /path/to/../sh3/modules/libexec directory and modify your httpd.conf file to add the following line into it:
LoadModule coldfusion_module  modules/libexec/mod_coldfusion.so
Stop and start Stronghold again.
Stronghold should load mod_coldfusion.so when Stronghold starts up again.


---------------------------------------------
Can my compiler cause recompilation problems?
---------------------------------------------

Many recompilation problems are caused by the use of the wrong compiler. In particular, we know the native compilers for Red Hat Linux 6.2 and HPUX don't work with Stronghold. The compiler we support is GCC, version 2.7.2.3, which can be obtained from ftp://prep.ai.mit.edu:/pub/gnu

Using GCC 2.7.2.3 has been confirmed to resolve problems with recompiles dying in "ap_execve.o."

Some people have also been able to recompile Stronghold successfully with GCC 2.8.1, so you might try that if 2.7.2.3 doesn't work on your OS.

If you have tried these compilers but are still having problems, please email a copy of the errors you receive to support.


---------------------------------
For ColdFusion Server version 5:
---------------------------------
If you are not running an EAPI version of Apache, at the end of the LoadModule section, add the following on one line (due to formatting in this Technote, it appears as two lines):

LoadModule coldfusion_module /opt/coldfusion/webserver/apache/mod_coldfusion_standard.so

If you are running an EAPI version of Apache, at the end of the LoadModule section, add the following on one line (due to formatting in this Technote, it appears as two lines):

LoadModule coldfusion_module /opt/coldfusion/webserver/apache/mod_coldfusion_EAPI.so

In the section AddModule, add the following on one line:

AddModule mod_coldfusion.c


0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Collapseable list of URLs. 10 142
Configure IIS to process JSON 10 92
Webserver access problem 5 76
Setting Up Local Lan Web Server 1 77
In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
What You Need to Know when Searching for a Webhost Provider
The purpose of this video is to demonstrate how to integrate Mailchimp with Facebook. This will be demonstrated using a Windows 8 PC. Mailchimp and Facebook will be used. Log into your Mailchimp account. : Click on your name. Go to Account Setti…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question