Solved

installed apache; configure myCompany.com

Posted on 2002-03-06
19
282 Views
Last Modified: 2010-03-04
I have installed apache 4.0 on win 2000 machine. I am new to this. What do I have to do so I can access my website or webpage over the internet. I can access it by localhost. What do I need to do. I guess I would need to change my localhost to another name like panarella.com. is this right. i know my isp ip address. also I have cable modem. does this pose a problem because I do not have a static ip address? please help..
0
Comment
Question by:npanarella
  • 5
  • 5
  • 3
  • +3
19 Comments
 
LVL 2

Accepted Solution

by:
mhonomichl earned 25 total points
ID: 6846191
The easyest way to do it with a name is to go to www.dyndns.org and use them as a name server.  Otherwise you should be able to get to it via the IP address
0
 
LVL 15

Expert Comment

by:samri
ID: 6846349
any dynamic DNS solution would work.  The ServerName directive in httpd.conf doesn't matter much, unless you are into doing some redirection and virtual hosting.

btw; What is Apache 4.0, Do we have 4.0 yet.
0
 
LVL 12

Expert Comment

by:lexxwern
ID: 6846591
yeah.
Apache 2 is still under beta. 4?
0
 
LVL 12

Expert Comment

by:lexxwern
ID: 6846595
but deerfield.com has a good free service of dns pointing.
tzo is another such service.

http://deerfield.com/
http://www.tzo.com/
regards.
0
 
LVL 12

Expert Comment

by:lexxwern
ID: 6846597
or is it deerfield.net
http://deerfield.net/
stop.
0
 

Author Comment

by:npanarella
ID: 6849291
Still no luck accessing my page via the internet..
I started apache tomcat server and was able to access my webpage with the following url:
http://localhost:8080/index.html

But when I logged onto the internet and tried to connect to the url; this time with my ip address inplace of localhost.
http://www.31.555.57.227:8080/index.html

I got could not display page?? any thoughts?? Do I have to set any configuration files to point to my ip address instead of local host. someone mentioned httpd.config but I do not have this file on my PC. I have a server.config file? Please help.

Thanks.
0
 
LVL 2

Expert Comment

by:mhonomichl
ID: 6850308
all you should need is the IP address:

31.55.57.227:8080

Depending on the browser that you are using, you may want to include the http://

http://31.55.57.227:8080

mark
0
 
LVL 15

Assisted Solution

by:samri
samri earned 25 total points
ID: 6850453
Hmm.. it's a Tomcat.  I'll have to pass this.

Try the propose action by mhonomichl, it you still can't access to you Tomcat (on port 8080), can you do a simple "telnet <your-server-ip-address> 8080".  Type in anything, and hit enter twice.  If you get connection refused.  That means, either Your tomcat is only listening to Loopback address (127.0.0.1), and not the ethernet (or whatever interface is used to connect to the LAN (and to the Internet).

In fact what you can try it to browse on the local machine (the server itself), and instead of using http://localhost:8080/, try http://theip.address:8080/

If this works, then try the "telnet" test.  If it still fails.  Check maybe you firewall/router is blocking any incoming request, or doing any kind of port filtering.

Btw, 31.55.57.227 is just an axample IP, and you actuall IP is different.  Right?.  It that is the real IP, It doesn;t look like a public IP (might be reserverd -- I might be wrong).

good luck
0
 

Author Comment

by:npanarella
ID: 6851504
31.55.57.227 is not my real Ip address, just used it as an example. I tried to telnet the ip address but got could no open a connection to host. connect failed.  are you sure I do not need to change or add the ip address to a conviguration file such as server.config??? I tried to connect with the url format mhomuchi said, but still no luck
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 2

Expert Comment

by:mhonomichl
ID: 6851527
If you have the configuration set to listen only to localhost, this may be causing problems.  Look for it in your configuration file and change localhost to the IP address.
0
 
LVL 15

Expert Comment

by:samri
ID: 6853186
Addition to mhonomichl's cooment;

Check you Listen, and BindAddress directive.  I believe that by default, Apache will be listening to all available ports (all IP address), but bear in mind that you have a dynamic IP address.  Perhaps the first thing you might want to do is to check you config, on whether you happens to do any customization, as to bind to specific ip address.

Next is, after you have obtained the IP address, try stopping apache, and restart.  Can use command line; NET STOP APACHE, NET START APACHE (unfortunately, there is not NET RESTART APACHE).


# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
#Listen 3000
#Listen 12.34.56.78:80

#
# BindAddress: You can support virtual hosts with this option. This directive
# is used to tell the server which IP address to listen to. It can either
# contain "*", an IP address, or a fully qualified Internet domain name.
# See also the <VirtualHost> and Listen directives.
#
BindAddress *
0
 

Author Comment

by:npanarella
ID: 6854815
I got it to work under my ip address now. can i register the same ip adress with more than one domain name. for example can i have webconnection.com and a entirely new domain name(new website) called freepizza.com registered to the same ip address.???
0
 
LVL 2

Expert Comment

by:mhonomichl
ID: 6854912
You can have as many registrations for a IP address that you want.
0
 
LVL 4

Expert Comment

by:gizmola
ID: 6858033
Yes you can have multiple domains answering on the same IP, but you need to insert the appropriate virtual server configuration directives to handle this.  FYI, this is done via the host header name provisions in the http 1.1 rfc.  Ok, so here's what you need in your httpd.conf

#You need this statement, with the appropriate settings #for your server:
NameVirtualHost 208.57.76.141:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost #container.  I've even included a <Location directive to #show how you might do a secure area with realms
#
<VirtualHost 208.57.76.141>
    ServerName kw.clan-sn.org
    ServerAdmin webmaster@gizmola.com
    DocumentRoot /sites/kw
    ErrorLog logs/kw-error_log
    CustomLog logs/kw-access_log combined
    <location /restricted>
        AuthName "kw.clan-sn.org"
        AuthType Basic
        AuthUserFile /sites/kw/restricted/usrfile
        require valid-user
    </location>
</VirtualHost>
0
 

Author Comment

by:npanarella
ID: 6859141
One more question. I went thru deerfield.com to register my ip address to a new domain. I then replaced the ip adress with the new domain name in the tomcat servlet.config file. Restarted tomcat. the only thing now is I can only access my website with the following URL
http://www.kingpin.27south.com:8080/index.html

ofcourse I would like to enter the above url minus the :8080 port number but if I do then the page will not display. any thoughts.  do I have to configure the tomcat server to listen on a default port number or something

0
 

Author Comment

by:npanarella
ID: 6859159
I also do not have a httpd.conf file. I have a server.config file.
0
 
LVL 2

Expert Comment

by:mhonomichl
ID: 6859272
in your config file, you should have something that sets the port to 8080.  You should only need to change this to 80

Mark
0
 
LVL 15

Expert Comment

by:periwinkle
ID: 9681910
No comment has been added lately, so it's time to clean up this TA.

I will leave a recommendation in the Cleanup topic area with the following recommendation for this question:

Split between mhonomichl and samri

Please leave any comments here within the next seven days.

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

periwinkle
EE Cleanup Volunteer
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
As Wikipedia explains 'robots.txt' as -- the robot exclusion standard, also known as the Robots Exclusion Protocol or robots.txt protocol, is a convention to prevent cooperating web spiders and other web robots from accessing all or part of a websit…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now