Slow response on serial terminals

I have a redhat 7.1 box.
i am using secong machine to connect the server using mgetty (on server) and hyperterminal (on client) using null modem cable.

i am connecing at 19200 bps. but the terminal is slow in respnding to the keystrokes. echo comes quite late. though screen updates are equally faster.

what i need to change to make response faster
LVL 10
Who is Participating?
DABOMBConnect With a Mentor Commented:
why are you using mgetty for your terminal, mgetty is most compatible with modems, you should use agetty for null terminals:

ex: this is my null terminal line in inittab under serial lines section..

s1:12345:respawn:/sbin/agetty 19200 ttyS0 vt100

and it works just fine, i am using terminal adapters that came with my routers and switches that convert serial to cat 5 and then back from across the house.

give it a try :)
The following is posted in all your open questions today.


Question(s) below appears to have been abandoned. Your options are:
1. Accept a Comment As Answer (use the button next to the Expert's name).
2. Close the question if the information was not useful to you. You must tell the participants why you wish to do this, and allow for Expert response.
3. Ask Community Support to help split points between participating experts, or just comment here with details and we'll respond with the process.
4. Delete the question. Again, please comment to advise the other participants why you wish to do this.

For special handling needs, please post a zero point question in the link below and include the question QID/link(s) that it regards.
Please click the Help Desk link on the left for Member Guidelines, Member Agreement and the Question/Answer process.

Please click you Member Profile to view your question history and keep them all current with updates as the collaboration effort continues, to track all your open and locked questions at this site.  If you are an EE Pro user, use the Power Search option to find them.

To view your open questions, please click the following link(s) and keep them all current with updates.

To view your locked questions, please click the following link(s) and evaluate the proposed answer.

------------>  EXPERTS:  Please leave any comments regarding your closing recommendations if this item remains inactive another seven (7) days.  Also, if you are interested in the cleanup effort, please click this link
Thank you everyone.
Moderator @ Experts Exchange

P.S.  For any year 2000 questions, special attention is needed to ensure the first correct response is awarded, since they are not in the comment date order, but rather in Member ID order.
kiranghagAuthor Commented:
ya a'll give, but please be patient for the points as my terminal is now broken and I am abt to fix it.
catch back to u later.
Can you now please finalize your questions? If not, we'll need to take the actions for you.

Moondancer - EE Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.