Solved

Share a folder under XP with password

Posted on 2002-03-08
6
197 Views
Last Modified: 2012-05-04
I got Xp prof. and want to share a folder over the network. But I can´t set any rules. The folder is available for everybody on the net (no domain just workgoup). How can I set a password?
0
Comment
Question by:brausy
  • 2
  • 2
  • 2
6 Comments
 
LVL 63

Expert Comment

by:SysExpert
ID: 6850423
Sharing a drive drive share  NT shares  NT file sharing
Permissions are set in two seperate places in NT and win2k/XP.

   1) There is a set of permissions on the share it self for access outside the local computer.

  2) There are file/dir permissions on the hard drive for local and remote access.

 right click on the drive/file, choose properties - security - permissions. Give the person/goup full
                   access.

3) delete all the *.pwl files in the \windows dir on win98. Your next login will recreate them. reboot
                   !!
OK, you need to add a new share rather than the default administrative share.
 Add the new share -( there is a new share button at the bottom )  call it C-drv, set the permissions,
  and that should solve the problem.

1) Add a new user on NT.
 2) Try logging into a workstation using this new user and password.

 See if you can access the NT machine.

 Please note that the default shares on NT are not accessible, you have to create NEW shares !
Other options is to enable the guest account, but this is a security breach usually.
                   I hope this helps !

From: stevenlewis     Date: 09/29/2001 06:49PM
              OK, the "access denied" gives us a clue.
              Log on to the 98 boxes using the client for M$ networks as the primary logon, this creates the access
              token that the w2k box needs. then on the share(s) you have to allow the guest account access to the
              share(s), in the permissions, allow everyone full control
              also enable the guest account on the w2k box
              Click on Start/Programs/Administrative Tools/Computer Management. Look for Local Users and Groups       under   System Tools (on the left side), and expand it to show the two folders, Users and Groups. Highlight       the Users folder, and then you'll see the Administrator and Guest account. Highlight the Guest account,               and click on Action. Go down to properties, and on the General Tab for Guest Properties, you'll see            the box checked for Account is Disabled. Uncheck it
-----------------
I hope this helps !

0
 
LVL 63

Expert Comment

by:SysExpert
ID: 6850430
From my suggestions above, turn OFF the guest account if that is what they are using.

You will need to create a separate user or group, and only these people will have access to the share.

The permissions can be set on the share or on the directory itself.

I hope this helps !
0
 

Author Comment

by:brausy
ID: 6850638
sounds goood, but the problem is that I can´t find properties - security - permissions! when I click on properties there is only one category with a casket to share the folder.The second casket is the permission  for the network users to allow them to change files- that is all no groups no password nothing and no more rights to give.
0
Save on storage to protect fatherhood memories

You're the dad who has everything. This Father's Day, make sure your family memories are protected. My Passport Ultra has automatic backup and password protection to keep your cherished photos and videos safe. With up to 3TB, you have plenty of room to hold the adventures ahead.

 
LVL 41

Accepted Solution

by:
stevenlewis earned 300 total points
ID: 6851905
you have to disable simplified file sharing first, in explorer, tools, folder options, advanced, sroll down to simplified fiel sharing, and uncheck it, then when you right click on a folder, and choose security, you will see all the options
see here
http://www.microsoft.com/windowsxp/expertzone/tips/september/stevens1.asp
0
 

Author Comment

by:brausy
ID: 6855643
thanks that is what I was looking for.
0
 
LVL 41

Expert Comment

by:stevenlewis
ID: 6858860
brausy Glad I could help
Steve
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
For many of us, the  holiday season kindles the natural urge to give back to our friends, family members and communities. While it's easy for friends to notice the impact of such deeds, understanding the contributions of businesses and enterprises i…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now