Solved

Application Error

Posted on 2002-03-12
8
398 Views
Last Modified: 2013-12-18
There is a database that resides on our R509 server, Windows 2000 platform.
Two documents that have an "In Production" status cannot be opened but all others can.  Whenever we try to open these two documents, it gives us an error message of either:
1)  ASSERT(dbBox) failed at line 276 in file d\dmisc.c
OR 2)  The instruction at "0x005342d4" referenced memory at "0x00000008".  The memory could not be "read".

How can we resolve this? Thanks in advance for your help.
0
Comment
Question by:zdima
  • 3
  • 2
  • 2
  • +1
8 Comments
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 6859432
This could be related to corruption in document.

Few of the causes/remedies

1. Check if you are using any special fonts especially in Richtext field (Look for $Fonts)
2. Check for any images which might be causing this problems (If possible delete the rich text fields)
3. Initialize or open event codes (try to Comment out the code and open)
4. Form properties (Design it to simple form by removing any headers or background images)

Let me know how it goes !

~Hemanth

0
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 6859446
0
 
LVL 18

Expert Comment

by:marilyng
ID: 6859513
Heman,

Really wild!! I've never run across this one before, good that you found the newsgroup discussion on it.  
0
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 

Author Comment

by:zdima
ID: 6930050
Hi,
I have tried all that and it still does not work!
It turns out that it is not only one document in particular.  It is any document that you choose by random.  Sometimes you can view it and sometimes it gives you the error message below which results in Notes crashing.

Here's more background on this issue:

I have recently put up a second Domino server which now acts as the application server and our existing domino server is now only our mail server.  Both are on Windows 2000 platform running R5.0.9.

I have transferred all application databases to the application server (using replication) and deleted the original copies from the mail server.

All databases are working as expected except for one.  It works most of the time but once in a while, when you double-click a document (by random) to view its contents, it comes up with the following error message:

The instruction at "0x005342d4" referenced memory at "0x00000008".  The memory could not be "read".
Click on OK to terminate the program.
Click on CANCEL to debug the program.

Thanks,
zdima
0
 
LVL 18

Accepted Solution

by:
marilyng earned 75 total points
ID: 6930331
zdima,

There are a number of references, including your above posted message on Notes.Net regarding the Assert Message and the other error you are receiving.

Is this database a specially constructed one or one thrown from a Notes Template?  Is it a mail-in database?  What's the difference between the databases that work fine and the one that doesn't?  For instance,

1. Have you checked to make sure that the database, and all its design elements are signed by the server.

2. Have you checked to make sure that any roles that exist are also applied to the server -- that the server has the correct access.

3. Is the server administering the database?  Or is the database set for the old server to administer it?

4. Have you run both fixup and compact on the database?

5. Have you tried to access these documents via Notes Peek? (To see what's different in the signatures that might be preventing the access)

6. Do these document have HTML in the RichTextFields?

7. Have you  cleared the replication history on the database?

8. Have you re-indexed the application (shift +F9 while it's open)?

9. Have you compacted the database?

10.  Generally, the best way to resolve corruption in a database is to throw a new replica on the server, clear the replication history, and then delete the old one.

Let me know how it turns out.. it may well be the bug that is not resolved in either 5 or Rnext.

Marilyng
0
 
LVL 24

Expert Comment

by:HemanthaKumar
ID: 6932239
You should be using some functionality/feature which is not properly embedded into the new release of notes. try upgrading or downgrading the version. New 5.0.10 is available, which says that it fixed most number of problems. Not sure though !!!



0
 

Author Comment

by:zdima
ID: 7105986
Thanks for all the info.  We have moved the applications to a new server box separating mail from applications.  I think the replication and deletion of the old one fixed the problem.
0
 

Expert Comment

by:ubiq314
ID: 7575136
Nope.  I get the same thing all too often in 5.0.11.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is an old article, please see an updated version of this article, located here: http://www.experts-exchange.com/articles/23619/Notes-8-5x-Windows-7-Notes-info-and-tips.html
  In today’s Arena we can’t imagine our lives without Internet as we are highly used to of it. If we consider our life style just for only 2 min we found that face to face communication is swapped by e-communication.  Every Where from Works place to…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question