Internet Connection Sharing

I have a W2K server with 2NICs.

NIC 1 192.168.0.1 255.255.255.0 DF None
NIC 2 192.168.1.1 255.255.255.0 DF None

The server has IP routing enabled so all clients connected to each network card can ping each other on both subnets.

I want to setup Internet sharing but ICS forces the server to have 192.168.0.1, in which case I am ok. But I dont want the 192.168.0.1 IP (can this be set-up with different IP?) I tried to setup dialup connection with NAT on the dialup interface. I can't get the clients to share Internet connection.

What is the best way of sharing Internet connection with RRAS server, NAT and dialup alone? I dont want to use 192.168.0.1 for ICS.

links would be great!!
SonikAsked:
Who is Participating?
 
stevenlewisConnect With a Mentor Commented:
0
 
stevenlewisCommented:
also here
http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q299801

Just a question, why do you not want to use 192.168.0.1 as the LAN NIC ip?
0
 
stevenlewisCommented:
You may have to use a third party solution for this
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
SonikAuthor Commented:
Stevenlewis,

Thanks for all links, I already have a server with a different IP with services runnning that are critical for clients, wanted to use this server as a backup server using dialup. When I use ICS it forces 192.168.0.1 which I don't want. Is there anywhere I can set the proxy settings for the dialup?
0
 
SonikAuthor Commented:
stevenlewis,

I can't get the clients to use Internet, if I can get one client to use Internet then I will give the points.

                         
                            |
                           Modem
                            |
192.168.1.20 --192.168.1.1 W2K 192.168.0.1 -- 192.168.0.3
Win98                                              Linux

How can I get 192.168.1.20 to use Internet? I can do everything on W2K except browse Web, I have to enter proxy server setting. Clients can't do anything although it server does dial when it tries a name resolution.
0
 
stevenlewisCommented:
with M$ ICS, you MUST use 192.168.0.1 as the ip of the NIC connected to the LAN
you have 2 different networks here
192.168.0 and 192.168.1
the w2k box can act as a router between the two
consider using the linux box instead
http://www.homenethelp.com/web/howto/linux-share-internet.asp
0
 
HousenetConnect With a Mentor Commented:
-The best way to do this without spending any money is to use rras, nat, a dod virtual adaptor bound to the ras profile & an rras static route bound to the dod adaptor for the external requests.
Here's the basic run down as I see it & remember the help in rras has step by step instructions for scenario's just like yours..
-configure station 192.168.1.20 gw as 192.168.1.1 assign external dns server Ip's.
-Disable rras , re-enable it & choose manual configuration.
-Add Dod adaptor with ISP credentials & phone no.
-Add routing protocol->nat.
-add both nic's (192.168.1.x,192.168.0.x) as private interfaces in Nat.
-add the dod adaptor as the public adaptor to translated tcp/udp etc..
-In static routes add one like so..
Interface=dial on demand virtual adaptor with isp credentials.
network 0.0.0.0
mask 0.0.0.0
-Leave the option to "allow route to initiate dial-up yada yada".
-thats it..
0
 
ewtaylorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
[split stevenlewis housenet]
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
[ewtaylor]
EE Cleanup Volunteer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.