Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 620
  • Last Modified:

ikernel.exe can't launch - InstallShield Error

I just installed the Win 2000 Service Pack 2.

I think it caused the following problem.

I went to re-install and after the install starts I get "Install Shield - ikernel.exe could not be launched"

I've set my permissions in DCOMcnfg.exe - still can't launch.

I am missing file Stdole32.tlb - which is reported by Install Shield as one of the most likely causes . . . But where can I get a copy of Stdole32.tlb???

I am running IE 6.0 and I've been told that installing IE5.5 will fix this problem also.  Can I have both IE 6.0 and IE 5.5 running on the same machine.  That would be great as I'm a webmaster and need to see both.

thanks!

April
0
aprillougheed
Asked:
aprillougheed
1 Solution
 
CrazyOneCommented:
I would first remove to the recyle bin or rename this directory or which ever directory the ikernel.exe is in and see what happens. This may force InstallSheild to rerun and to rebuld the directroy.
C:\Program Files\Common Files\InstallShield\engine

You might have to go so far as to remove to the recyle bin or rename this directory.
C:\Program Files\Common Files\InstallShield


Never tried running two different versions of IE at the same time. It may be possible but logically speaking I wouldn't think it would work because they may clash over certain support files.


The Crazy One
0
 
CrazyOneCommented:
You might consider reapplying the SP2 it may not of completely installed or remove it and then reintall it.
0
 
aprillougheedAuthor Commented:
OK - I got the ikernel.dll deleted

Ran setup.exe for TextPad
and now I get
"can't launch" "error loading type/lib dll"

And of course, the ikernel.dll is now again in the common files directory.

??

Aren't computers fun?

Thanks, April

 
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
jkrCommented:
Hum, I did some InstallShield Programming earlier - are you logged on as an Admin?
0
 
aprillougheedAuthor Commented:
Not logged on as Admin - but have set my login to have admin privileges.

I've set my privileges in DCOMcnfg.exe - still can't launch.

I'll log in as Admin and give it a go.

A.
0
 
CrazyOneCommented:
>>>OK - I got the ikernel.dll deleted

Did you remove the entire directroy or just the file. If it was just the file then remove or rename the entire C:\Program Files\Common Files\InstallShield\engine directory. What I mean is get rid of the InstallShield\engine directory and dont remove the C:\Program Files\Common Files directory. What is needed is to get all of InstallShields Files removed so InstallShield is forced to rebuild all the files and directory.
0
 
aprillougheedAuthor Commented:
I renamed the directly - no luck
I deleted the entire directory - no luck
I logged in as admin and renamed dir. - no luck
I logged in as admin and deleted the entire - no luck

Could it be that I'm missing the Stdole32.tlb file?

This was mentioned in INFO doc from InstallShield at:
http://support.installshield.com/kb/view.asp?articleid=Q104985
0
 
CrazyOneCommented:
Could be. Try this

Start > Run and type in

SFC /scannow

Have your Win2000 CD at hand becasue SFC may ask for it. SFC checks the condition and versions of the system files and will replace them if they need to be.
0
 
CrazyOneCommented:
If you want I can email it to you. Also do a search for STDOLE32.TL_ if the search finds it then use the extract command on it then place it in your C:\WINNT\system32. Actually you should find the STDOLE32.TL_ file on your Win2000 CD in the i386 folder.
0
 
dew_associatesCommented:
Hi April,

I'm not sure if this will help, but here goes.

Dennis

============
1. Insufficient permissions on the machine. If you are using a Windows NT or a Windows 2000 machine, you need to have administrative permission to run a n InstallShield Professional 6.x setup. Make sure you have the correct permissions.

2. If you just ran an InstallShield setup, the engine takes a few seconds at the end of the installation to clean up. During this time Ikernel.exe (the engine file) is running in memory from a previous process; that is why you are not allowed to launch another setup. Waiting a few seconds and running the setup again should resolve this.

3. Check and make sure Ikernel.exe is not in memory. If it is, and setup is running at the time, end that task.

4. Clean out the Temp directory.

5. Delete the Program Files\Common Files\InstallShield folder and then rerun the setup.

6. Delete the Program Files\Common Files\InstallShield\Engine folder and then rerun the setup.

7. Reinstalling Internet Explorer (IE) 5.5 can also repair a number of corrupted/missing core Windows files from your machine, so reinstalling IE 5.5 and the NT service pack is also suggested.

8. You may not have sufficient COM permissions. For information on how to troubleshoot this, see Knowledge Base article Q104986, INFO: Initialization Error Troubleshooting.

http://support.installshield.com/kb/view.asp?articleid=Q104986

9. A potential cause is a missing Stdole32.tlb, stdole2.tlb, or Stdole.tlb file. These are core Windows files and should exist on your machine. Make sure that if you get these files from another machine, the machine is running the same operating system as the target machine.

10. Make sure that you are using the latest version of the InstallShield engine. To install the latest engine, see Knowledge Base article Q105097, INFO: Install the Latest Version of Ikernel.exe.

http://support.installshield.com/kb/view.asp?articleid=Q105097
0
 
aprillougheedAuthor Commented:
OK - still stuck . . .

Permissions are ok - I have allow access, allow launch, etc.  I've cleaned temp, recyclebin and file directories.

1.  I've gotten InstallSheld Professional v.6.3 evaluation copy and will try to install it next.  

2.  I found the Stdole32.TL_ -- but I don't know where to run the "extract" operation.  Is it from the command line??

4.  I'm running MS IE 6.0 which I re-installed and I ran Detect&Repair on MS Office XP Professional.  Can I re-install MS IE 5.5 on top of 6.0 or in a different directory??

Wow -- this is a bad problem.

:)

Thanks, April



0
 
aprillougheedAuthor Commented:
Tried to install InstallShield Professional v.6.3 evalation . . .

same problem -
can't launch lib/dll.

So I'm thinking it much be the STDOLE32.TL_

Can anyone tell me how to extract this file from my Win 2000 Professional CD?

Thanks, April
0
 
CrazyOneCommented:
expand E:\I386\STDOLE32.TL_ C:\WINNT\System32\STDOLE32.TLB
0
 
CrazyOneCommented:
If your CD drive is different than E then subsitute E with the appropriate drive letter.
0
 
aprillougheedAuthor Commented:
Good Job CrazyOne - that did it.

The long post above from dew . . . I had already gotten from InstallShield Web Site.

Thanks to everyone.

April
0
 
CrazyOneCommented:
You are welcome. :>)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now