• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 584
  • Last Modified:

ulimit -d <number> does not change the data segment size

Hey guys, I am not that familiar with unix world , please try to explain it as simple as possible:-)

I am trying to increase my data segment size with ulimit -d
right now it is 8192 KB.
Running ulimit -a 780000 does not help it runs but it does not echange any thing.

Help!
0
prokni
Asked:
prokni
  • 2
  • 2
  • 2
  • +1
1 Solution
 
UkWizardCommented:
It depends what shell you are using, i believe the syntax is different for different shells.


run /bin/sh first,then retry it.
0
 
UkWizardCommented:
Why do you want to change it anyway, i have never had to in all my years as a unix guy.
0
 
decdragonCommented:
Your message says you are running "ulimit -a 780000". If this is not a typo, you need to do the following:

>sh (or ksh)
>ulimit -d
  (You will get the current data segment value setting)
>ulimit -d 780000
>ulimit -d
  (the returned value should be 780000)

Keep in mind that this setting will only apply to your parent process (shell) and associated child processes. In addition, a process that wishes to increase ulimit values must typically have the appropriate priviledges to do so (meaning sometimes you have to be root).
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
prokniAuthor Commented:
I am root
it was typo
I am runing ulimit -d 780
If I run it under Korn shell it gets effected but under Cshell I can not change it.
0
 
prokniAuthor Commented:
The reason I want to change it is, We are running chilisoft on Solaris and we are experiencing a problem with their module under apache. they have asked us to change the data segment size and file descriptor.
0
 
decdragonCommented:
Under CSH you would do the following:

>ulimit -d
 (You will get the current data segment value setting)
>limit datasize 780000
>ulimit -d
 (the returned value should be 780000)
Notice that the actual command to set the ulimit in CSH is actually "limit". In addition, under CSH you need to add the "datasize" resource variable.
0
 
ahoffmannCommented:
ulimit is sh and derivates (ash, bash, ksh, pdksh, zsh, etc.), in csh and tcsh the command is limit (as described by decdragon)
To get the current values in csh, simply do a
  limit

But keep in mind that you cannot change the values out of bounds specified by the kernel.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now