Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 189
  • Last Modified:

My Documents Folder location does not stay after logout.

Hi, I have many win2k workstations that are experiencing the same issue. The profiles are located on the "D" partition, but the "My Documents" icon on their desktop points to the "C:\MyData" folder.
I've opened the properties and selected "restore default" which then displays the correct path "D:\Profiles\msalzwe\My Documents".
While I stay logged in the my documents stay pointed to the correct location. Upon loging out then back in, the location changes back to C:\MyData.

What I've done:
1) Checked this site for possible resolutions. Some where close but not it.
2) Checked Microsoft KB. Again some were close...mainly stating how to change the location...which I have done.
3) Re-installed SP2 .
4) Checked permissions on ntuser.dat.
5) Check that the "personal" key in registry does get set properly before logging off.

My thoughts:
1) key is not saved on exit. Permissions show that it should be capable.
2) key is reset on logoff. Not sure what would be resetting it though.
3) key is reset on logon.
 

Any help would be greatly appreciated.
0
msalzwe
Asked:
msalzwe
  • 2
1 Solution
 
MPimentelCommented:
I would say, if you have a w2k domain controller, create a folder redirection policy for the my documents folder. I fyou don't know how, let me know and I will give you more details. But that is easy to do, and its what I would do instead of troubleshooting many machines.
0
 
msalzweAuthor Commented:
I have a mixed environment where the PDCs and BDCs are NT4 with member servers and workstations Windows 2000.
The problem is across many workstations since they were all populated with the same image.
0
 
MPimentelCommented:
Ok, here is the solution I tested:

1. Logon to the computer as local administrator.
2. Delete all profiles in the computer, by going to properties of my computer and then user profiles.
3. At the run command, type Regedit. and hit Ok.
4. Go to the key HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders and change the value of the one that says My documents to whatever you want.
5. close regedit.
6. Copy the profile of the local administrator to the dafault user profile with access to everyone on the local machine.
7. Reboot computer.

All users who login to that computer will  have the same my documents location.

You have to be sure that the NT coputers are not definind policies for folder redirection, because when the nt server sends thge policies, those are "hard coded" in the win2k pro registry, on a win2k server environment, the policies are chached on the clients and refreshed at logon, but this does not occurr on a NT environment.

Good luck. Let me know if you dont know how to copy profiles. Well, i should just tell you huh?

1. Open windows explorer.
2. Tools -> folder Options -> View -> Show Hidden Files and Folders - Click Ok.
3. Right click on my computer icon -> Properties
4. Click User Profiles Tab
5. For Each Profile <> Administrator, highlight and click Detete.
6. Highlight administrator profile.
7. Click Copy To
8. Browse to c:\documents and settings\default user -> click ok
9. Click Permitted to use and select the Everyone group on the local machine. Click ok -> Read the message and click Yes.

This actually very useful when you prepare your image. To give any user who logs to a machune to have the same windows desktop settings.

Cheers.
0
 
ewtaylorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
[accept mpimentel]
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
[ewtaylor]
EE Cleanup Volunteer
0

Featured Post

Important Lessons on Recovering from Petya

In their most recent webinar, Skyport Systems explores ways to isolate and protect critical databases to keep the core of your company safe from harm.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now