DHCP-Windows XP

I am connect to the internet via SMC barricade gateway router. DHCP is disabled on this. I set up a Windows 2000 Server and turned on DHCP on it. I authorized it and setup the scope which contains the default gateway address of the router. At a command prompt in all Windows 2000 clients I type ipconfig and IP address, subnet, and default gateway are correct. Now on my XP client, it was assigned an ip address ok but it did not receive the default gateway. Any help would be appreciated.
schmad01Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
MindphaserConnect With a Mentor Commented:
Force accepted

** Mindphaser - Community Support Moderator **
0
 
jboddyCommented:
Ths gateway address needs to be out of the scope! It has to be fixed.
You could end up issuing your gateway address to a client machine!
Either define the gateway adr as the first or last IP addr you have and cut it from the scope, or have two scopes, one before and one after the gateway addr.
You have been lucky so far that the gateway addr has not been given out to a client and killed your network!
0
 
SynTechCommented:

Schamd,

Please disregard the above comment.

What Schamd is saying is that he assigned the default
gateway as part of the scope options to be assigned
to all clients, not that he included the default
gateway address IN the scope to be given out.

At least, thats what I assume :)

If this is the case, check out this link:
<A HREF="http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q269879">
Microsoft Knowledge Base Article Q269879
Basically, make sure the server and client have the latest
Serive Pack and hotfixes.

Hope this helps.

0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
schmad01Author Commented:
SynTech is correct in his assumption. By the way its Schmad01. I will check when I get home , but I believe my Windows 2000 server has serv pak 2 already loaded.
0
 
jmiller47Commented:
Can you please specify your scope of IP addresses that you are using in DHCP on Windows 2000 Server? I have seen problems in XP that if you are using the wrong class of IP addresses then XP automatically assigns or screws up IP info to try and "FIX" your mistake...

0
 
ewtaylorCommented:
No comment has been added lately, so it's time to clean up this TA.
I will leave a recommendation in the Cleanup topic area that this question is:
[split syntech jmiller47]
Please leave any comments here within the next seven days.
 
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!
 
[ewtaylor]
EE Cleanup Volunteer
0
 
schmad01Author Commented:
Does not apply anymore.  No longer running XP.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.