• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 340
  • Last Modified:

Special Characters

Hi all,
     I'm changing from NT to Linux. All is working fine but because I'm in Mexico we use special characters as: áéíóúñ...

With windows NT there is no problems when I transfer files with special characters in the name to the server folder. But with Linux when I try to copy a file to Linux (samba) server folder then I get an error message and the file is created in the folder but I have no acces to it unless I go to the server (physically) and rename or delete the file or folder. I have noticed that this happens when I copy or transfer files with special characters.
Is there any configuration I have to do in the Linux box to accept the special characters?
0
d_plus
Asked:
d_plus
1 Solution
 
ahoffmannCommented:
Samba has sevaral configuration options for this, please read   man smb.conf  carefully, the combination of these configurations is important.

     mangle case
     case sensitive
     default case
     preserve case
     character set
     client code page
     mangled map
     mangled names
     mangling char
     
0

Featured Post

Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now