Solved

SSHD Fails to start

Posted on 2002-03-15
10
684 Views
Last Modified: 2013-12-27
Hi all gurus,

I'm using Solaris 8 Sparc platform. I downloaded all and installed all 7 packages(egd,openssl...) to install OpenSSH3.. as instructed from www.sunfreeware.com.
However when I run this command

#/usr/local/bin/ssh-keygen

to generate the private keys I received this error:

ld.so.1: /usr/local/bin/ssh-keygen: fatal: libc.so.1: version `SUNW_1.19' not found (required by file /usr/local/bin/ssh-keygen).

When I tried to start the sshd daemon I get this error:
ld.so.1: /usr/local/sbin/sshd: fatal: libsocket.so.1: version `SUNW_1.4' not found (required by file /usr/local/sbin/sshd)

Does anyone know what' s wrong?

ddl






0
Comment
Question by:ddl76
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +3
10 Comments
 
LVL 14

Expert Comment

by:chris_calabrese
ID: 6870812
Sounds like you downloaded a version compiled for a different release of the OS.
0
 
LVL 40

Expert Comment

by:jlevie
ID: 6871469
Chris is correct. The version that you downloaded is for some other version of Solaris. Why not just download the OpenSSL and OpenSSH sources and build your own? They aren't difficult to build and the result will match your OS version. The sources are available from:

http://www.openssl.org/
http://www.openssh.org/
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6873967
the message definititely prints: "fatal: lib* ... not found"
This might indicate application-OS-version mismatch, but I assume that it is simply a wrong LD_LIBRARY_PATH environment variable setting.
PLease check as follows:

   ldd /usr/local/bin/ssh-keygen
   ldd /usr/local/sbin/sshd
   echo $LD_LIBRARY_PATH

I'm pretty shure that LD_LIBRARY_PATH does not contain a path to libc.so and libsocket.so, which are in /usr/lib, usually.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:ddl76
ID: 6876352
Hmm,

I downloaded the package from sunfreeware.com. I also downloaded other packages and it works fine. How can it be wrong...?

I have also exported my new LD_LIBRARY_PATH with /usr/lib, but it doesn't work too.

ddl76
0
 
LVL 14

Expert Comment

by:chris_calabrese
ID: 6876799
The other packages you downloaded may not require a specific OS release.  The version you should be picking up is the one at http://www.sunfreeware.com/programlistsparc8.html#openssh

Alternately, you can get the source from www.openssh.com and compile it yourself.
0
 
LVL 51

Expert Comment

by:ahoffmann
ID: 6877918
ddl76, at the moment it's not important which package works, and which does not. The program in question needs to be checked. Please follow my suggestion, especially ldd, and post the resukts.
0
 

Author Comment

by:ddl76
ID: 6901365
I get this output for ssh-keygen:
 
libsocket.so.1 =>        /usr/local/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libc.so.1 (SUNW_1.19) =>         (version not found)
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2

I get this output for sshd:
 libpam.so.1 =>   /usr/lib/libpam.so.1
        libpam.so.1 (SUNW_1.1) =>        (version not found)
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libsocket.so.1 =>        /usr/local/lib/libsocket.so.1
        libsocket.so.1 (SUNW_1.4) =>     (version not found)
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libc.so.1 =>     /usr/lib/libc.so.1
        libc.so.1 (SUNW_1.19) =>         (version not found)
        libmp.so.2 =>    /usr/lib/libmp.so.2
0
 
LVL 51

Accepted Solution

by:
ahoffmann earned 200 total points
ID: 6914227
ldd's output tells you explicitely that there are some libs not installed, repectively not found via LD_LIBRARY_PATH environment variable. See lines with: (version not found).

You need to install thes libraries corectly, or install a openssh packackes which matches your installed libs.
0
 
LVL 21

Expert Comment

by:tfewster
ID: 8052583
No comment has been added lately, so it's time to clean up this Topic Area.
I will leave a recommendation for this question in the Cleanup topic area as follows:

- Answered by ahoffmann

Please leave any comments here within the next 7 days

PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER !

tfewster
Cleanup Volunteer
0
 

Expert Comment

by:SpideyMod
ID: 8099685
per recommendation

SpideyMod
Community Support Moderator @Experts Exchange
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
what is a good general partitioning scheme for RHEL? 23 144
OpenLDAP Proxy to Active Directy 6 453
add some character at the end of line in vi 7 107
Martian Packets Unix 5 73
In tuning file systems on the Solaris Operating System, changing some parameters of a file system usually destroys the data on it. For instance, changing the cache segment block size in the volume of a T3 requires that you delete the existing volu…
My previous tech tip, Installing the Solaris OS From the Flash Archive On a Tape (http://www.experts-exchange.com/articles/OS/Unix/Solaris/Installing-the-Solaris-OS-From-the-Flash-Archive-on-a-Tape.html), discussed installing the Solaris Operating S…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question