CDROM - Controller

Do I need a controller for the CDROM? Any existing ones I try to add (Add New Hardware) from the available list have a conflict.

Do I need to download a controller or could it be another problem?

My CDROM is accessible with DOS but if I do a dir or attempt to open it in Windows Explorer I get error messages.

It is a Mitsumi CDROM Model:CRMC-FX400D. I have updated the drivers, so autoexec and configsys have lines calling new files. Does this mean I don't have a controller!?

I'm thinking the h/w is stuffed.
But someone might have a suggestion that works.
I was going to clean a little marble in the case - but the phillips screws are to small - stopped that idea.

In the Device Manager it also reports it is running in MS-DOS compatibility mode:"Virtual Memory MS-DOS compatibility mode" and "Compatibility mode paging reduces overall system performance."

The CDROM says it is CATEGORIE 1 - The controllers availible are "Double Speed," "New Single Speed" and "Older Single Speed." There is no external label suggesting what this one is. It was manufactured in 1995.

So how do I determin its speed and how do I locate a new file - looks like it should be an ".ini" file? But then do I need a Controller?

Who is Participating?

Improve company productivity with a Business Account.Sign Up

1175089Connect With a Mentor Commented:
You do not need from separate controller for CD-ROM if it is IDE device (I think that your FX400 is).The device is connected to the standart IDE controller on the MB, like a HDD.If you use 2 devices on single channel (HDD and CD-ROM with one cable), one of them must be Master (this is jumper setting) and other must be Slave, and you must remove DEVICE=MTMCDAI.SYS/D:MTMIDE01 (or simular) line from your config.sys and MSCDEX.EXE /S /D:MTMIDE01 /M:10 (or simurar) line from your autoexec.bat
Chris RipollMaster of NoneCommented:
It may be a long shot...I have just fixed my brother-in-laws computer that was giving me the same grief. Everything seemed fine but could not get CD-ROM to work. Same message about compatability mode. The problem...........Junkie virus in boot sector...CD-ROM is back.

Like I said ...long shot...worth a check...

Good luck.
another thing you could try is to download updated cd-rom and chipset drivers
Building an Effective Phishing Protection Program

Join Director of Product Management Todd OBoyle on April 26th as he covers the key elements of a phishing protection program. Whether you’re an old hat at phishing education or considering starting a program -- we'll discuss critical components that should be in any program.

Your FX400 is IDE (I was concerned about the old Mitsumi drives that have a proprietary controller interface, but yours is not that old).

In your previous question, you had changed jumper to cable select, then ran into problems.  I trust you've gone back to either master or slave, taking into account what  1175085 says above.  If you're still on CS setting, remember that the selection of Master or Slave is dependent on the position on the cable:  the end of the cable is connected to Master and the middle connection on the cable becomes the Slave position.  If you've got the wrong connection (from your intention), then you could have a conflict with another device on that IDE channel.

Please start over in explaining to us the situation you have right now.  What operating system do you have?  What is the computer/motherboard brand and model?  Can you get into the BIOS (you reported a password problem previously)?  What does the BIOS show regarding the presence of the CDROM?  What is the setup regarding what IDE devices are master/slave on which channels?  What, if anything, is still in config.sys and autoexec.bat?  Have you tried several known good CD's in the drive lately?  If your hard drive is on the same IDE channel as the CDROM, does that hard drive (old ones) have a jumper on the back called Slave Present (labeled SP)?  If so, make sure it is ON or the CDROM will not work.  Have you checked for boot sector virus as chrisrip suggests?  And one last shot:  if you've searched registry for noide and deleted, then boot to safe mode, in device manager remove all IDE drivers and drive controllers, reboot and let Windows find and reinstall drivers.  Would be good to find updated motherboard drivers if possible, also.

There's your homework.  And, by the way, your drive is 4X.
Oh, one other thing.  Try the following:

-  Boot from a clean write protected boot diskette (make sure it was made with the same operating system as you have on the hard drive but NOT made by the troublesome computer's system).
-  Once at A:\> type fdisk /mbr (make sure there's a space between fdisk and /mbr) and press enter, this should return you to the A:\>
-  Type sys C: and press enter, once the system has been transferred remove the diskette and reboot the computer.
I found your motherboard from your other question.  You can learn how to flash the BIOS at, then download the zipped file for SI54PAIO Rev 2.1 at (at the bottom of the page).  Make sure you read the instructions from the first web site and download the proper flash utility so that the unzipped file from the second site will work.
1175085's suggestions make sense.

Did you know that you don't need to install any drivers for the CD. Ignore Window's suggestions of single or dual speed. If your drive works in DOS I wouldn't be too worried about the connections/cables either.

Do remember that Windows doesn't like DOS drivers for CD drives. It'll give you compatibility mode errors. In fact it disables these lines when installing Windows. Edit your Autoexec.bat and config.sys. Insert a "REM" (without the quotes) in front of all lines in these files that have anything to do with the CD Drive (theoretically you can REM all of the lines in these two files - Windows doesn't need them). Reboot your PC and your drive should work in Windows.
admollerAuthor Commented:
It has a IDE direct to MB so is set to master.
IDE adapter 0 Master (850) this is C:drive - ok

Below is the CD settings I guess:

IDE adapter 1   Master (None)
Autotype Fixed Disk [Press Enter]
Type [CD]
Write Precomp
Multi-Sector Transfer [Disabled]
LBA Mode Control [Disabled]
32 Bit I/O  [Disabled]
Transfer Mode [Standard]

Do those settings look ok?

Set IDE 1 (where is your CD)settings to AUTO.In some cases they works better.
Admoller, if the CD works in DOS then the setting ARE okay.

If you are still having problems in Windows can you confirm you tried disabling those lines in config and autoexec.
Chris RipollMaster of NoneCommented:
I must agree with Macrobeat. If the hard drive and the CD-ROM drive both work under DOS environment, then the hardware is definately OK. If the drive is unavailable once Win9x loads then you have a S/W issue and I would start by checking the bootup files (config.sys and autoexec.bat) as mentioned. If this is OK I would have to suspect a virus issue as I mentioned before. The junkie virus causes problems like these as it creates a condition where windows boots up with DOS compatability mode on drives. It also infects I once saw someone spend 4 hours loading and reloading NetWare 5.0 on a server with strange errors that made no logical sence. It turned out to be the Junkie virus sitting in the boot sector of his netware boot disk.

Cheers & good luck.
Thanks chrisrip.

If Admoller confirms my previous question my next advice was going to be to delete the IDE controllers in the device manager and let windows re-find them on a hard re-boot.
Macrobeat:  along with a bunch of other stuff (hopefully not overdone), I suggested that early on; however, we've not gotten confirmation of several of the steps we've recommended.   We still don't know about a boot sector virus, the status of the config.sys and autoexec.bat files, or whether controllers have been "removed" from Device Manager and refound.  Those three items seem to have priority before we can know if any further troubleshooting is required, wouldn't you agree?
Micro66, absolutely

I can see better when the light is on :-)
admollerAuthor Commented:
Sorry about the delay/reply.
I have removed lines and removed controllers, no success.

When I mentioned it was ok in DOS, that is I can type d: and it appears to change ok. But then when I type in dir it produces an error, "CDR101:Not ready reading drive D."

I've fdisked /mbr ok

So I believe it is h/w stuffed.

The original question was do I need controllers, 1175089 answered that first so I'm accepting that!

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.