Solved

cannot telnet to new machine on network.

Posted on 2002-03-18
5
237 Views
Last Modified: 2013-12-27
There is a new machine on our network and when I try to telnet into it, I get a message saying "Not on console."  It won't let me telnet into it, so my question is:

What setting do I look for on a server that will not allow telnet from remote machines.

0
Comment
Question by:carydb
5 Comments
 
LVL 5

Expert Comment

by:ecw
ID: 6877798
Try to login as something other than root.  By default root can only login on the console.  From /etc/default/login,

# If CONSOLE is set, root can only login on that device.
# Comment this line out to allow remote login by root.
#
CONSOLE=/dev/console

0
 

Author Comment

by:carydb
ID: 6877832
Yes, I can login with my user ID, but I would like to log in as root.  The /etc/default/login Does not have CONSOLE set, so It seems like I should be able to telnet into the box.  The following is from the machine's /etc/default/login:

# If CONSOLE is set, root can only login on that device.
# Comment this line out to allow remote login by root.
#
#CONSOLE=/dev/console


This new machine is replacing a machine that has been in the network for a while.  That older machine will allow telnets from root.
I would like to tkeep the new machine configured as closely as possible to the old one.

Any other ideas?

0
 
LVL 5

Expert Comment

by:ecw
ID: 6878455
This is the sual cause, have you checked the entire file to make sure there isn't any line beginning with
  CONSOLE=
0
 
LVL 38

Accepted Solution

by:
yuzh earned 50 total points
ID: 6878702
Telnet is not secure, you should not use telnet to login as root to the system.

Get a copy of secure shell installed on you system, and use secure shell instead.

   you can download it from the following site:

   http://sunfreeware.com/

0
 
LVL 4

Expert Comment

by:newmang
ID: 6881208
You really should not allow root to telnet in directly, you should consider a secure shell as yush suggests.

In the meantime you can telnet in as your user then type su - and provide root's password to become root.

Note the - after the su means you become root with root's environment, if you leave the - off then you become root but with your own environment.

Cheers - Gavin
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
This video shows how to set up a shell script to accept a positional parameter when called, pass that to a SQL script, accept the output from the statement back and then manipulate it in the Shell.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now