can't ftp and telnet in Redhat7.2

After logon as root, I try to ftp and telnet to the localhost in Konsole. Here's the error message, would you pls help?


# ftp localhost
Connected to localhost.localdomain.
220 xxx FTP server (Version wu-2.6.1-18) ready.
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): anders
331 Password required for anders.
Password:
530 Login incorrect.
Login failed.
ftp>

# telnet localhost
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Red Hat Linux release 7.2 beta with CLE (Gaga)
Kernel 2.4.12-0.1 on an i686
login: anders
Password:

System error
Connection closed by foreign host.

Many thanks!
Anders.
andersyAsked:
Who is Participating?
 
jlevieConnect With a Mentor Commented:
Sorry, it's /usr/sbin/authconfig... My bad...

I'm guessing that the system is configured for a GUI login and that's why you are having trouble with root's login.

There's a way to get to a console, even with the GUI login enabled. Alt-Ctrl-F2 will take you to another virtual console (and Alt-Ctrl-F7 will take you back to the GUI). You can run authconfig in a terminal window from root's login, but the terminal type isn't right and the display is a bit messed up. You can still use the tool that way but it's harder to figure out what you are doing.
0
 
SixpaxCommented:
Please answer the following questions:

1) does ftp and telnet work as root instead of anders?
2) what does the entry in /etc/passwd look like for "anders"?
3) what are the contents of /etc/shells?
4) what are the contents of /etc/hosts.allow?
5) what are the contents of /etc/hosts.deny?
6) if you are running inetd, what does the ftp and telnet entries look like in /etc/inetd.conf?
7) if you are running xinetd, what are the contents of /etc/xinetd.d/telnet and /etc/xinetd.d/wu-ftpd?
8) what happens when you run "su - anders" as root?
0
 
MFCRichCommented:
Your FTP stuff appears as though you entered the wrong password for 'anders' or that user doesn't exist.

On most distros root cannot log-on to telnet or ftp for security reasons. If you need root access through telnet you should telnet in as a normal user and then 'su' to root.
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

 
jlevieCommented:
This system sure doesn't look like RedHat 7.2 to me. Neither the 7.2 distribution nor the updates provide kernel-2.4.12-0.1. And that might be a cause of the failures being seen.

However, it looks somewhat like the system might be configured for other than normall password/shadow file authentication. The wu-ftp server doesn't normally toss an Kerberos error message and seeing that messages makes me think that it might be Kerberos that is failing or isn't compatible with the FTP and telnet server.
0
 
andersyAuthor Commented:
Hello Sixpax,

1. still won't work for root
2. anders:x:500:500:anders:/home/anders:/bin/bash
3. /bin/sh
   /bin/bash
   /bin/bash2
   /bin/ash
   /bin/bsh
   /bin/tcsh
   /bin/csh
   /bin/ksh
   /bin/zsh
4 and 5. no content
6. using xinetd
7. telnet:
   service telnet
   {
        flags           = REUSE
        socket_type     = stream
        wait            = no
        user            = root
        server          = /usr/sbin/in.telnetd
        log_on_failure  += USERID
        disable         = no
   }
   wu-ftpd:
   service ftp
   {
        socket_type             = stream
        wait                    = no
        user                    = root
        server                  = /usr/sbin/in.ftpd
        server_args             = -l -a
        log_on_success          += DURATION USERID
        log_on_failure          += USERID
        nice                    = 10
        disable                 = no
   }
8. I can su to anders.


Hello MFCRich,

You may be right as I can't login anders in login prompt. Even I change the passwd in User Manager, I still cannot login. Do you know why?


Hello jlevie,

My version is "Red Hat Linux release 7.2 beta with CLE (Gaga)", where CLE is Chinese Language Extension. If it's the problem of Kerberos, do you know how to fix?


FYI: When I try to login FTP using anonymous, it works. I think it should be the problem of authentication. Do you guys have any hints?

Many thanks.
0
 
jlevieCommented:
Is the system configured to use Kerberos Authentication?
0
 
andersyAuthor Commented:
Hello jlevie,

Can you tell me how to check if the system is using Kerberos Authentication?
0
 
SixpaxCommented:
I know this doesn't answer the problem with your user login, but to allow root to login through telnet or ftp you need to remove/rename the /etc/securetty file.  By default, root is not allowed to login to the machine from a remote connection.

What messages do you get when you try to login as "anders" from a login (console) prompt?
0
 
jlevieCommented:
Check /etc/sysconfig/authconfig. If Kerberos is being used there'll be a line containing 'USEKERBEROS==yes' and somewhere you'd have a Kerberos server that all systems would be configured to use.
0
 
andersyAuthor Commented:
USEKERBEROS = no

Do you have any other suggestions?
0
 
jlevieCommented:
Can the anders user log on the the console?

Also can I see the contents of /etc/sysconfig/authconfig?
0
 
andersyAuthor Commented:
Hello jlevie,

I can't login as anders, even I've changed the password. I can only login using root.

Here's the content:

# cat authconfig
USEHESIOD=no
USELDAP=yes
USEMD5=yes
USENIS=no
USEKERBEROS=no
USELDAPAUTH=yes
USESHADOW=yes
USESMBAUTH=no

Pls help!
0
 
jlevieCommented:
Okay, according to what's above your system has been configured to use LDAP for user names and authentication. Is that what you intended and do you have an LDAP server that's configured to provide Linux compatible authentication?

Since you say that you've changed the password for anders, my guess if that you've done it on the Linux system. But, since the system has been told to use LDAP that has no affect.

To change the authentication method you'll want to log in on a console, not the GUI, and execute /sbin/authconfig. Uncheck LDAP and leave "Cache Information", "Use NIS" and "Use Hesiod" un-selected on the first screen. On the second screen only "Use Shadow Passwords" and "Use MD5 Passwords" should be selected. Reboot when done and you should be configured for conventional authentication.
0
 
andersyAuthor Commented:
Oops... I can't login as root in Console! I can only login as root in graphic mode.

Can I directly modify /etc/sysconf/authconfig by setting
 USELDAP=no ?

BTW, I can't find the file /sbin/authconf.
0
 
andersyAuthor Commented:
I can login as anders and perform ftp and telnet.
Many thanks!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.