Getting an AS400 to send an email

Hi,

Could someone point me in the right direction regarding getting an AS400 which runs OS400 to send an email to a pc running Outlook 98 which uses smtp as its email protocol.


Many Thanx

Notorious.................
NotoriousAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

 
MN_DaveCommented:
Have you tried something like this?

SNDDST TYPE(*LMSG) TOINTNET((myaddress@mydomain.com))
DSTD('Miscellaneous Message') MSG(TEST)
LONGMSG('This is a test email.')                    
0
 
samic400Commented:
use SNDDST command. Using the following syntax to send out an e-mail message:

SNDDST TYPE(*LMSG) TOINTNET((<e-mail address here>)) DSTD(<subject>) LONGMSG(<message here>)  

you will need to have SMTP running.

STRTCPSVR cmd and start SMTP server.

Add a directory entry:

ADDDIRE  USRID(INTERNET GATEWAY)  USRD('Allow OV/400 to send INTERNET Mail')  SYSNAME(INTERNET)  MSFSRVLVL(*USRIDX)

PREFADR(NETUSRID *IBM ATCONTXT)

Press the Enter key.  Then, type the following:

CHGDSTA  SMTPRTE(INTERNET GATEWAY)

This should do it for you.

Also, STRMSF to make sure this is running too!






0

Experts Exchange Solution brought to you by ConnectWise

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
 
rwardCommented:
Another option to using SNDDST (which requires you to setup and configure the SMTP server on the AS/400) is to use SNDM which is an open source email utility that allows you to use any SMTP server.

The link to the freeware SNDM utility is: http://homepage1.nifty.com/uzaemon/#download

The utility does require you have the ILE RPG compiler on your machine.

Rob
0
 
NotoriousAuthor Commented:
I wish to accept samic400's answer because his solution worked and he gave a good detailed response. rward's response would not of worked because my machine does not run an ILE RPG compiler.

Notorious..........

P.S Sorry for the late response
0
 
NotoriousAuthor Commented:
Thank you. Sorry for the late response.

Notorious..........
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.