Solved

System bios hook

Posted on 2002-03-19
25
18,522 Views
Last Modified: 2007-11-27
Hello All;

"Error! Cant find system BIOS'hook." is the error message
when trying to update Phoenix bios on a custom built
HP Pavillion 7905 with an Asus A7M266-M board.

Same error using HP's dmiflash.exe or awflash.exe
with bios settings at default.

Also, any links for replacement bios will be appreciated.
Points splits or additional if needed.
Thanks for any and all input.
0
Comment
Question by:centerv
  • 9
  • 4
  • 4
  • +4
25 Comments
 
LVL 2

Expert Comment

by:genguy
ID: 6881858
Make sure you make a back up copy of your present bios and be absolutely sure you are flashing in the correct rom code. Double check the bios versions now, if it gets flashed with the wrong one, it may not boot again, and may not be fixable.
Try this one from hp's site:
http://www.hp.com/cgi-bin/cposupport/swindex.pl?p=hppavilion67254&l=en&c=BIOS

Good luck, and be carefull.
0
 
LVL 18

Author Comment

by:centerv
ID: 6882342
genguy
Good points but not applicable in this case.
The error is immediate after executing aflash.
No other options are available post error.
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 6883134
Well it looks like your BIOS wants to go fishing but doesn't have any hooks to put its worms on. LOL

Just having some fun with you cent. Wish I had something to offer that would help. :>)


The Crazy oNe
0
 
LVL 18

Author Comment

by:centerv
ID: 6883341
Hi Crazy  :-)
That's where I ought to be, fishing!

Haven't found much on this, except that it seems to be
common to Asus boards with or without HP.
Neither site is much help or their tech support, so far.
The dealer that sold the PCs is stumped as well and I've come up blanks with purchasing replacement bioses.
Not much time to chase this further right now, so hopefully
someone here may have seen this before.
Later.
0
 
LVL 1

Expert Comment

by:BOFH
ID: 6883576
hiya centerv

www.unicore.com

they do replacement bios'
Have you tried re-setting the bios (jumper off battery)
???

www.amptron.com for tons of bios utilities :)

Good Luck

BOFH
0
 
LVL 18

Author Comment

by:centerv
ID: 6884035
Hi BOFH
Received sticker shock from unicore/mrbios at $70.00 each.
Last bios I purchased was $10 from a manufacturer.
I understood that Asus sold their bios for $25.00 but I've
not been able to get an answer from them or find a link
for their bios sales.
As this is a favor for a friend, (didn't know what I was
getting into!) I'm inclined to stay on the low end.
Will check amptron.
0
 
LVL 2

Expert Comment

by:genguy
ID: 6884876
Hit f1 while booting and get the bios version number from the main setup screen, post it for us, please.
For Phoenix bios I think you need to use Phlash.exe utility.
This site has some good faqs about bios flashing, and can reprogram a failed flash. I have attached what I think is applicable.
http://www.badflash.com/faq.html

Q. I have a PHOENIX bios and the PHLASH.EXE gives me no option to save the old
file. What can I do?
A. The latest AMI and AWARD flash utilities can usually be used to make a backup of
your old file. These utilities are available for download from any major motherboard
site. If this does not work there is a great program called UNIFLASH available at
http://www.pppr.sk/rainbow/programs.html#UniFlash that can also be used to save the
file. DO NOT attempt to use any of these to actually flash your chip, the PHLASH.EXE
program must be used for that.

5. You have a defective chip. You can just about bet on it if you peel back the sticker
on your chip and find it is made by MX or ASD or marked with an H.T and then a string
of numbers. Only about 1 out of 10 of these chips will take a reflash due to their poor
quality. It is the failure of this chip that likely caused your flash to fail, unless you know
you used the wrong file. If the flash utility properly detected your BIOS chip and gave
you a verification error or a write error part way through it is very likely your chip is
bad. If your flash utility can not identify the chip, suspect the chip is bad. If your flash
went normally, gave no errors, but your machine no longer works, suspect a wrong or
corrupted file.
0
 
LVL 18

Author Comment

by:centerv
ID: 6885326
genguy
Phoenix Bios 4.0 release 6 0 E
The sticker on the bios chip (not on the bios proper)
has the following  A26HT 308 LCBO

I'm inclined to think that the chip is bad, except for the
fact that these machines are new (2 of them with same mobo
and haven't tested a third yet) and both have the same problem.
ME preloaded and they run great, but an XP upgrade calls for a bios flash. Dmiflash is the HP utility and aflash is
the Asus utility for flashing this board.
Both Hp and Asus seem very reluctant to sell bios replacemnets.
Your above links seem very promising and will check out, but it may not be for a day or so.
0
 
LVL 2

Expert Comment

by:willinois
ID: 6886536
Similar question on a German equivelant site (roughly translated):

-- Translation Results by SDL International --
Subject: BIOS of the P2B Mainboard flashen discussion group: hardware I hab the 45 GB hard disk of Western digitally bought me and had to assess in the new type of the computer that I require a new Bios-version. It gives run brought also on the Asus-homepages, to be sure hab I no program with the pertinent ROME to that to this. Hab tries I: AFlash v 1.26 Ami-Flash v8.2x Phlash ROME: 1012 Final 1013 concrete AFlash brought immediately a mistake message in the start: "Error. Cant find system BIOS Hook" the other both the ROME did not accept. (Size etc.) Can someone herewith help me? Jonas Of: Jonas enamel: jonas.z@gmx.net date: 22.07.00 20:31:00 -------------------------------------------------------------------------------- . -------------------------------------------------------------------------------- . You bist certainly the correct BIOS (!) to the correct (!) To have Board? Asus had on its pages tp://www.asuscom.de/de/support/techmain/bios/index.htm B BiosUpdates and accompanying Flasher, in addition to information actually always quite well "together".. Test perhaps again - greeting Manuel of: Manuel enamel: electronicconsulting@t-online.de date: 22.07.00 20:50:00 -------------------------------------------------------------------------------- . -------------------------------------------------------------------------------- . Oh Jonas, I forgot: would test, set whether you for the Flashen a Jumper mußt ("Schreibschutz" openly) and: Aflash126.* should be actually correct.. mfg Manuel of: Manuel enamel: electronicconsulting@t-online.de date: 22.07.00 21:12:00 -------------------------------------------------------------------------------- . -------------------------------------------------------------------------------- . The flashdatei must have the ending in the award-bios. awd. Of: Oliver enamel: asci01@freenet.de date: 23.07.00 12:34:00 -------------------------------------------------------------------------------- . -------------------------------------------------------------------------------- . Bruised! First it (!) must seek is after the download name - usually one *. zip secondly there inside then an aflash*. exe third hot the file of the Updates mostly *.bin, can contained however also only figures.. All other (Board/BIOS-Hersteller) only greeting Manuel shake of: Manuel


At least it gives a BIOS support site, and looks at some jumper settings.
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6887016
Latest AFLASH util:
ftp://ftp.asus.com.tw/pub/ASUS/mb/flash/aflash.exe
BIOS 1006 for A7M266:
ftp://ftp.asus.com.tw/pub/ASUS/mb/socka/amd760/a7m266/am261006.zip

Are these actual retail ASUS boards that you're putting into HP Pavilion cases or are they OEM'd boards made by Asus for HP?  If the latter, see this page:
http://www.hp.com/cgi-bin/cposupport/swdl.pl?c=pv167&i=pv-1009-1&p=hppavilion67254&n=hp+pavilion+PC+model+7905+configurable

Sounds like you need to make a typical Win98/DOS boot disk (apparently there is an option for this in WinXP, but you can just format /s a: from a Win98 box).

-dog*
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6887021
Also, if you can dig it out of willinois' comment above, it seems to indicate that there is a "BIOS flash enable" jumper that needs to be set, so check for that also.

-dog*
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6887047
I've read some conflicting info on this system...some info says it has an Athlon XP, some say a Pentium 4 2GHz?

-dog*
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 18

Author Comment

by:centerv
ID: 6887296
willinois
Sorry, the link you posted does not work for me. Could you check?
dogztar
these boards are A7M266-M (M for mid I'm guessing) which truncates
the boards leaving only 3 PCIs and an AGP.
They are Athlon XP CPUs.
Being M boards, makes them slightly different than the full
A7M266 They have only one jumper, which I believe is the cmos clear
but it does have an option in the bios configuration to allow the bios to upgrade.
When I enable this option, it does not save to cmos.
It goes thru the motions, but doesn't save.
In other words, when I access the bios again, that option is back to being disabled.
The boards are clearly stamped Asus with the board number
and as these are custom build Hps, the hardware is not proprietary,
except for the bios (I'm guessing, as the bios is clearly HP)
Bios rom/bin  vrs is irrelevant, as the error comes up directly after executing the exe no matter which (latest).
My search prior to posting here led me to different models of
Asus boards as far back as 3 years ago,producing that same error,  and also to HPs, (presumably with Asus boards).
The majority of the post  are in a language other than english, which leaves me out.
Cannot find the A7M266-M on Asus's site.

0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 6887303
I assume the A7m266-M the -m stands for "Micro" as in MicroATX hence the reduced slots, etc.  I think you will need to contact HP for this, to get the proper upgrade.  Its very funny how HP has a "model" number that can represent 2 completely different baseline systems; ie. a AthlonXP base or Pentium4-base.  The link I posted does have information on 3 different BIOS updates, but they don't specify which is which (as in for what system, just a board specification, something like BoraBora or Amazon??)  Obviously the BIOS update you need will differ depending on what CPU/chipset is on the board.  What about the Northbridge/southbridge?  Is it a VIA chipset??  The northbridge should be near the CPU, about 1.5 inches square.  It may have a heatsink on it...

-dog*
0
 
LVL 18

Author Comment

by:centerv
ID: 6887456
These don't seem to be micro boards, as generally micros
I've worked with have 2 PCIs and no AGP.
This particular line is an HP custom configuration, and to that end
Hp refers all to the retail dealer. The retail dealer in this case leaves a lot
to be desired and say no more.
It seems HP uses this line for their different configurations
and therefore the confusion because the 7905 can either be an
Athlon or Pentium depending on the board used I suppose.
These systems were a bargain and therefore not much documentation with them.
The Amazon etc I've not been able to decipher yet, either.
The chipset is the same as the full size Asus A7m266 and
what a combo!
The controller is an AMD761 and the PCI set is Via.

The update and flash I've been working with is 3.11 Amazon(3.09 now installed) as that was the only update on that site when I started this project.
Will check the 3.32 file.

Been a while since I've been this stumped  :-)


0
 
LVL 2

Expert Comment

by:willinois
ID: 6887582
dogztar,

your right, it should have been http://www.asuscom.de/support/techmain/technical.htm
but that's the Deutsch version

I think this would be closer:
http://usa.asus.com/inside/flash_mb.htm
0
 
LVL 2

Accepted Solution

by:
genguy earned 150 total points
ID: 6887776
O.K. guys and gals, I downloaded all three and unzipped them. The Amazon one has updates for the the Northwood core. This is an Intel cpu. This is definetly not the correct bios for your boards. So it's probably a good thing that the flash didn't work. The BoraBora/Bermuda is probably the right one, but you need to confirm this. Check the release notes and readme that is packaged with the updates. At one point I found a search engine on HP's site that you could just type in the version and revision numbers and it would return the correct bios updates, but do think I can find it again? no way. Well if I run accross it again I'll post a link.
I couldn't find this board (-M) either. Maybe it was a just for HP version?
0
 
LVL 10

Expert Comment

by:kiranghag
ID: 6887858
most branded mobos have a jumper to disable FLASH upgrades.
I have seen couple of HPs that have this tooo.
so make sure that u have enabled flash upgrade juper or switch on the motherboard.
u'll have to dig for ur manual or actually search ur mobo for any printed info abt the jumper.
0
 
LVL 2

Expert Comment

by:willinois
ID: 6888808
Often you can find specific MOBO jumper setting on the internet if you search very dilligently.
0
 
LVL 10

Expert Comment

by:kiranghag
ID: 6890624
HP puts a silver sticker usually inside
0
 
LVL 18

Author Comment

by:centerv
ID: 6891571
Ok all.
Here's the scoop from my findings.
One must have all the documentation when working with an HP
(my first time) or a reliable and knowledgeble retailer.
HP's code names mean nothing unless one knows exactly what they are.
To the retailer's defense, price (discount)was a factor, but still doesn't
make up for lack of knowledge.
This one turned out to be a Bermuda and the 3.32 did the trick.
winXP loaded and humming away.
Overall I'm impressed how well these systems are running.
Asus never responded to my emails and their tech support site left some to be desired.
HP phone support unable to help without numbers and the
emails referred to retailers for support.


genguy
Appreciated your effort and input. Totally missed the northbridge bit.
Would have liked to see the -M clarified but we may not
get it from either Asus or HP.

dogztar
Appreciated the effort you put into this question.
Please look for a separate post for you.

Crazy
Hope you haven't salivated too much hoping to get your claws in this one. LOL
Time for me to go back to fishing!
You should have surpassed me in win98 by now, as I've not put much time in here lately.

All others
Thank you for your participation.

centerv

0
 
LVL 18

Author Comment

by:centerv
ID: 6891574
Increased points for your effort.
0
 
LVL 44

Expert Comment

by:CrazyOne
ID: 6891657
>>>Crazy
Hope you haven't salivated too much hoping to get your claws in this one. LOL
Time for me to go back to fishing!

Naw I was just hoping you, your BIOS and me could do some fishing together. LOL


>>>You should have surpassed me in win98 by now, as I've not put much time in here lately.

Not quite yet but I am on your doorstep though. I don't hang out as much in the Win98 TA as I did. Since Win98 is going to be phased out by MS around the mid year 2003 I prefer spending my time with the Win2000 and XP TA's since these OS's MS will be supporting and selling for some time to come. :>)
0
 
LVL 18

Author Comment

by:centerv
ID: 6891790
How true, Crazy.
Peeking in XP occasionally, but not too much action.
Didn't get mail for over 2 weeks recently.
Hopefully the site will recover soon.
0
 
LVL 2

Expert Comment

by:genguy
ID: 6891891
Glad to hear it worked out, (With help from from my friends, CO,BOFH,Will,Dog,Kir) I'll be in your neck of the woods soon and in need, since I'm going XP in the next month. See ya soon.
Genguy.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

The Rasberry PI is a low cost piece of hardware that you can have a lot of fun with through experimenting and building/working on projects like media players, running a low cost computer, build data loggers etc. - see: https://www.raspberrypi.org
Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now