Solved

a problem with rcmd and rexec  routines

Posted on 2002-03-19
3
926 Views
Last Modified: 2012-05-04
My linux application need a way of starting its remote server on the same platform.
rcmd and rexec are for me the answer to the need, but
then a problem arises.

For the rcmd I'm providing the necessary arguments
perfectly :
   For a try on single machine using a looping TCP
   connection (i.e to 127.0.0.1 with localhost as the
   hostname).  
   
    char **ahost;
    *host=(char *)malloc(30);
    strcpy(*host,"localhost");
    rcmd(**ahost,514,"root","spy","mkdir new",0)
   
The execution of this compiled version of these codes
give as error message: Permission Dinied.

showing that The authentication failed.

for the case of rexec I try with a similar demo with
port number 512 but this
time the error message is
-> :localhost.localdomain: connection refused. (which appears after a long waiting )

My question is :
--------------
  Is there some special configurations
practices needed by the server (rshd and rexecd)of these two routines.
Or is there any special way to use this two routines? If
yes can u please tell me the minimum necessary
requirements that must checked before having a successful
usage of this two routines.
steps
 







 

  ahost,rport,locuser,ruser



0
Comment
Question by:marech
3 Comments
 
LVL 2

Accepted Solution

by:
pheur earned 100 total points
ID: 6902249
1. Forget about rcmd, rsh, rexec, rlogin, and even telnet. use ssh instead. Any decent Linux or UNIX distribution has it. You will have to use

system("ssh ruser@host remote command");

This normally requires you to enter a password. To avoid it generate with ssh-keygen a keypair, and install the public key on the remote machine and the private key on the machine starting ssh. See the ssh documentation for more details.

2. If you still insist on using the horribly insecure rcmd/rexec, make sure that rexec is enabled on the remote machine in /etc/inetd.conf, and is not filtered by the firewall.
3. Applications that start their servers on remote machines are a very bad habit.

----
Radu-Adrian Feurdean
Brainbench Linux MVP
0
 
LVL 20

Expert Comment

by:jmcg
ID: 9901570
No comment has been added lately, so it's time to clean up this TA.
I will leave the following recommendation for this question in the Cleanup topic area:

Accept: pheur {http:#6902249}

Please leave any comments here within the next seven days.
PLEASE DO NOT ACCEPT THIS COMMENT AS AN ANSWER!

jmcg
EE Cleanup Volunteer
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now