[2 days left] What’s wrong with your cloud strategy? Learn why multicloud solutions matter with Nimble Storage.Register Now

x
?
Solved

Can't connect to the internet after Win2k re-install

Posted on 2002-03-21
16
Medium Priority
?
176 Views
Last Modified: 2010-04-13
I recently re-installed Windows 2000 Professional on my computer and things seemed to go smooth at first. But when I tried to connect to the internet (via cable modem), I could not get a connection. I have tried repairing the installation, switching ports on the hub, switching network cable, replacing NIC card, and using a different PCI slot. I know my cable modem is still working becuase my other PC works fine. I also know the NIC card works fine because I can pull up the "bad" computer from the "good" computer over the network. However, when i do an IPconfig from the command window I have no settings.

Anyone got any ideas on what is happening and how I can fix it?
0
Comment
Question by:emeysenburg
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
16 Comments
 
LVL 5

Expert Comment

by:buddhole
ID: 6888261
More info please:

- have you got a router?
- does the cable modem provide dhcp ?
etc
0
 
LVL 2

Expert Comment

by:omk
ID: 6888340
Check if your NIC is disabled.
If you have nothing in ipconfig you did not install TCP/IP,
if it is 127.0.0.1 then you have problems with your NIC (hardware or configuration.
Click Start->Settings-> Network and Dial up connections.
Do you have local area conection icon there?
If NO then system can not foind your NIC, check device manager.
If yes, right click on the icons (it should be enabled (disable on pop-up window), goto the properties. check show icon box, verify that you have tcp/ip istalled, checked its configuration.
0
 
LVL 1

Expert Comment

by:rpaquet
ID: 6888630
Verify if your host file is correct.
simply try ipconfig/release and ipconfig/renew.
Is your PC correctly add to the domain ?
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 1

Author Comment

by:emeysenburg
ID: 6888953
more info....
I do not have a router. I have two standalone computers that are connected to a switch (i had said hub earlier... sorry). The switch is then connected to the cable modem. The ISP provides DHCP.

TCP/IP is installed. When pulling up Network and Dialup Connections from the start menu and selecting Status, the dialog box confirms that I am connected. If I select properties from the same place, I have 4 components listed (and checked)... Client for Microsoft Networks, File and Print Sharing, NetBEUI, and Internet Protocal (TCP/IP). When I select properties from TCP/IP, I have 'Obtain an IP address automatically' and 'Obtain DNS server address automatically' selected.

Clarification:
When I do a ipconfig from the command line, here is what i get.

Connection-specific DNS Suffix  . :
AutoconfigurationIP Address . . . : 169.254.194.61
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

It should be this (or similar):

Connection-specific DNS Suffix  . : kc.rr.com
IP Address. . . . . . . . . . . . : 65.28.xx.xx
Subnet Mask . . . . . . . . . . . : 255.255.252.0
Default Gateway . . . . . . . . . : 65.28.xx.xx

Hope this helps with diagnosis.


0
 
LVL 2

Expert Comment

by:omk
ID: 6889074
This is an APIA address.
Quick fix is to assign temporary static IP address, reboot PC and then check "obtain IP address automatically" again.
You can not release APIA address with ipconfig.
You need to edit registry to disable APIA permanently.
0
 
LVL 1

Author Comment

by:emeysenburg
ID: 6889313
omk: can you be more specific.

What is a APIA address and what is it for?
How does this prevent my system from obtaining an IP from the DHCP server?
How do I edit the registry to disable APIA permanently?
0
 
LVL 2

Expert Comment

by:omk
ID: 6889354
They call this APIPA as well:
this is the link with short explanation:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;q255836
To disable it completely you need to create a new key IPAutoconfigurationEnabled of type REG_DWORD within the subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\
Assign 0 to this key,
to enable change the value to 1.
And you need to reboot PC.
The worst case you need to do it up to 5 times,
but already mentioned trick with a temporary address can save you some time.
0
 
LVL 2

Expert Comment

by:ssr
ID: 6889791
The problem is that the machine can't find a DHCP server to get an IP address from, or it isn't setup to use DHCP.  How many machines do you have, and do you have a dedicated DHCP server?

SSR
0
 
LVL 1

Author Comment

by:emeysenburg
ID: 6890028
omk:
you were correct about the APIPA. I have since setup an IPAutoconfigurationEnabled key in the registry. This corrected the problem of getting an AutoconfigurationIP Address of 169.254.194.61. Now when I do ipconfig, I just get 0.0.0.0

While playing with the registry, I compared the settings between my 2 computers. The computer that works had a lot more settings than the other so I added a few registry keys to see if I could force it to find the DHCP server. Here is what I added: DhcpDomain, DhcpDefaultGateway, DhcpServer, DhcpNameServer, DhcpSubnetMask, DhcpSubnetMaskOpt..... I added all those and still nothing. However now the ipconfig displays Connection-specific DNS Suffix  . : kc.rr.com  like it should.

I am raising the point value since this seems to be a pretty difficult question.

ssr: please see my second response.

Thanks for the help
0
 
LVL 1

Author Comment

by:emeysenburg
ID: 6890031
forgot to update point value
0
 
LVL 1

Author Comment

by:emeysenburg
ID: 6890052
update:
I pulled up Microsoft Management Console to look at the errors being generated and here is the DHCP error:

Your computer was not assigned an address from the network (by the DHCP server) for the Network Card with the address 0040xxxxxx. The following error occurred: The semaphore timeout period has expired. Your computer will continue to obtain an address on its own from the network address(DHCP) server.


0
 
LVL 2

Accepted Solution

by:
omk earned 900 total points
ID: 6890206
Write down Ip address and other information from the pc which can see internet, unplug it from switch, type in these numbers in your test pc. If it works it means that your ISP releases only one IP address, and you need the second nic to be installed and internet sharing turned on.
0
 
LVL 2

Expert Comment

by:omk
ID: 6890212
BTW, I do not like this semaphor message.
Do you have scsi devices on this computer?
0
 
LVL 14

Expert Comment

by:AvonWyss
ID: 6891073
On the switch, does the status led for the network connection where you plugged in the Win2K computer show a connection? Does also the Win2K NIC show a connection (if the NIC has a connected led)?

If this is OK, go to Network connections and open the NIC's properties. You may want to enable the "Show connection in taskbar" option since it will allow you to see when data is sent or received by blinking. Open the NIC's status window, if the "Sent Packets" or "Send Bytes" (depends on the NIC driver) greater than zero? I assume that receive is 0.

If send is greater than 0, could it be that your ISP only allows a limited numer on machines to be connected? Som ISPs have a limitation of 1, or 2, computers. If the DHCP server encounters a new computer (MAC address), it just doesn't give a DHCP address. In this case, ask your ISP to reset the registeres MAC addresses of your computer.

omk, a semaphore (in computer programming) is a structure used for thread synchronization. It's not related to SCSI at all. When DHCP tries to get an address, it uses auch a semaphore to lock the NIC until the DHCP answer packet has arrived. If it does not arrive, the semaphore timeout expires, and the DHCP client knows that there was a problem.
0
 
LVL 1

Author Comment

by:emeysenburg
ID: 6893193
Turns out the error WAS with ISP. They recently upgraded their servers to only allow one IP address per MAC address.

Thanks for the help.

0
 
LVL 2

Expert Comment

by:omk
ID: 6893694
emeysenburg
You know that if you turn on ICS, you still can enjoy internet sharing.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
It’s time for spooky stories and consuming way too much sugar, including the many treats we’ve whipped for you in the world of tech. Check it out!
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Please read the paragraph below before following the instructions in the video — there are important caveats in the paragraph that I did not mention in the video. If your PaperPort 12 or PaperPort 14 is failing to start, or crashing, or hanging, …

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question